Z not homing with the probe.

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Z not homing with the probe.

This topic contains 3 replies, has 3 voices, and was last updated by  Jeff 2 days, 11 hours ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #103153

    Jeff
    Participant

    So I was testing out tool changes today and found a bug in my system. First off I’m using this spindle: https://www.amazon.com/Spindle-Cooled-Milling-Converter-Engraving/dp/B01LNBOCDA  hooked into a Noma power bar, separate from my MPCNC power, different wall outlet and all, possibly same circuit (haven’t started shutting off breakers to find out). The initial home would go fine, x, y, then z, the job would start(This was done with the spindle power not plugged in). Up came a tool change, stop the spindle, flick the switch to power the spindle off(safety first), change the bit and hit resume. Z would start to home with the probe attached, but as the axis was going down it would act as if it hit the probe and then wait for me to remove the probe wire and continue the job. Weird. So I started messing around to find the issue. It would seem that when the power supply was plugged into the power bar it wouldn’t home properly. Once removed it would. So I moved the power to the same power bar as the MPCNC and sure enough problem solved.

     

    I just thought I’d put this out there incase anyone else might run into this problem and are chasing their tails like I was.

    1 user thanked author for this post.
    #103342

    grishien
    Participant

    Jeff, not sure what exactly you blame for the problem.

    What factor did solve your problem actually?

    • This reply was modified 3 days, 23 hours ago by  grishien.
    #103354

    Barry
    Participant

    Moving the spindle power to the same power strip as the rest of the machine.  Probably had a ground loop.

    #103478

    Jeff
    Participant

    Yes as Barry pointed out, moving the spindle to the same power supply did fix the problem I was having. But I have not tried different power bars as of yet. The power bar I’m using right now is run through my e-stop and I’m not to sure if I want to have everything run through that as I’m worried about the current limitations of the switch.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.