Z Drop on print from fusion 360

New Home Forum LowRider Troubleshooting – LowRider Z Drop on print from fusion 360

This topic contains 5 replies, has 3 voices, and was last updated by  Greg 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #97005

    John
    Participant

    Hi Still very new to CNC i just finished my lowerider last week. A did the rest with the crown it worked fine both drawing and cutting it out. So i switched over to fusion 360(also new to it) and made a simple  little pig but when i load it and it starts to cut when ever it lifts the Z only one side raises and it looks like the other side drops like its turning off the stepper on just one side so it drops while the other side lifts so i went back cut out he crown from scratch and worked fine. I will link my g code for the pig. I am using the MarlinV1/MPCNC_Fusion360_V6_SDcard post processing i found on the forums. Let me know if you think a vid would help. Thanks alot

     

    ;pigtest
    ;T1  D=3.175 CR=0 - ZMIN=-10 - flat end mill
    N10 G90
    N15 ;Units in mm
    N20 G92 X0 Y0 Z0
    N25 M84 S1800 ;Change Stepper disable timeout to 30 minutes
    N30 G1 Z10 F2000 ; Lift Z 10mm to avoid dragging to first operation
    
    ;2D Contour6
    N35 M106
    N40 G1 X43.786 Y75.22 F2000
    N45 G1 Z10 F2000
    N50 G1 Z5 F2000
    N55 G1 Z2 F333.3
    N60 G1 Z-0.683 F333.3
    N65 G1 X43.793 Y75.218 Z-0.753 F333.3
    N70 G1 X43.815 Y75.209 Z-0.82 F333.3
    N75 G1 X43.851 Y75.196 Z-0.88 F333.3
    N80 G1 X43.898 Y75.178 Z-0.931 F333.3
    N85 G1 X43.954 Y75.157 Z-0.969 F333.3
    • This topic was modified 2 months ago by  John.
    #97014

    BT
    Participant

    As a first guess, your z-axis is moving too fast – 2000 mm/min when it should be something less than 900 mm/min – and probably losing steps on the one side.  There’s probably a setting in the post-processor for this.

    Also, is that the post-processor linked on Ryan’s milling basics page (https://github.com/guffy1234/mpcnc_posts_processor)?

    1 user thanked author for this post.
    #97023

    John
    Participant

    Yes it is ok i will check that

    #97046

    John
    Participant

    Ya that is what it was Thanks alot. Do you use fusion 360 what settings seam to work the best for 2d cutting

    #97090

    BT
    Participant

    I’m sorry, I don’t use Fusion360 for CAM, I use Estlcam.

    #97135

    Greg
    Participant

    I updated my max acceleration and feedrate in the firmware so it’s not possible to cause the Z steppers to skip.  I noticed the problem trying to jog from cnc.js as well so might as well fix it at it’s source.

    I set max feedrate to 6 and max acceleration to 25.. haven’t seen any skipping since.

    I think the gcode M203 Z6 should temporarily change the max feedrate if you’re not comfortable doing firmware stuff.

    • This reply was modified 2 months ago by  Greg.
Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.