Z-axis shifts up or down more than it should

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Z-axis shifts up or down more than it should

This topic contains 11 replies, has 2 voices, and was last updated by  Glenn 11 months, 2 weeks ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
  • #28696


    While cutting foam with DW660 on tower, doing the intermediate training left side.

    The Z-axis is shifting to far up or down, but only sometimes.

    Sometimes when getting set for the next layer the Z stepper drives to far.
    ie gcode:
    G01 X17.8000
    G03 X13.6950 Y106.0841 I0.0020 J-6.5295
    G01 X13.8957 Y105.8381
    G00 Z21.0600
    G00 X13.2117 Y10.1119
    G00 Z13.5600
    G01 Z10.0600 F180
    G01 X31.4949 F900
    G01 X32.9917 Y11.5406
    G01 X11.4127

    Z ended up around 16.00 actual

    or here:

    G01 X17.6013 Y98.6944
    G01 X20.8950
    G01 Y100.1231
    G01 X18.2362
    G00 Z21.0600
    G00 Z5.6000
    G01 Z2.3000 F180
    G01 X17.9461 Y100.2521 F900
    G01 X18.0775 Y100.5479
    G01 X18.1000 Y100.5625
    G01 X21.2125
    G01 Y32.7875

    Z ended up around -10.00 actual

    Allthread to stepper connector is tight.

    Stepper just seems to drive to far at times?

    Also seems that the gcode generated by Estlcam likes the move Z around alot.
    Is that normal or necessary?



    What version, because you are missing z rapid speeds.

    Z axis problems? Software Updates

    EstlCam Basics



    Estlcam 10.011



    For some reason you don’t have a z rapid in you code. Double check it is in your settings.



    Thought that I had done that? But they were blank. dang.
    On the tool list, looks like I need values in the finish feed rates also.

    Than you mister Vicious … again!



    Working great now.



    Sweet, I know this kind of thing is very frustrating but you gotta love it when it’s a relatively simple fix!



    Simple for me. But I bet you spent a bunch of ttime figuring it out.



    Shoot we all used it as is for a year…the coming of RC8 made it worse. It was a giant group effort, but it was only 2 or three days of before both estlcam and the fusion post processor were fixed up and the machine worked even better than before.



    So now I am trying to use SketchUp and SketchUCam for Gcode.

    I notice, before I cut, that there is no Z rapid limits in the code.

    Do I need to manually put it in?



    You should really stick with estlcam or fusion with our post processor. Almost all other CAM depend on the firmware for rapid limits or treat all three axis with the same speed.

    Other controllers have a rapid command built in, our ramps doesn’t do it that way, yet.



    The other day I noticed that the back bearings on the tower, the bolts that were left very loose, were not in contact with the gantry tubing.

    I tightened all 4 bolts up until a 3 bearings in each group were fully contacting the gantry tubes. Now the load on the bearings seems to be helping the Z stepper support the gantry.

    So far no Z slips with a Z transit speed of 480mm/min

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.