Z axis only moving in one direction

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Z axis only moving in one direction

This topic contains 30 replies, has 3 voices, and was last updated by  Silverback94 2 years, 8 months ago.

Viewing 30 posts - 1 through 30 (of 31 total)
  • Author
    Posts
  • #25759

    Silverback94
    Participant

    Okay this is a weird one for me I have had my MPCNC for a while now I bought all of the electronics and belts and screws and so on from you and I must say I have had a ball using this thing. From printing to etching and now I’m trying out my hand at routing and out of no where the Z axis won’t move in both directions. I have changed the ramps board, arduino, stepper controller, updated the firmware and even changed out the stepper motor. for the life of me I can’t figure it out.

    Help!

    Silverback94

    #25761

    Ryan
    Keymaster

    Use the RC7 firmware, and test with manual movements from repetier. If that works it’s a gcode issue if that doesn’t work we can leave gcode out of it.

    #25762

    Silverback94
    Participant

    Sorry I should have been more specific, that is the version that I updated to and I was trying manual movements cause my first thought was gcode as well.

    #25763

    Ryan
    Keymaster

    check your z endstop port. If it is triggerd somehow it will only move one way.

    #25768

    Silverback94
    Participant

    Well that’s the funny thing, if I click on the Z up the motor goes down if I click on the Z down the motor goes down until it hits the endstop then it quits. Now if I flip the wires on the motor connector and do the same thing the motor moves in the opposite direction but it won’t move in both directions just one depending on how I plug it in???

    #25770

    Ryan
    Keymaster

    Oh you are using endstops…check your firmware settings there are multiple things you need to adjust.
    Sorry but I don’t support endstops because of this. You have a min and max setting, direction setting, safety setting, home direction setting, home speed setting, bump setting.

    #25771

    Silverback94
    Participant

    Ah ha I am used to the older version with just the true/false statement on the min. let me check those out and I will let you know.

    And thank you very much for the help.

    #25778

    Silverback94
    Participant

    well I disabled endstops altogether and it still only moves in one direction

    #25779

    Silverback94
    Participant

    Here is my config.h file

    Attachments:
    1. Configuration.h
    #25783

    Ryan
    Keymaster

    Use my firmware and physically unplug them and see what happens.

    #25790

    Silverback94
    Participant

    I get this when I try to upload

    exit status 1
    using typedef-name ‘fpos_t’ after ‘struct’

    #25796

    Silverback94
    Participant

    this is the ver. im trying B16_32_fullG-112515

    #25804

    John
    Participant

    I ran into that error at one point also. You can rename that variable throughout the code, to something other than fpos_t like fpos_t1 or fpos_tbacon for example, and then save and compile.

    Found my answer here originally
    http://forums.reprap.org/read.php?146,691608

    Cheers,
    John

    #25922

    Silverback94
    Participant

    Thank you John, It’s going to be a couple of days before I can try it out but I will let you know.

    #26024

    Silverback94
    Participant

    Well here is the update, I have brought the mega and the ramps into the house along with a power supply and a stepper for the z axis. In response to Johns post I did get the B16_32_fullG-112515 version to load by changing the fpos_t to fpost instead of fpos_t1 after looking trough the forum he suggested that seemed to work better. Now I did not change any settings in the firmware just loaded it and tested with repetier manually moving the z axis and I still have the same problem, if I move the stepper to x or y it functions normally???

    #26028

    Ryan
    Keymaster

    I don’t believe changing the firmware was the best of options. This is not a common issue around here.

    What manual speeds are set in your repetier?

    #26029

    Ryan
    Keymaster

    the firmware you are using is also an old one. If you use the newer RC7 I have a feeling it would compile properly for you. either comment out the lcd or install the lcd library. as soon as the nest working reviosn comes out I will put up another non lcd version.

    #26031

    Silverback94
    Participant

    I didn’t have a problem with the RC7 compiling I only went back to the old one after you posted this “Use my firmware and physically unplug them and see what happens.” I thought that’s what you meant, no problem though i will go back to RC7 and see what happens. the manual speeds are set to; Travel feed rate 500 and z axis feed rate 100.

    #26032

    Ryan
    Keymaster

    the z axis can only go 8mm/s

    #26033

    Ryan
    Keymaster

    and the x and y are maxxed at 190mm/s, but 80 is more reasonable

    #26034

    Silverback94
    Participant

    still only moves in one direction

    #26035

    Ryan
    Keymaster

    still sounds like your z enstop pin is shorted.

    Disable them in the firmware and that should make it work.

    if it is only going down and makes a noise trying to go up you have to much friction in the system, if it make no noise at all it is an endstop issue.

    #26036

    Ryan
    Keymaster

    but if you bought it from me I actually test the endstops for shorts so it should not be the issue, unless you sorted the pins when you put on your ensdtops. either way disable them in the firmware and I am confident that will sort it out.

    #26037

    Silverback94
    Participant

    I don’t even have it attached to the machine, and the endstops are disabled, I even just now tried using the LCD control panel to move the z axis up and down and it only moves in one direction, I don’t know what the heck is going on with this thing…

    #26038

    Ryan
    Keymaster

    The pins can be shorted. I suggest you disable them in the firmware. My firmware has them enabled by defualt. The pins, solder points, or mega can be the endstop issue but disabling them in the firware should fix it.

    I can give you all kinds of options to try but I prefer to eliminate the most likely issues one at a time in order.

    #26039

    Silverback94
    Participant

    yes they are disabled in the firmware

    #26043

    Ryan
    Keymaster

    I feel we have bee through all of this.

    1-flip the plug, if it moves the other way it is not mechanical.
    2-swap drivers, if it still doesn’t move
    3-check to make sure all pins are in the drivers and in the ramps to arduino.
    4-disable the endstops in the firmware
    5-maybe your mega died

    #26044

    Silverback94
    Participant

    1-flip the plug, if it moves the other way it is not mechanical. I moves the other way so doesn’t seem to be mechanical.
    2-swap drivers, if it still doesn’t move one of the first thing that I did and didn’t change anything.
    3-check to make sure all pins are in the drivers and in the ramps to arduino. Done and Done
    4-disable the endstops in the firmware Done and Done
    5-maybe your mega died Changed out the Mega and same problem.

    #26046

    Silverback94
    Participant

    Fixed it!!!

    #26048

    Ryan
    Keymaster

    what was it?

Viewing 30 posts - 1 through 30 (of 31 total)

You must be logged in to reply to this topic.