Z axis moves on autohome

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Z axis moves on autohome

This topic contains 10 replies, has 4 voices, and was last updated by  Bill 1 week, 3 days ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #109157

    Ryan
    Participant

    Ok so I have the machine up and running, flashed the board for the dual endstops and send the m119 code and it shows the endstops as open. When I press home on Repetier, the only thing that moves is Z in the + (up) axis.

    #109166

    Chris
    Participant

    you need to wire the limit switches as normaly closed. the 2 outside pins. and z min is open.

    • This reply was modified 2 weeks ago by  Chris.
    #109188

    Ryan
    Participant

    you need to wire the limit switches as normaly closed. the 2 outside pins. and z min is open.

    I have the 2 outside pins connected, but they are normally open as recommended from the site.

    For the safest configuration the endstops should be wired in the Normally Closed position (NC), to prevent wire disconnects from damaging the machine during the homing sequence.

    I don’t have any endstop for the z. Are you saying to just put the pins on the RAMBo board even though not connected to anything?

    #109191

    Barry
    Participant

    No, don’t hit the home button.  Use the home x and home y buttons only.  Z will always be a moving target because the work piece will always be a different thickness. They should be normally closed.  If you found something saying open let us know so it can be fixed.  The z endstop will be a touch plate.

    • This reply was modified 2 weeks ago by  Barry.
    #109197

    Ryan
    Participant

    It should work without a touch plate though correct? I don’t have one yet.

    #109198

    Ryan
    Participant

    No, don’t hit the home button.  Use the home x and home y buttons only

    When pressing either of those, the Z axis still goes up and nothing happens on the X or Y axis. I have to press emergency stop to get the Z to stop

    #109200

    Barry
    Participant

    Did you rewire the end stops?

    #109204

    Ryan
    Participant

    I tried to print the crown and same thing happens. Z axis just continues to move upwards.

    #109205

    Ryan
    Participant

    I have them wired as originally wired following the V1 instructions on the website. NC position.

    #109207

    Ryan
    Participant

    12:27:03.294 : start
    12:27:03.294 : echo:Marlin bugfix-2.0.x
    12:27:03.312 : echo: Last Updated: 2018-01-20 | Author: (V1 Engineering, Ryan, 402)
    12:27:03.312 : echo:Compiled: Aug 10 2019
    12:27:03.312 : echo: Free Memory: 3339 PlannerBufferBytes: 1488
    12:27:03.316 : echo:EEPROM version mismatch (EEPROM=? Marlin=V64)
    12:27:03.320 : echo:Hardcoded Default Settings Loaded
    12:27:08.919 : FIRMWARE_NAME:Marlin bugfix-2.0.x (Github) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:V1 E CNC EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    12:27:08.919 : Cap:SERIAL_XON_XOFF:0
    12:27:08.919 : Cap:BINARY_FILE_TRANSFER:0
    12:27:08.919 : Cap:EEPROM:1
    12:27:08.919 : Cap:VOLUMETRIC:1
    12:27:08.919 : Cap:AUTOREPORT_TEMP:1
    12:27:08.919 : Cap:PROGRESS:0
    12:27:08.919 : Cap:PRINT_JOB:1
    12:27:08.919 : Cap:AUTOLEVEL:0
    12:27:08.919 : Cap:Z_PROBE:0
    12:27:08.919 : Cap:LEVELING_DATA:0
    12:27:08.919 : Cap:BUILD_PERCENT:0
    12:27:08.919 : Cap:SOFTWARE_POWER:0
    12:27:08.919 : Cap:TOGGLE_LIGHTS:0
    12:27:08.935 : Cap:CASE_LIGHT_BRIGHTNESS:0
    12:27:08.935 : Cap:EMERGENCY_PARSER:0
    12:27:08.935 : Cap:PROMPT_SUPPORT:0
    12:27:08.935 : Cap:AUTOREPORT_SD_STATUS:0
    12:27:08.935 : Cap:THERMAL_PROTECTION:1
    12:27:08.935 : Cap:MOTION_MODES:1
    12:27:08.935 : Cap:CHAMBER_TEMPERATURE:0
    12:27:08.935 : X:0.00 Y:0.00 Z:0.00 E:0.00 Count X:0 Y:0 Z:0
    12:27:08.935 : echo:DEBUG:INFO,ERRORS
    12:27:08.935 : Begin file list
    12:27:08.935 : End file list
    12:27:08.935 : echo:Unknown command: “M80”
    12:27:08.950 : echo:DEBUG:INFO,ERRORS
    12:28:16.034 : Reporting endstop status
    12:28:16.034 : x_min: open
    12:28:16.034 : x2_min: open
    12:28:16.034 : y_min: open
    12:28:16.034 : y2_min: open
    12:28:16.034 : z_min: open
    12:28:16.034 : z_max: open

    #109568

    Bill
    Participant

    It looks like you might be running the default Marlin build instead of Ryan’s version…

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.