Z-axis MOVEMENT not correct

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Z-axis MOVEMENT not correct

This topic contains 8 replies, has 2 voices, and was last updated by  Zach K. 2 months, 3 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #94349

    Zach K.
    Participant

    I recently changed my z-stepper motor because I messed up the wires on my old stepper motors. I some how managed to rip them by the stepper motor and was impossible to fix.

    The problem I am having is for every 10mm its moving about 2mm.

    I purchased 17HS19-2004S1 stepper motor from amazon.

    The last stepper motor worked perfectly fine that I had.  I even reflasehed the board. I put the motor on the x axis for drivers and still wasn’t moving the correct amount. I have all the settings all the same as provided I don’t know what to do.

     

     

    Speces for 17HS19-2004S1

    Electrical Specification:

    * Manufacturer Part Number: 17HS19-2004S1
    * Motor Type: Bipolar Stepper
    * Step Angle: 1.8 deg.
    * Holding Torque: 59Ncm(83.6oz.in)
    * Rated Current/phase: 2.0A
    * Phase Resistance: 1.4ohms
    * Inductance: 3.0mH+/-20%(1KHz)

    Physical Specification:

    * Frame Size: 42 x 42mm
    * Body Length: 48mm
    * Shaft Diameter: 5mm
    * Shaft Length: 24mm
    * D-cut Length: 15mm
    * Number of Leads: 4
    * Lead Length: 1m with connector
    * Weight: 390g

    Connection:

    Black(A+), Green(A-), Red(B+), Blue(B-)

    Warning:

    Make sure the motor connect to a constant current or chopper drive controller before you test motor.
    Connecting the motor directly to a power supply will destroy the motor

    #94350

    Ryan
    Keymaster

    A 5x difference is a really weird number, that is not a typical issue. It sounds fine and moves smoothly, just not enough?

    #94351

    Zach K.
    Participant

    Correct my driver is set right about .7 volts. And its depth is off when I manually move and also when I run a program.

     

     

    I noticed the guy on this forum link was seeming to have the same issue but some how his just randomly resolved itself.

    z axis not moving correct amount

     

     

    #94352

    Ryan
    Keymaster

    Did you correct or change the Z steps when you reflashed it? This would explain a 4X difference by 5X is not typical, are you guessing at that difference or can you measure it?

    #94358

    Zach K.
    Participant

    I did not hange anything do I need to change something when I flash it

     

    #94361

    Ryan
    Keymaster

    I did not hange anything do I need to change something when I flash it

    I have no idea what hardware or firmware you are using.

    From that video I have no idea what amount you told it to move.

    #94363

    Zach K.
    Participant

    I have ramps 1.4  flashed for dual endstops Latest version.

    I moved 10 mm the max z axis reptier host allows without manual command. Didn’t have video showing the software because video was too long otherwisse and wouldn’t upload. So I move 10mm and it only oved not quite even 2mm

    #94365

    Ryan
    Keymaster

    Check the z steps, the new firmware (from github) is set for a leadscrew, if you do not have a leadscrew you need to change it. Drivers, step rate also a factor. I will check back in a few hours after I prep shipping.

    #94366

    Zach K.
    Participant

    Thats got to be it I believe I am using a 5/16 rod yet. Is there a place that shows me eveything I need to change in the firmware. Or do you think it’d be best to just change it to the leadscrew?

    Thanks

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.