Z axis is slipping on one side

New Home Forum LowRider Troubleshooting – LowRider Z axis is slipping on one side

This topic contains 19 replies, has 9 voices, and was last updated by  Coinbird 1 week, 1 day ago.

Viewing 20 posts - 1 through 20 (of 20 total)
  • Author
    Posts
  • #108541

    TJ
    Participant

    My new machine is running great except for one problem:  the z axis is occasionally dropping down on one side. I’ll start a cut and make sure its level (its often not), and then 10 minutes into a cut it’ll be uneven. Most recently the cut was ruined because the router assembly dropped all the way down and got stuck on the board. Pictures of both sides attached.

    Its not slipping on the z tubes, it seems to actually be loose inside the stepper and just kind of drop with gravity (I can apply a few pounds of pressure from top and the vertical screw spins the z axis down on this side).

    Is there something I need to tighten, or is my stepper faulty? Or any other ideas?

    #108612

    Barry
    Participant

    Could be a loose wire.

    #108623

    Krzysztof Rygwelski
    Participant

    Im guessing that setscrews in couplers lose up. tight them up and use Loctite.

    #108627

    TJ
    Participant

    The set screws are tight, so that’s not it.

     

    #108631

    TJ
    Participant

    Update:

    It appears that when I connect from my laptop through repetier host, it resets the mini rambo. It’s at this time that the z-axis drops on one side (but never the other).  This is dangerous for my bit, but also gets me out of alignment everytime.

    So I thought that it sometimes got out of alignment during the run, but now I’m thinking it only happens when I connect, but sometimes it only drops part way, so I hadn’t noticed it right away.

    My understanding is that reset during connection is normal, is that correct?  If so, how do I prevent the stepper motor from letting the z-axis drop when I connect from my computer through Repetier Host?

     

    I’m not sure if this helps, but here’s the log when I connect and the z-axis on one side drops:

    13:58:40.026 : start
    13:58:40.032 : echo:Marlin bugfix-2.0.x
    13:58:40.033 : echo: Last Updated: 2018-01-20 | Author: (V1 Engineering, Ryan, 302)
    13:58:40.033 : echo:Compiled: Jul 31 2019
    13:58:40.033 : echo: Free Memory: 3639 PlannerBufferBytes: 1472
    13:58:40.034 : echo:Hardcoded Default Settings Loaded
    13:58:40.034 : echo: G21 ; Units in mm (mm)
    13:58:40.038 : echo: M149 C ; Units in Celsius
    13:58:40.039 : echo:Filament settings: Disabled
    13:58:40.039 : echo: M200 D3.00
    13:58:40.039 : echo: M200 D0
    13:58:40.039 : echo:Steps per unit:
    13:58:40.043 : echo: M92 X100.00 Y100.00 Z400.00 E100.00
    13:58:40.043 : echo:Maximum feedrates (units/s):
    13:58:40.047 : echo: M203 X120.00 Y120.00 Z30.00 E25.00
    13:58:40.047 : echo:Maximum Acceleration (units/s2):
    13:58:40.051 : echo: M201 X400.00 Y400.00 Z200.00 E2000.00
    13:58:40.055 : echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    13:58:40.055 : echo: M204 P400.00 R3000.00 T400.00
    13:58:40.059 : echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
    13:58:40.059 : echo: M205 B20000.00 S0.00 T0.00 J0.00
    13:58:40.059 : echo:Home offset:
    13:58:40.063 : echo: M206 X0.00 Y0.00 Z0.00
    13:58:40.063 : echo:Material heatup parameters:
    13:58:40.063 : echo: M145 S0 H196 B92 F0
    13:58:40.067 : echo: M145 S1 H240 B110 F0
    13:58:40.067 : echo:PID settings:
    13:58:40.067 : echo: M301 P17.98 I0.98 D83.62
    13:58:40.068 : echo:Stepper motor currents:
    13:58:40.071 : echo: M907 X900 Z900 E900
    13:58:40.216 : N1 M110*34
    13:58:40.216 : N2 M115*36
    13:58:40.216 : N3 M105*36
    13:58:40.216 : N4 M114*35
    13:58:40.275 : N5 M111 S6*98
    13:58:40.277 : N6 T0*60
    13:58:40.278 : N7 M20*22
    13:58:40.278 : N8 M80*19
    13:58:40.278 : N9 M105*46
    13:58:43.385 : N10 M105*22
    13:58:45.647 : N11 M220 S58*109
    13:58:45.650 : Cap:SERIAL_XON_XOFF:0
    13:58:45.651 : Cap:EEPROM:0
    13:58:45.651 : Cap:VOLUMETRIC:1
    13:58:45.652 : Cap:AUTOREPORT_TEMP:1
    13:58:45.652 : Cap:PROGRESS:0
    13:58:45.652 : Cap:PRINT_JOB:1
    13:58:45.654 : Cap:AUTOLEVEL:0
    13:58:45.654 : Cap:Z_PROBE:0
    13:58:45.654 : Cap:LEVELING_DATA:0
    13:58:45.654 : Cap:BUILD_PERCENT:0
    13:58:45.654 : Cap:SOFTWARE_POWER:0
    13:58:45.658 : Cap:TOGGLE_LIGHTS:0
    13:58:45.659 : Cap:CASE_LIGHT_BRIGHTNESS:0
    13:58:45.659 : Cap:EMERGENCY_PARSER:0
    13:58:45.659 : Cap:AUTOREPORT_SD_STATUS:0
    13:58:45.662 : Cap:THERMAL_PROTECTION:1
    13:58:45.662 : Cap:MOTION_MODES:1
    13:58:45.680 : N12 M221 S100*83
    13:58:45.695 : N13 M111 S6*85
    13:58:45.711 : echo:DEBUG:INFO,ERRORS
    13:58:45.712 : Begin file list
    13:58:45.712 : N14 T0*15
    13:58:45.712 : N15 M155 S1*84
    13:58:45.716 : End file list
    13:58:45.716 : echo:Unknown command: "M80"
    13:58:45.724 : echo:DEBUG:INFO,ERRORS

    #108647

    Dan Roesch
    Participant

    I don’t use Repetier but I rest my Lowrider on two cradles that keep it level and the bit off the work surface until I power things up and the steppers engage. Maybe that could also be a solution to your situation?

     

    Dan

    #108662

    Ryan
    Keymaster

    My understanding is that reset during connection is normal, is that correct? If so, how do I prevent the stepper motor from letting the z-axis drop when I connect from my computer through Repetier Host?

    Yes. Connect then position your router, or use and LCD and SD card.

    #117490

    Marjo (Belgium)
    Participant

    So it’s normal that one stepper of the z axis (every time the same one) falls down if a laptop is connected and repetier host is also connected? Or is it caused by a wirering or other problem?

    thanx

    Marjo

    #117499

    Barry
    Participant

    It happens.  Is the side that drops the side that the router is sitting at?  I’ve noticed in the past that the steppers will lock, then unlock when power is applied to the board.  Just for a second, which caused the leadscrew to lose it’s friction, then the weight of the router will push that side down.

    #117888

    Coinbird
    Participant

    I had this problem and didn’t actually notice it until today.

    Mini Rambo, firmware, and steppers shipped by Ryan.

    Today I re-routed my wiring through better plastic conduit, and put everything back together. I also had cut two new Y plates and had them cranked down fairly tight.

    Then, at the end of cutting a new part, the router side of my Lowrider v2 suddenly dropped down (lead screw and stepper spinning, collet was not slipping.) At first I thought I somehow messed up the wiring. After restarting and raising Z, it dropped again, and I found I could make the opposite side do the same thing by leaning on it with a little force on top of the motor.

    So, it appears that I had two problems:

    * Y Plate bearing screws were too tight, not allowing smooth up/down motion (power off, the motors should spin and the axis will bottom out)

    * I have a pretty heavy vacuum hose, and I had reoriented it so there was a few pounds of down force on that side of the Lowrider.

    I had seen a few misaligned cuts, with what I thought was X axis skipping, but now I think it was actually from the Z axis collapsing on one side, causing a diagonal cut (oval hole being one symptom.)

    My solution:

    * Loosen bearings on Y plates so the Z axis moves up and down without hindrance (gravity spins the motors)

    * Reorient my heavy vacuum hose so the weight isn’t bearing down on one side (10′ shop vac crush proof hose.) I propped it up on a sawhorse for now.

    * Slowed down Z travel to 2 mm/s

    * [Edit: See below, had to increase Drive Strength]

    So far so good. Made an absolutely perfect part this evening.

    Maybe this information will be helpful. I thought the Z axis could lift a lot, but I realized I had quite a bit of weight on it, when you add it all up!

    IMG_20191014_214443

    • This reply was modified 1 month ago by  Coinbird.
    • This reply was modified 1 week, 1 day ago by  Coinbird. Reason: Add note on drive strength
    #117906

    frosty
    Participant

    Are you Z steppers wired in series or parallel? Single driver or dual driver for Z? What is your current limit for the drivers?

    Z motors should be able to hold that weight, but only if you are giving the motors enough juice.

    #117916

    Greg
    Participant

    I had some issues with the default firmware max acceleration, feedrate and jerk settings for Z axis.  I had to lower them to ensure the Z axis never skips.

     

    #117920

    Coinbird
    Participant

    My Z is wired in series, plugged into the single Z axis on the mini Rambo (i.e. stock configuration.) Interesting that you lowered default feedrate/accel/jerk, I was hoping not to do that, but might give that a shot if I notice skipping again.

    #117969

    Greg
    Participant

    That is how mine is setup as well.. the big one to change is probably acceleration.

    I believe you can play with the values without updating the firmware by inserting some gcode before you print:

    http://marlinfw.org/docs/gcode/M201.html

     

    #117970

    Coinbird
    Participant

    Thanks for the tip. I think I can do it straight from the LCD and save the configuration. I’ll probably lower it a tiny bit just to be safe. I think I saw that video of a lowrider lifting some large weights and just assumed I’d be able to lift anything!

     

    Edit: also noticed that somewhat recently in the firmware notes, the defaults for the Z axis were lowered a bit

    • This reply was modified 1 month ago by  Coinbird.
    #117972

    Greg
    Participant

    Ahh I got my lowrider a year ago so might not apply anymore.  Also mine came with the EEPROM save disabled so not sure if it will be  save-able for you.   Even on 3d printers if you set the accel too high it can start skipping and they hardly have any weight at all.

    My max_accel for Z is set to 25 mm/s and max feedrate for Z is 6 mm/s which may be conservative but I just kept turning them down until I stopped getting missed steps when all the weight was on one side.  I’ve done lots of cuts since without issues.

    (you can also set max feedrate with M203).

     

    #117973

    Coinbird
    Participant

    Great. I was able to make it “slip” like the OP, during a long Z80 move (not accelerating at that exact second) so I will definitely drop the feedrate as well. I’m not in a huge rush, and pretty excited to have the 1 issue I was having be resolved.

    • One last thing I did was lower my ESTLCam Z rapid travel down to 350 (from 480 from the tutorial). Setup -> CNC Programs -> Rapid Feed Z

    Have cut a few parts since with zero Z axis issues. Very happy!

    • This reply was modified 1 month ago by  Coinbird. Reason: Add Z feedrate
    #120784

    Coinbird
    Participant

    Wanted to update this thread for future searchers, I discovered the Drive Strength setting in Marlin (under Configuration) and bumped up Z to 1200, up from 900. This seems to be able to lift the weight I’ve been putting on it.

    Pretty sure someone already mentioned checking that setting but for some reason I was afraid of raising it above 900.

    Could someone explain (mini Rambo) how I might determine what the max power setting might be for the Z axis? 1200 works great, just more of a curiosity (will 2000 fry the board?)

    I will probably rebuild the firmware with 1200 as default for Z, so I don’t need to remember to change it every time.

    Midway through another awesome project, will post soon…

    #120791

    Ryan
    Keymaster

    Two things happen when you up the power. The drivers get hotter and dissipate the heat on the underside of the board, at some point a fan is a good idea, and second the steppers get hotter at some point they can soften the PLA.

    With my equipment as is I do leave a lot of power on the table. It is okay to raise the current just keep an eye on temps.

    #120800

    Coinbird
    Participant

    Ah, thanks for the advice and what to watch out for. I’ll keep it just barely up to the point that prevents skipping and leave it at that, and keep an eye on temps so I don’t melt anything.  Worst case I can print new parts! 😄

Viewing 20 posts - 1 through 20 (of 20 total)

You must be logged in to reply to this topic.