Wiring for Dual End Stops

New Home Forum Mostly Printed CNC – MPCNC Advice – MPCNC Wiring for Dual End Stops

This topic contains 7 replies, has 2 voices, and was last updated by  James 1 month ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #63636

    James
    Participant

    Hey guys, I’m pretty new to all of this. I have the machine built and squared and have the Ramps 1.4 programmed. Before I wire it, I was wondering if I can run the steppers independently to the Ramps board and wire them individually like for Auto Square, but run it without the end stops. Basically I want to upgrade to the stops eventually but only want to make the harness once.

     

    Any tips are appreciated.

     

    James

    1 user thanked author for this post.
    #63638

    Ryan
    Keymaster

    Sure, just switch the logic for the endstops in the dual firmware or use jumpers on them to fake it until you are ready.

    #63640

    James
    Participant

    Is there a place in the firmware where I can just link the two drivers together?

    Edit: I just saw this on your site. ..

    Plugging In The Steppers

    Remapping of pins is used in the firmware to allow the use of all the control boards drivers. The unused extruder driver/s are used for the extra stepper/s.

     

    It looks like I can just remap the pins in the standard firmware and not mess with the Auto Square firmware until I’m ready?

    James

    #63644

    Ryan
    Keymaster

    Or…just use the regular firmware until you are ready.

    I don’t think I understand what you want. I read that as you wanted to use all 5 drivers so you didn’t have to run new wires, but you only want to use 3 like the standard firmware?

    #63646

    James
    Participant

    Yes. I didn’t know how to phrase it. I’d like each driver to be run separately to each stepper, than just link 2 sets in the firmware. I am unsure of the best way to set it up.

     

    James

    #63648

    Ryan
    Keymaster

    That is exactly what the dual end stop firmware is.

    #63649

    James
    Participant

    Cool. I will give it a shot. Thanks for the help.

     

    James

    #63650

    James
    Participant

    Also, I’m not sure if it’s just my computer, but the picture of the Ramps 1.4 that shows the connections for the end stops doesn’t show up.

     

    James

    1 user thanked author for this post.
Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.