When "Auto Home" Z Goes off the rails.

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC When "Auto Home" Z Goes off the rails.

This topic contains 6 replies, has 4 voices, and was last updated by  Jeffeb3 1 week, 5 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #119615

    BillM
    Participant

    Literally.

    V1 Engineering Dual End Stop Kit. When I Auto Home from LCD screen, Y & X home fine to their end stops, but Z just keeps moving up and literally moves beyond the lower bearings. Seems to be expecting Z end stops?

    How do I resolve this?

    Is it just a matter of commenting out the Z portions here in the configuration.h?
    // Specify here all the endstop connectors that are connected to any endstop or probe.
    // Almost all printers will be using one per axis. Probes will use one or more of the
    // extra connectors. Leave undefined any used for non-endstop and non-probe purposes.
    #define USE_XMIN_PLUG
    #define USE_YMIN_PLUG
    #define USE_ZMIN_PLUG
    #define USE_XMAX_PLUG
    #define USE_YMAX_PLUG
    #define USE_ZMAX_PLUG

    Thanks!

    #119616

    Ryan
    Keymaster

    You can not auto home without a Z stop of some sort. You can home X and Home Y if you have them or add it to gcode G28 X Y.

    #119618

    BillM
    Participant

    So that menu item for the LCD is not meant to be used? Is there any way to remove it? Or make it run only X & Y?

     

    #119620

    Victor D.
    Participant

    So that menu item for the LCD is not meant to be used? Is there any way to remove it? Or make it run only X & Y?

    There are two options for homing; in the “motion” menu and in the “custom commands” menu. The motion menu options homes x, y, and z; while the custom commands menu allows you to home x, y separate from z.

    Now, to answer your question, I’m sure there’s a way to remove the auto home from the motion menu but I’m not the best person to walk you through the process.  I know you can edit the custom commands in the configuration_adv.h file, just look for CUSTOM_USER_MENU but for the other menu items, someone else will have to chime in.

    1 user thanked author for this post.
    #119621

    Ryan
    Keymaster

    There is a custom menu item to home individual axis when you go in and input your machine size (“bed size”) you can enable it in the config_adv.

    1 user thanked author for this post.
    #119622

    BillM
    Participant

    Thanks Gents, appreciate the prompt replies!

    #119637

    Jeffeb3
    Participant

    This might br useful to give these homing items a more prominent location in the menu:

    https://github.com/MarlinFirmware/Marlin/blob/bugfix-2.0.x/config/default/Configuration.h#L1699

    I didn’t see any way to disable Z homing though. Grbl makes that possible, although it’s a bit confusing for non-programmers.

    1 user thanked author for this post.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.