Unable to properly calibrate Z axis

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Unable to properly calibrate Z axis

This topic contains 8 replies, has 3 voices, and was last updated by  Ryan 1 month ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #35468

    Brad Payne
    Participant

    I am using Estlecam with my MPCNC and I have calibrated my X and Y directions, however, I can not get Z into calibration. When I move 1″ in Estlcam, my z axis moves about 5/8″.

    I have tried adjusting my “Distance Per revolution” but my calculations (I dont have them in front of me) require me to set the Distance per revolution so small that I get an error about the frequency being over 160hz.

    Has anyone else had this issue and have a way around it? I’m using 5/16″-18tpi rod for my Z axis.

    Thanks in advance for any advice.. I’m so close and I can’t wait to cut!

    #35494

    Ryan
    Keymaster

    Have a look in the estlcam thread I believe I have the settings in the second post, we have to go less than 32nd stepping to stay under the limit. You need to remove jumpers.

    #35507

    Brad Payne
    Participant

    Geez. If it were a snake it would have bit me.. I never noticed the software forum at the bottom.. Thanks!

    #51412

    Ryan
    Participant

    I just did my fist test print of the calibration boat. The X and Y axis are bang on but the Z axis is stretched almost twice what it should be.

    Here are the steps per unit as set in the config file.

    #define DEFAULT_AXIS_STEPS_PER_UNIT { 200, 200, 4535.44, 200 } //MPCNC

    I’m using the 5/16 threaded rod for the Z axis. Could my stepper motor be giving more steps that is expected or do I have the wrong axis steps per unit? I have all three jumpers on the ramps board for the Z axis. Is that correct?

    Thanks for your help.

    #51413

    Ryan
    Keymaster

    What drivers?

    #51414

    Ryan
    Keymaster

    Actually it would be best to start your own thread with all your machine and software specs.

    #51415

    Ryan
    Participant

    I’m using drv8825 on the X and Y axis. I used an a4988 on the Z because I fried one of the original drv8825s. That explains what’s going on.

    What should the setting be for an a4988?

     

    I also used an a4988 for the extruder.

    #51416

    Ryan
    Keymaster

    1/2 that of the drv, you are in 16th stepping with all three jumpers on that one.

    #51418

    Ryan
    Participant

    Got it. Thanks.

Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.