Trouble with Z axis raising above material plane between cuts

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Trouble with Z axis raising above material plane between cuts

This topic contains 71 replies, has 7 voices, and was last updated by  Robert Norris 9 months, 2 weeks ago.

Viewing 30 posts - 1 through 30 (of 72 total)
  • Author
  • #31868

    George Kriete

    Hello All,

    Love the machine, loved building it.

    I build a full complete kit from MPCNC.

    It went together nice, following the directions.

    I am running Widows7, Estlcam 10.
    The control panel in Estlcam moves the Gantry in all the correct directions.
    I built it 40″X40″, which gives me about 29.5″ square cutting area. 5″ legs, and a 12″Z Axis.

    When I practiced with the pen attachment, Z did not raise off paper between line sections.
    Then I tried to put my dremel on the Gantry, all snugged up.
    I am saving for the Dewalt router.

    Tried practicing on a piece of foam board. Still Z is not raising above the plane of the material.
    I set the Z axis to zero with the tip of the bit touching the top of the foam.
    It goes down a little and begins the design.
    never lifts above the top of material.

    I saw in the Estlcam instructions to reverse the Z direction.
    When I tried that the control panel move Z in the opposite direction,
    When I run/ machine the design it lifts up and never touches the material at all.

    Please help me, I am sure it is just an ID10t error on my part. probably just one small thing I am missing.

    Some pictures enclosed below.

    Thanks in advance for any and all help
    George in NEPA



    That is usually how it behaves if it has an endstop on it wired incorrectly.


    George Kriete

    I do not have end stops on my machine.

    this is a really cool machine, but I need help getting it to work correctly.



    In Estlcam, under Basic Settings, what do you have in the Clearance plane box?


    Dalton Porter

    All of my Z-axis issues thus far have been due to a loose connection between the stepper and wiring harness. Black tape didnt work for me so I used a zip tie as shown inthis post.


    Robert Norris

    Hi . I have the almost the same problem did you resolve it , the z axis seem to move a fraction like a micro movement , are you trying in estlecam or using nc file in repetier host .


    Robert Norris

    PS . i have 6mm clearance in ectlcam , when i connect in repetier host the connectbutton stays green and it sounds sound like a click but ant move manualy in program . please any help , so close yet so far lol



    How fast are you trying to move it, have you lubed the screw, checked for any interferences?

    Those are the top three issues in order or occurrence.


    Robert Norris

    the z axis moves with manual control in estlcam but when trying to do a test piece with a pen it only moves a fraction . x and y work fine . have set max z speed to 8 mm per second


    Robert Norris

    don’t understand why when in repetier host it clicks but wont move on any axis i have set all settings as you have stated in basic set up in repetier host and light is green on connect icon. in estlcam x and y work fine but z axis moves a tenth if that of what it should be . frustratingly close now .



    I am not clear on the issue. If you are using estlcam to control the machine it is a different story. If you are using repetier I can easily help you. You can’t use both.

    What firmware are you using?


    Robert Norris

    the issue is the mpcnc seems to do very little in repetier host , mpcnc just clicks once when connected and light is green. so i tried your full logo in estlcam worked but z axis not moving just tiny 0.1mm movements so pen wont leave paper . in estlacm the manual moment on all axis work in rh nothing . just want to get one to work . im happy to use repetier could not get to work so tried estlcam thats all . apologies as a noob to this set repetier setting as stated in tutorial resistor in place


    Robert Norris

    i bought kit from you so flashed already , got ardunio, repetier host , estlcam on laptop



    Here is my normal workflow…
    I load a picture (dxf) in estlcam. Pick my bit/tool.
    Then I use estlcam to generate the path for the tool to follow.
    Then save off the path to an .nc file.
    The I switch to repetier host and connect to the machine
    Then load the .nc file that estlcam saved
    Then power the router and hit play/start in repetier host…

    Is that the sequence you are following?

    Here’s the other question that springs to mind…
    estlcam has an option to download firmware to the Cnc… did you happen to do that? That firmware isn’t (to my knowledge) able to control the mpcnc completely yet.


    George Kriete

    In the Basic Setting in Estlcam v10, my Clearance Plane is set to 5.00mm.
    I think that is how it was I do not remember changing it.

    What should it be?


    George Kriete

    I am using Estlcam v10. The control panel in program moves all the X, Y, and Z fine and in the right directions.
    When I save as a program and click machine program, the preview pops up and if I use the tilt view arrows it looks like it is lifting high enough above the work piece.
    Then I click OK and the control panel pops up with the program loaded and I click the play/ run button on bottom right and it moves in X and Y correctly, but Z is not going up and down as it should.
    It does not lift up and the bit cuts along as it moves to the next section to be cut.
    So I have these cuts along the same paths that it shows in the preview.


    George Kriete

    As far as how fast am I how fast am trying to move it.
    I just selected the bit from the tool list and then selected the type of cut I want to make. I have not set any speeds. I thought it was set by selecting the bit. it shows numbers in the boxes for that bit.

    Yes I have greased the screw. That was in the instructions.

    I am not sure what interference you are referring to.
    All the wire harnesses move freely.


    Robert Norris

    George im sorry for jumping on your thread but it seems like we have the almost the same problem i did update the firmware in estlcam so will i have to re flash firmware ?


    George Kriete

    I checked my wire harness plugs On Z and the plugs are still very snug together with the electrical tape.
    I will keep this in mind if I have an issue in the future.



    Sounds like you both are using the estlcam firmware. I don’t have enough experience with it to really understand what could be happening.

    It would be best for you both to re-flash your arduino’s back to my firmware.



    Robert Norris

    thank you will try this , sorry again for jumping thread , thanks for all your hard work.


    George Kriete

    I am sorry I do not understand.
    What did Estlcam flash, you said it flashed Estlcam firmware.
    If I reflash the Arduino board with your firmware. Then use Estlcam, wont this then happen again.
    I never flashed anything to the Ardunio board.
    It should have been flashed before you shipped it out.
    You recomend using Estlcam as one of the programs to work with MPCNC.

    Please help me to get this resolved.

    I spent most of my day off yesterday going over all the replies to my post. Went and checked each suggestion. Nothing helped.
    The only one I did not check was the swapping Z with either X or Y.
    I was not sure what to do. If I just swapped the wires, I did not want to damage the Z frame, X and Y have a lot more movement.
    I tried to pull the ramp off the board, did not want to break it, in real snug.
    the whole unit came assembled. All I put on was the one jumper with a diode on it on the jumper pictured.


    George Kriete

    I do not have a problem with you jumping in.
    Our problems are similar. Maybe you explained something better than me to get the answer.
    I went over all but one reply and still not running right.
    Back to work today. will try more when I get some time, in a few days.
    Big project at work, a lot overtime right now, grabbing every minute I can.

    1 user thanked author for this post.

    First thing: check your pineapple coupler. It often happens that this thing get loose, then the Z axis doesn’t move up.
    Then, you seem to have checked already your clearance plane. What happens if you set a very high value, like 30mm?
    What is your Z-axis origin in Estlcam? it should be set to “workpiece top side”
    The CNC program start should be set “at clearance plane”
    What speed did you setup your Z axis? Try a lower speed, it is possible that you set up too high speeds and then your motor loses steps

    One of these things should solve your problem, hopefully
    Good luck, let us know how it worked šŸ™‚


    Robert Norris

    When setting up estlcam there is a bit that says do you want to connect with ardunio I thought it downloaded drivers but now believe it reflashed ardunio.will try reflashing at weekend. Let you know x, y and z work fine z works manually in estlcam but not when cuting also not connecting properly with repetier host I assume it has reflashed it. Hope this makes sense.



    Does your workflow look like this?

    EstlCam Basics

    Pay particular attention to steps 6 and 7.

    George it was flashed prior to shipping, it appears you did things to flash estlcam’s firmware on the board. Most likely you are not doing steps 6 or 7. This never used to happen because it was incompatible, now it is meaning you can flash it, if you do things differently. You could prevent this by doing all of this without the board plugged in when you generate your gcode. You will most likely need to reflash the board. It is a very easy process and I have it all laid out step by step with screenshots.

    2 users thanked author for this post.

    George Kriete

    OK so I need to reflash the Arduino board.
    Your post says there are step by step instructions with screen shots.
    Please send a link to where it is.

    Then I make the code in Estlcam, with machine not plugged in and run program in repetier host to cut design.

    Thank you for the help. I hope this works, I am so excited to make stuff.
    I have several people ask me to make stuff when I learn how to use it.



    The link eight posts above titled Firmware.

    1 user thanked author for this post.

    George Kriete

    I am sorry. I must be really bad at this.
    You said I need to create to program in Estlcam with MPCNC unplugged.
    Then Save the program. Close Estlcam.
    Open Repieter Host. load program.

    So I download Reipter Host from link.
    Install it open it and it seems to me that it is for 3D printers.
    I am not following. How do I set Repieter Host to commicate with the Arduino board to cut and carve on my CNC machine.

    If Estlcam v10 will not run/control CNC, wil Estlcam v9 work.
    I am getting frustrated. Just want to make stuff. Spent too much time and money for this not to work right.

    I really need help.



    Step by step with text and pictures,

    Step by step in video form (he has many other step by step videos as well),

Viewing 30 posts - 1 through 30 (of 72 total)

You must be logged in to reply to this topic.