Trouble getting proper movement.

New Home Forum ZenXY Troubleshooting – ZenXY Trouble getting proper movement.

This topic contains 3 replies, has 3 voices, and was last updated by  Jeffeb3 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #106573

    Tim
    Participant

    Okay so I have my table mostly setup, but I’m just struggling a bit with the correct motor polarity and wanted to check on a few things to make sure I’m not crazy.

    When I power on the RAMPS board and use the “Motion” section on the LCD to move, things work as expected (positive x goes to the right, away from the endstops, and positive y goes further back away from the motors).

    However, when I use the “Home” function on the LCD, it does not move Y first, it crashes and keeps trying to run indefinitely in both -X and -Y. The switches do register as triggered when depressed using M119 gcode.

    Also, I’m not sure if sandify is supposed to auto-home first, but every sandify gcode I’ve tried to load, and the device takes off in the +X and +Y direction indefinitely and crashes into the maximum extents. Does sandify try to home first? If so, why does homing with gcode go the opposite direction of homing from the LCD?

    Do I have something flipped around on one of my motors?

    #106577

    Ryan
    Keymaster

    Have you tried using repetier host?

    I can not think of any reason it would do that if everything you said is correct, other than we don’t use the home button because we don’t have a Z endstop.

    #106581

    Tim
    Participant

    Thanks for the quick reply. I’ll try swapping around the connectors a few more times and then take a video if I can’t figure it out.

    #106588

    Jeffeb3
    Participant

    I just do them manually:

    G28 Y
    G28 X

    Like Ryan said, there is no Z so the regular homing won’t work. You can set the homing order in the firmware, amd you might even be able to disable Z to make G28 work.

    Sandify won’t do any homing unless you put it in the starting gcode section. If you start the machine with the magnet in the middle, it’s going to think that is 0,0. If you told sandify that you have a 500x500mm bed, then the pattern will start near 250, 250. So either figure out the homing or start the machine at the hone position.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.