Trouble converting .dxf to .stl using estlcam

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Trouble converting .dxf to .stl using estlcam

This topic contains 6 replies, has 3 voices, and was last updated by  Pieter 3 months, 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #102719

    Pieter
    Participant

    hello fellow mpcnc-ers!

     

    i just finished my build of a mpcnc.

    The information about the machine:

     

    x: 600mm

    y: 400mm

    z: 120mm

     

    using a rambo V1.4 bought with a complete set (without printed parts) bought from Ryan.

    Endstops are not installed yet.

     

    I tried doing the “Crown-test” using the instruction on the v1engineering-site to convert the .dxf to .stl wich did not work. The machine drove the z (slowly) into the spoilboard.

     

    then tried the supplied .stl crown and it worked perfectly!

     

    In recab: i’m doing something wrong with converting .dxf to .stl or the settings in repetier-host are wrong.

     

    hopefully somebody out here can see what i’m mixing up here!

     

    thanks!

     

    Pieter

    (the Netherlands)

    #102756

    Ryan
    Keymaster

    What step of my instructions does your error happen? You should not be doing anything with an STL in my crown demo.

     

    #102774

    Pieter
    Participant

    Thanks for the reply Ryan.

     

    i’m mixing things up…

    it happens when converting dxf to gcode

    #102804

    Ryan
    Keymaster

    When using this page, https://www.v1engineering.com/estlcam-basics/, at what point does something go wrong? The entire page is the process of getting CNC gcode from a DXF, nothing is actually converted.

     

    Your issue is far to broad to help. To us it sounds like “I have a DXF, what is next?”

    #103141

    Brent
    Participant

    If I can jump in as a newbie I had this problem as well Ryan.  I think this is a chance to put a G92 reference into the milling basics page.  I may be incorrect but if this is the same as what I was experiencing, I would start the machine, and move the bit to where I wanted to start the program with the LCD controls, then start the program.  At that point it would return back to the turn on location and begin the program.  This sort of sounds like what this person is saying?

    I looked over the milling basics page and there isn’t a reference to resetting the origin.  It does “Don’t pay any attention as to where it is shown on the bed. It will start where ever your head currently is.”  Unless I missed something with mine, this is a true statement if I have the G92 x0.0000 y0.0000 z0.0000 code added as part of the startup in estlcam.

    If I’m mistaken, pardon the interruption.

    #103142

    Ryan
    Keymaster

    I understand what you are saying.

    If you wouldn’t mind, I am not sure how to word that clearly. Any ideas? At power up or reboot on a non-dual endstop machine that is zero, any movements with the LCD will move the zero point.

    I think I have a blurb on the Crown page. I don’t think many use the LCD to move a non-dual machine. I have always just moved it by hand and started. Part of the reason I suggest people uncomfortable with electronics to not use dual.

    #103233

    Pieter
    Participant

    Hi guys,

     

    thanks for the reply’s and sorry for the late reaction. (Sometimes i have to work too…)

     

    i’ve found the troublemaker. Some settings in estlcam were wrong, 100% human error.

     

    the MPCNC, pieter edition, is routing as we speak!

     

    thanks again!

    2 users thanked author for this post.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.