Strange movement

This topic contains 7 replies, has 3 voices, and was last updated by  mon 1 week, 2 days ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #109371

    mon
    Participant

    Thanks to reading many forum posts, my Crown is fine. I cut my own wasteboard, which took a long time but completed successfully, and made some successful test cuts in foam and wood. Yesterday, I attempted to cut out a fence. My first attempt went well, other than I had not placed enough tabs in ESTLCAM and decided I wanted a cut-out in the vertex of the angle.

    Nice cuts but learned something about tabs.

    I made changes to the DXF in FreeCAD and re-did the CAM in ESTLCAM. But when I ran the job, I noticed some jerky movements that would always occur in the same place.

    jerk

    In both cases, the tool would jerk past the cut so quickly it would shake the machine. You’ll also notice that at the top left the cut turned out to be wrong angle.

    When I first put the MPCNC together I noticed a similar behavior on one particular program where the tool would just wander off for a while and then get right back to what it was supposed to be doing. It wasn’t a jerk–it was a wander, and it was repeatable. The job looked good in Fusion and an online gcode simulator. I just chalked it up to not understanding Fusion 360, which I was attempting to learn at the time.

    I’m running firmware 402 on a MKS GEN-L V1.0 with DRV8825’s. (I think I was running the earlier firmware when I had the wander problem.)

    Any thoughts? Could bad wiring cause this kind of behavior even when some jobs are good?

    Thanks.

    fence2

    #109478

    Jamie
    Participant

    This is really strange.  Your gcode looks good and I don’t think wiring can do this, and I don’t think a mechanical issue would be so repeatable or give you that straight line segment at a weird angle.

    The only thing I can think is the firmware is doing something strange, perhaps if the G1 movements are clipped to non-negative coordinates but G02 and G03 are allowed to go negative?  It sounds like a stretch, but the areas where there are problems are just slightly negative.  Also, it looks like the holes are almost, but not quite centered on the bars.  I’m guessing they are supposed to be centered, because why would they be slightly off on purpose?  And then maybe the cuts along the X and Y axes (at slightly negative coordinates) are being pushed into nonnegative coordinates by the firmware.  This is a long shot.

    Try power cycling your machine with the tool to the left and in front of your workpiece (which will become your extreme limit if you have soft stops enabled in firmware).  Your entire workpiece will be within the machine’s limits.  Then jog to your workpiece and issue G92 X0 Y0 Z0 to set your workpiece coordinates.  You should then be able to run your job and reach the slightly negative coordinates without any problems.  If this works, then I think it means you have accidentally (or maybe intentionally) enabled soft endstops.  Soft endstops are problematic unless you always always home, and even then the are risky because you can easily forget where the machine’s soft limits are, e.g. if you disable steppers and drag the tool to the workpiece, and then if you hit the limits you ruin your work.

    Although this seems unlikely, this symptom is really strange and I can’t think of anything else.

    #109481

    Jes Laursen
    Participant

    In estl cam you have the option to disable G02 and G03, this solved the problem for me. I cant remember what the option is called.

    #109482

    Jes Laursen
    Participant

    Edit: it’s called: use arc commands g02/g03, and it’s under cnc program settings.

    #109496

    mon
    Participant

    Thanks for the replies. I learned a lot by just Googling the information in your answers.

    I’m using the dual endstop firmware, which has the soft endstops enabled. I disabled them with an “M211 S0,” ran the program, and the side jerk seems to have gone away.

    Then I–here’s the embarrassing part–re-read Ryan’s instructions for the dual endstop firmware. He says:

    1. Have a work offset when using the dual endstop firmware (which I didn’t do).
    2. Set the origin(?) with “G92 X0 Y0 Z0” if you don’t need the dual endstop functions (which I didn’t do).

    I’ll try cutting with this later and see if it also clears up the centering errors Jamie noticed.

    Thanks again!

    #109512

    mon
    Participant

    Just an update…

    With “G92 X0 Y0 Z0” and no offset, I still get the unwanted movement.

    “M211 S0” seemed to work though, so perhaps I’ll try a cut with that.

     

    #109516

    Jamie
    Participant

    G92 X0 Y0 Z0 doesnt actually disable the soft endstops, it just allows you to set a zero point that is safely inside your working space, so when you go negative relative to your zero point you’re still within the machine limits.

    For this to work you have to jog to your workpiece so the machine knows that it’s inside its limits. If you disable steppers and drag to the workpiece it will still think it’s at the edge of its working space, whether or not you do G92. I think this is not quite correct in Ryan’s documentation. The non-dual typical workflow can fail for this reason unless you do M211 like you are doing.

    #109654

    mon
    Participant

    Jamie,

    It cut perfectly. Thanks.

    -Daniel

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.