Problems with G code

This topic contains 3 replies, has 2 voices, and was last updated by  Jeffeb3 1 week, 4 days ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #117057

    Bojan
    Participant

    Hello guys.

    I am runing my MPCNC with Arduino mega + Ramps 1.4 + LCD + Marlin 2.0 Bugfix (downloaded from github – MPCNC_Ramps_T8_16T_LCD_32step_DualEndstop ). I milled few parts out of wood with this machine and i am very happy with results. But some parts i cant mill or carve properly. I am using Estlcam for generating G-code (enabled G2 and G3).  The simulation in Estlcam is showing proper path, but when i start it on MPCNC via SD card, the path is diferent. It moves in strange ways with some fast movements. (The Zero origin is set in the middle of carved parts, so there are also negative values in the Gcode).  I tried the same G-code with diferent firmwire (link from youtube  – https://www.youtube.com/watch?v=jlOyqca9AqM) and it works properly. But both firmwire are based on Marlin.

     

    What could be the problem for this? In attachment is example of G-code

    Thank you in advice.

    Best regards,Bojan

    #117067

    Jeffeb3
    Participant

    How are your steppers wired? Are they in series? You might be able to just use the version that doesn’t say “dual_endstop”.

    The dual endstop has soft stops enabled in X and Y. They make sure that you don’t clobber your home switches. So it won’t let you move negative. If you don’t need dual endstop firmware, that’s an easy fix.

    You can also disable soft stops with a gcode command:

    http://marlinfw.org/docs/gcode/M211.html

    M211 S0

    Or you can disable it in ths firmware if you search for MIN_SOFTWARE_ENDSTOPS in Configuration.h

    #117122

    Bojan
    Participant

    How stupid i am 🙂 Thank you Jeffeb .. the problem was in combination of dual en stop firmwire + G-code with origin (zero) in the midle of model. It generates G-code with negative values but the firmwire doesnt permit it to go below zero. I changed firmwire on my arduino and now it works fine 🙂

     

    Thank you for help.

    Best regards,Bojan

    #117134

    Jeffeb3
    Participant

    Be nice to Bojan. He’s not stupid, he just was looking at it so long it turned invisible. Glad it’s working.

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.