Problem using Estlcam with MPCNC

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Problem using Estlcam with MPCNC

Tagged: ,

This topic contains 21 replies, has 4 voices, and was last updated by  MegaDad3D 1 week, 4 days ago.

Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #88487

    MegaDad3D
    Participant

    I’m running into what I think is a bizarre situation when trying to carve from Estlcam. I am new, so I’m asking for a sanity check. Either it’s doing something totally different than it should, or else there’s something that I’m totally missing. Hopefully, you guys can steer me in the right direction.

    I’m trying to print a holddown. I designed it in Affinity Designer and exported it as a SVG file. The SVG file looks good in Estlcam. I created toolpaths for an inner slot (full depth for 3/4″ plywood), two ledges at 3/8″ at each end, and a parting cut along the outside edge. It looks good to me in the Estlcam layout.

    design

    tool

    It also looks good to me in the Preview.

    toolpath
    But when I run the gcode (attached to this post), it doesn’t print the part that I think it should. It is short on both the X and Y dimensions, specifically on the sides closest to the origin (lower left). You can see a slope there that shouldn’t be along the X axis cut. Finally, there are two places where it “jogs left” on the far left side that are not in the GUI. All of this seems to my eye to be in the GCODE.

    holder6

    I’m still evaluating Estlcam, and I’d like to know that I can make it work before I purchase it. Any suggestions will be appreciated.

    #88493

    MegaDad3D
    Participant

    posted in error, sorry

    • This reply was modified 1 week, 5 days ago by  MegaDad3D.
    • This reply was modified 1 week, 5 days ago by  MegaDad3D.
    Attachments:
    #88497

    Barry
    Participant

    Do you have an eighth inch end mill to use?  If not, cut your X/Y feeds in half.

    1 user thanked author for this post.
    #88503

    MegaDad3D
    Participant

    I think I figured it out. The edge of the tool during the cut was extending beyond the origin. I moved the origin .250″ down and .250″ to the left in Estlcam, regenerated the gcode, and re-ran the part. It looks like I expected now:

    design_neworigin
    holder6b

    If anything, I wish Estlcam had warned me about the condition instead of generating odd gcode.

    Thanks for your attention. I hope that my pain helps someone else. I only have to wait 24 seconds per save now in Estlcam… 🙂

    #88507

    MegaDad3D
    Participant

    Do you have an eighth inch end mill to use? If not, cut your X/Y feeds in half.

    1/8″ bit is supposed to arrive tomorrow. Thanks for your advice.

    #88509

    Barry
    Participant

    Origin location shouldn’t matter.  I do stuff with it centered to my project from time to time.  Unless it just physically couldn’t reach and skipped steps, but it doesn’t look like it did that.

    #88513

    MegaDad3D
    Participant

    Origin location shouldn’t matter. I do stuff with it centered to my project from time to time. Unless it just physically couldn’t reach and skipped steps, but it doesn’t look like it did that.

    That’s what I thought, too. I was printing in the middle of the MPCNC work area, not near the ends of either axis.

    FWIW, the only thing I changed between the first carve and the second is to relocate the origin in Estlcam.

    #88518

    MegaDad3D
    Participant

    I’m attaching the gcode that “worked”. I don’t see the issue in the gcode, but I’m new so I might be missing something. If it isn’t the gcode, then maybe it’s the firmware?

    I really don’t see how it could be hardware, because it was very consistent from carve-to-carve, and from layer-to-layer within the same run.

    • This reply was modified 1 week, 5 days ago by  MegaDad3D.
    Attachments:
    1. holddown_6a.gcode
    #88532

    Ryan
    Keymaster

    You are missing a setting or two in estlcam, from what I can see at least “repeat F”, highlighted picture number five on the estlcam page.

    1 user thanked author for this post.
    #88537

    MegaDad3D
    Participant

    You are missing a setting or two in estlcam, from what I can see at least “repeat F”, highlighted picture number five on the estlcam page.

    You either have better eyes than me or you have a lot of experience with this. I’m guessing both, actually.

    I checked the “repeat F” and will retry with my original origin point.

    Thanks for looking at it.

    BTW, some of the GUI screens are different between what’s on your page and the version I have. I can’t blame this setting, because that’s one that is the same. But it did confuse me a bit having more options than there were when you grabbed the screens.

     

    #88554

    MegaDad3D
    Participant

    This is getting even more bizarre. I checked the “repeat f” and ran it again. I also moved the origin in Estlcam back to the lower left edge of the part. The resulting carve looked like the first one I posted in this thread.

    So I made one different change and placed the origin in the center:

    design_6c

    I had Estlcam generate new gcode (attached) and the result looked like this. It was a scrap of MDF that was barely as wide as the part. Nonetheless, I didn’t expect this:

    carve_6c

    This is the only situation where I’ve had this kind of problem. I’ve carved about a dozen or so different practice designs and this is the only one where I’ve had this behavior. (Edit to add: all my other carvings have had the origin at the lower left, outside the path of the tool.) I can jog the machine with the LCD, and other than the fact that I cannot jog negative on X or Y (but I CAN jog either negative or positive on Z), I see nothing like this.

    Any help would be appreciated.

    • This reply was modified 1 week, 5 days ago by  MegaDad3D.
    • This reply was modified 1 week, 5 days ago by  MegaDad3D.
    #88562

    MegaDad3D
    Participant

    Since Ryan noticed one config setting, I’m adding a screen print of those as well.

    basic_settings
    presets
    coordinates

    #88577

    Barry
    Participant

    Wait.  You can’t move negative positions?  Are you running dual endstop firmware?

    #88582

    MegaDad3D
    Participant

    Wait. You can’t move negative positions? Are you running dual endstop firmware?

    yes, I am running dualstop firmware. RAMBo as delivered from Ryan.

    FWIW, I loaded the gcode into the following simulator and got what I expected, i.e. no odd paths.

    https://ncviewer.com/

    #88583

    MegaDad3D
    Participant

    Barry, your question made me go back and re-read the page about dual-endstops.

    Auto Square, Dual EndStops

    I read, under Use “Quick one off jobs as you always would setting the home position by hand and just running the job.”

    I also read the section about work offsets. “If you where to cut out that part it would result in going negative past your endstops and misalign your machine.”

    I presumed that since I was far from the endstops, I wasn’t in danger setting the origin in the middle manually. Based on what I have seen, there’s something in the firmware that doesn’t like negative X or Y values, even when the dual endstops aren’t triggered during an operation. If that’s the case, then I know what to do.

     

    [edit:] It would be nice to be able to carve using the center as origin in some situations and to be able to use the dual endstops in others. But I can live with it, if that’s the case.

    • This reply was modified 1 week, 5 days ago by  MegaDad3D.
    #88622

    Barry
    Participant

    Home the machine first.  After that you’ll be able to do negative moves.  Until it knows where the hard zero is, it saves itself by not allowing manual negative movement.  So before trying the next carve, click the X and Y home buttons in repetier, don’t hit the big home button though!  It will try homing z, which doesn’t have a home switch, so it will do a pushup, and probably break something.  After that you can jog over to your work zero, issue a G92 X0 Y0 Z0 to give it it’s new zero location, and hit go.  Here’s where it gets handy for having end stops.  Once you know the offset zero location for X and Y(I write them down), you can do easy tool changes, then just rehome XY, manually moving to the written down XY, reset the new tool Z0, G92 X0 Y0 Z0, and it’s right back to the exact spot the first end mill was at.

    1 user thanked author for this post.
    #88632

    MegaDad3D
    Participant

    Thank you very much @Barry ! That is very helpful. I’ll do some experimenting and report back.

    #88680

    MegaDad3D
    Participant

    I’m happy to report that thanks to @Barry , it is working like it should, even with negative X and Y values. This photos show two different passes made from the same gcode. In the upper one (which I already posted), I manually set the zero in the LCD and tried to print, with “bizarre” results.

    holder6c_success

    In the lower one, I homed X and Y using the dual stops, then I jogged to the center and issued the ‘G92 X0 Y0 Z0’ command in Repetier, and had Repetier run the gcode. This part came out exactly as I expected.

    I went ahead and saved the ‘G92 X0 Y0 Z0’ as Script 1 so that it will be easily available in Repetier.

    I’m very happy and grateful for the assistance.

    1 user thanked author for this post.
    #88701

    Ryan
    Keymaster

    Are you using dual endstop firmware? You can’t go negative XY with that.

    1 user thanked author for this post.
    #88702

    Heath
    Participant

    This sounds a lot like the issue I was having in this thread:  https://www.v1engineering.com/forum/topic/problem-with-0-at-center/

    I’ll have to do some more experimenting myself.  Since then, I’ve just avoided any negative movements.

    1 user thanked author for this post.
    #88714

    MegaDad3D
    Participant

    Are you using dual endstop firmware? You can’t go negative XY with that.

    Yes, I am running dual endstop. I now realize that negative X/Y values are a problem, unless you send the  ‘G92 X0 Y0 Z0’ as recommended by Barry, above.

    My process was:

    1. Connect Repetier via  USB to RAMBo
    2. Home X in Repetier using dual endstops
    3. Home Y in Repetier using dual endstops
    4. Jog to the center of the workpiece using Repetier
    5. Send the gcode ‘G92 X0 Y0 Z0’ in Repetier
    6. Run the gcode file that was created with a center origin in Repetier

    The last photo has two executions of identical gcode. The one on top is without the procedure: fail. The one below is with the procedure: success

    #88715

    MegaDad3D
    Participant

    This sounds a lot like the issue I was having in this thread: https://www.v1engineering.com/forum/topic/problem-with-0-at-center/

    I’ll have to do some more experimenting myself. Since then, I’ve just avoided any negative movements.

    I watched your video and that looks a lot like what I was getting. The router would jerk back and forth as it went toward negative. In the photo in the OP of this thread, the two little jogs on the left were exactly like that.

    I am with you that there are times when carving with the origin at center makes sense. I think it’s worth trying Barry’s suggestion.

Viewing 22 posts - 1 through 22 (of 22 total)

You must be logged in to reply to this topic.