Problem (flashing Marlin firmware on Mini Rambo)

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Problem (flashing Marlin firmware on Mini Rambo)

Tagged: ,

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #109907
    WD
    Participant

    Hello to all the community here,

    First of all I am trying to built the MPCNC project:

    I am facing an issue with my mini rambo board (chinese clone probably), when I try to flash the Marlin firmware MPCNC_MRambo_T8_16T_LCD from the official github thread of Marlin.

    When I compile & upload that firmware from Arduino v1.8.9 (tried also v1.9 BETA) and followed these flash instructions, it shows no errors, but the screen that comes with the board shows only 4 lines of white upside down y characters.
    The button beeps & seems that it is moving inside the menus, but no movement coming from the steppers :-/

    While, when I flash the same board with the prusa3d ,  everything works smoothly…the motors respond via the Repetier-Host program & the screen shows correctly the English characters and the menus to navigate!

    Can anyone please help me resolve that issue..?

    Thanks a lot in advance 😉

     

     

    #109916
    Barry
    Participant

    Need to edit the firmware for that screen.  Open the Arduino sofware, then tab over to Configuration.h

    Find this part, waaaay down towards the bottom;

    //=============================================================================
    //======================== LCD / Controller Selection =========================

    //======================== (Character-based LCDs) =========================

    //=============================================================================

    // RepRapDiscount Smart Controller.

    // http://reprap.org/wiki/RepRapDiscount_Smart_Controller

    // Note: Usually sold with a white PCB.

    //#define REPRAP_DISCOUNT_SMART_CONTROLLER

    Change that last line to;

    #define REPRAP_DISCOUNT_SMART_CONTROLLER

    Then a little ways down from there find;
    //=============================================================================
    //======================= LCD / Controller Selection =======================
    //========================= (Graphical LCDs) ========================
    //=============================================================================

    //
    // CONTROLLER TYPE: Graphical 128x64 (DOGM)
    //
    // IMPORTANT: The U8glib library is required for Graphical Display!
    // https://github.com/olikraus/U8glib_Arduino
    //

    //
    // RepRapDiscount FULL GRAPHIC Smart Controller
    // http://reprap.org/wiki/RepRapDiscount_Full_Graphic_Smart_Controller
    //
    #define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

    And change the last line to;

    //#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

    After that recompile the firmware and upload it.  Should work.

    1 user thanked author for this post.
    #109919
    WD
    Participant

    THANKS a lot @Barry, for your lightning fast response to my problem here! 😀

    I followed your instructions above, which were very well written & easy to understand 😉

    It worked!!! 🙂

    • This reply was modified 3 months ago by WD.
    1 user thanked author for this post.
    #109925
    Barry
    Participant

    Sweet!

    1 user thanked author for this post.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.