MPCNC Z-Endstop

New Home Forum International German MPCNC Z-Endstop

Tagged: 

This topic contains 5 replies, has 2 voices, and was last updated by  Ryan 1 week, 6 days ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #118870

    Simon
    Participant

    Hallo miteinander!
    Ich bin neu in diesem Forum. Meine MPCNC ist beinahe fertig und ich schlage mich nun mit der Elektronik herum.
    Meine Konfiguration:
    – Arduino Mega
    – RAMPS 1.4
    – Dual Endstops
    Eigentlich funktioniert beinahe alles. Homing von x und y läuft perfekt, die Soft-Endstops tun auch. Auf der Z-Achse funktioniert die Tastplatte, welche ich auf dem Z_MIN_Endstop anschliesse. Damit die Z-Achse bei etwas schwungvoller Bedienung des Impulsgebers nicht oben ausfährt, habe ich dort einen Endstop montiert. Dieser ist “Normaly closed” verdrahtet und an Z_MAX angeschlossen, verweigert jedoch den Dienst.
    Irgendwo habe ich wohl was übersehen, finde den Fehler aber nicht. Wäre super, wenn mir jemand auf die Sprünge helfen könnte.
    Vielen Dank!
    Simon

    #118871

    Ryan
    Keymaster

    The Z is set for normally open so you can use it as a contact switch.

    #118880

    Simon
    Participant

    Danke Ryan für deine rasche Antwort.
    Das habe ich versucht, aber auf den Schalter folgt keine Reaktion.
    Z_MIN_ENDSTOP_INVERTTING und Z_MAX _ENDSTOP_INVERTTING sind auf TRUE gesetzt.
    Müsste sonst noch irgendwo eine Anpassung erfolgen?

    #118901

    Ryan
    Keymaster

    Nothing needs to be changed in my firmware, it works as is already. Flash a fresh copy and it should work

    #119917

    Simon
    Participant

    Hallo
    Habe nun Marlin neu geflasht. Nun funktioniert Z_MIN mit der Tastplatte. Z_MAX geht leider immer noch nicht, so dass die Z-Achse oben rausfahren kann. Dafür wäre eigentlich der Endstop gedacht gewesen. Dieser zeigt jedoch keinerlei Reaktion. Was könnte hier falsch sein?
    Danke für jede Hilfe.
    Simon

    #120004

    Ryan
    Keymaster

    I have endstops only on homing in my firmware. Look at the Softstop settings in marlin.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.