Marlin won't report back and can't flash update

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Marlin won't report back and can't flash update

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Stephen 2 weeks, 2 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #112211

    Stephen
    Participant

    Hi,

    I had the rig I built from the kit with Rambo board and dual end stops was working for a while and everything seemed good.  Of course I couldn’t leave well enough alone and I hooked up a laser.  The laser ran off 12v so I hooked it into the fan and used M106/7 to turn it on and off.  I ran a couple simple etching jobs and all seemed well.  I had the rig powered up, the laser/fan off (M107) while I worked on an etching test.

    A little while passed and I tried to run an etching test, in cncjs I noticed it wasn’t responding to the Axis controls.  I could insert commands at the command prompt in cncjs and the rig would respond but wasn’t getting an ack or any output back.  The Axis wasn’t keeping track of location.

    I tried everything and couldn’t get it working right.  I reinstalled cncjs on a brand new raspberry pi.  I tried flashing the latest marlin firmware but I get avrdude timeout errors.

    1. any idea what cause the problem in the first place?

    2. does this have to do with the way I hooked in the laser, and was there a better way?

    3. any idea how to get round the timeouts.

    I actually had another rambo board (don’t ask why).  I flashed it just fine and got back up and running but the fact that this one stopped working troubles me.

    #112257

    Barry
    Participant

    I think cncjs has a bug with marlin.  Usually it works fine after a move is sent through the gcode window though.

    #112303

    Stephen
    Participant

    Yeah unfortunately I am familiar with that issue and this isn’t that.  I usually used a M119 command to report back the endstop status to get past the issue you are talking about.  Now I type M119, hit enter, and just get a prompt without any response.

    I can type a G0 X10 for example and the rig moves but the axis panel doesn’t track the movement and still shows all 0s

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.