MadMachine – let the fun begin

New Home Forum Mostly Printed CNC – MPCNC Your Builds – MPCNC MadMachine – let the fun begin

This topic contains 103 replies, has 17 voices, and was last updated by  Jeffeb3 5 months, 2 weeks ago.

Viewing 30 posts - 31 through 60 (of 104 total)
  • Author
    Posts
  • #53618

    Madman
    Participant

    Hi Mmmfishtacos

    It says it is an Afinibot but who knows.

    Quick update – got a micro-SD, put the gcode file onto it, plugged it in, set her up using the notepad and told it to run the file on the SD card.

    All went well (more or less anyway) until about 2 layers from the end.

    The notepad had gone to sleep and when I reactivated it the printer froze.

    On that print I had 3 places where one layer was indented – like there was not enough material being extruded and the next layer was outdented as if the material from the previous layer was now coming through. (camera on cell wont take decent shot – sorry)

    I know that I still have all sorts of cooling issues etc and it looks like there was a partial clogging taking place which cleared and the material went gushing out on the next layer.

    Anyway, each “failure” adds to the knowledge pool which will eventually lead to success.

    #53620

    Jeffeb3
    Participant

    That is a melzi board. I have one in my wanhao duplicator i3. The wanhao one has different pull-up resistors than the normal melzi board. Mine are 10k (they have 1002 printed on them). The wanhao board also didnt have a bootloader, so I had to reprogram it with an ISP programmer the first time. Hopefully, you’ve got a standard melzi.

    You can print from SD without an LCD, if the firmware supports it. There are gcode commands for printing from SD. The filenames are dos formatted though.

    As for Z0 compensating for the thickness of the paper, don’t stress too much. Just use the same paper all the time, and adjust things until your first layer looks right. If you’re consistent, it won’t matter if it’s exactly 0 or it’s 0.4mm. You can adjust this height with gcodes a little, or you can usually make an adjustment in the slicer.

    2 users thanked author for this post.
    #53649

    Madman
    Participant

    Thanks for the info there Jeffeb3 – will add it to the rapidly growing database in my head.

    Reportback:

    After speaking VERY nicely to Alison and trying about 20 prints that only got to the 2nd or 3rd layer I figured out that the paper feeler gauge needs to be a VERY sloppy fit so that the first layer does not run with the nozzle tight up against the bed at the start of the print.

    When that happens the first layer is not at all flat, all sorts of spikes and bumps sticking up and when the next layer comes along, you can hear the nozzle slamming into them as it makes its way around.

    By the 6th or 7th layer everything starts to settle down and the racket goes away but it cannot be very good for the nozzle!

    Eventually I managed to get one printed fully that did not look too ad at all – So I carried on and by late last night I had all 4 of the foot pieces printed.

    This morning when I got up I sliced the next part (BottomCornerM I think) and when I was looking at the instruction page on v1engineering to see the print time I almost had a heart attack!

    I had sliced and printed the 4 previous pieces at 20% infill !!!

    Oh well, Newbie mistake I suppose…

    So I CAREFULLY prepared the next part, put it on the SD and started it up.

    Here is a tip: If you are printing from an SD card and like me you have to initialize the print from a PC/Laptop/Notepad and the thing goes into sleep/hibernation mode (or whatever) DO NOT WAKE IT UP !!!

    What seems to happen is that when the PC gets going again, it tries to re-establish communications with the printer and probably sends a reset or initialization  command (or something) which stops the SD card print dead in its tracks and you get yet another “failed print”!!!

    I have hunted down the screen saver, hibernation, hard drive sleep and every other “switch something off” setting that I could find and turned them all off and I move the mouse every 15 minutes or so while the thing is printing.

    Alison seems to have settled down quite a bit but on every part there is at least 1 line that is a bump – probably caused by the extruder’s lack of cooling but I have identified the problem and will be dealing with it ASAP.

    What I did notice is all sorts of small wavy patterns all over the place – not too serious (I hope) and I sat for a long time trying to figure out what could be causing that.

    There must be some sort of movement somewhere so I took one of the small filaments (had plenty lying around from making sure that the nozzle was working prior to starting a print) and glued it to the Z axis holder on the one side and watched it for a bit.

    Sure enough, when the nozzle went through the areas that showed this “pattern” it waved around like crazy even though the X axis was not moving at that point.

    So I started to look around and saw that the vertical shafts were moving almost imperceptibly in the location holes in the acrylic.

    On my machine these shafts are held in place by small pieces of acrylic that are screwed into place to keep the shafts from moving out of location vertically but there is definitely some lateral movement of these shafts when the print head is being thrown around.

    This is probably a big part of that issue!

    I think what I am going to do is drill and tap some holes so that I can use grub screws to positively lock the shafts to the plates they are mounted in.

    That will provide better stability and hopefully go a long way towards solving that issue.

    There also seems to be a bunch of other areas that are “vibrating” when you place your finger lightly on them and I’ll have a look at that as well.

    Now lets talk about CAD software…

    The last CAD package that I used was “CADDY” which I am willing to be that no-one reading this knows anything about.

    It was back in ’93, under DOS3.3 !!!

    So I’m learning how to do things in FreeCAD while I am waiting for Alison to give birth to the next part.

    Why?

    Because one of the next things that I have to do is make a new extruder mount/Y axis plate so that I can properly mount everything and not like it is currently with cooling fans hot glued into place.

    I know! I do weird stuff!!! But just maybe the world needs some more weird people!!!

    Anyway, thanks for reading and any comments, tips, reprimands etc are welcome.

    All the best and thanks for taking the time to read my ramblings

    Aubrey (AKA MadMan)

    #53656

    SquidPlan
    Participant

    The feet might be usable. Be super careful not to evertighten the bolt and they may work.

    Can you start an sd card print from pronterface?  Not sure if that would allow you to disconnect right after starting it. If it does, then it wouldn’t get messed up by the computer sleeping.

    #53666

    Bob Lasure
    Participant

    Good Luck, Just keep plugging away, you’l get there!

    1 user thanked author for this post.
    #53724

    Bill
    Participant

    The feet should be fine, there’s very little pressure put on them during use. They’re there to keep the whole assembly from shifting around when the bit is pushing against your work piece. Just barely snug down the screws and they’ll hold fine.

    1 user thanked author for this post.
    #54284

    Madman
    Participant

    Hi all – quick update:

    If the Afinibot I3 clone is supposed to be “one of the better ones” as claimed by some on YouTube then I shudder to imagine what the “worse ones” are all about!!!

    This particular machine (AKA Alison) was a lemon from the day it was made!!!

    But that is not a problem as I have rebuilt and refurbished far more complex machinery before.

    The biggest issue at this time is that on the Z axis there is NOTHING that aligns properly and therefore nothing works properly.

    The guide rods are a sloppy fit into the frame so the printer head wobbles all over the place.

    I believe that machines “talk” to you, all you have to do is listen to them!

    And Alison started binding on the Z axis – BADLY!!!

    So much so that one stepper could not overcome the resistance and the other then jacked the guide bars for the Y axis all over the place.

    The result was instant bad prints – EVERY TIME!!!

    So I supported the extruder, undid the lead screw couplings and as I was removing the lead screws and saw that they were both horribly misaligned with regard the center of the coupling/motor shaft – the one that was skipping by almost 2 millimeters!!!

    So I stripped off the printer axis assembly and put the Z axis back to start investigating what could be done.

    The lead screw was definitely not aligned to the center of the motor.

    Unfortunately there is no way to set the alignment using the motor placement as it is positively located using the spigot on the motor in a tight fit to the acrylic that it is mounted to.

    So if I can’t use the motor to align things, then what about the screw nut?

    Previous owners MUST have battled with this issue and tried to “fix” it because on the side that seized, UNDER the nut was a washer (one of the VERY FEW on the machine) AND A PIECE OF MATCH STICK!!!

    As there is not really too much space in the printed Z guides to allow for over-sizing so that the nut is aligned with the motor AND it would mean replacing the self tapping screws with bolts and nuts to allow for movement (no space either!) it looks like there needs to be some major surgery done on the motor mount.

    I have ordered the next batch of tools that I will need to do this operation AND a 500 pack of assorted flat washers 3mm to 6mm so until that all arrives, Alison will have to sit in the corner and sulk.

    For what it needs to do the machine design is not bad BUT there are details that need to be addressed that, to be honest, will allow everything to work together properly.

    Alison was a lemon from day one – the “mods” that someone tried to make to fix the problem are proof of that – but once I have sorted this alignment issue (and who knows what else I will find along the way) she will be a happy and productive lady – my “Lucky Lemon”.

    This next week should be interesting….

    In the meantime I am trying to find which slicer to use – been using CuraEngine but Slic3r (2 flavors) are also present – any comments?

    Thanks for reading people.

    Aubrey

     

    #54285

    Jeffeb3
    Participant

    It’s a bummer your first printer isn’t smoother for you, but part of me thinks it’s good this printer has someone with such patience as it’s owner.

    I like slic3r, the prusa version. I haven’t used the most recent version of cura either though. Once I get settings that work, I don’t like messing with it.

    1 user thanked author for this post.
    #54674

    Madman
    Participant

    Hi everyone – quick update…

    Ordered some tools and they are dribbling in.

    So I started to take things apart – and dropped one of the steppers!!!

    Now normally it would get to the maximum reach of the wires and sort of stop but not this one!!!

    The wires all parted and it hit my foot which prevented damage to the motor but my foot was another matter.

    So I investigated why the wires had parted so easily.

    The joints had been “disguised” with heat-shrink BUT they were not soldered and had simply pulled apart.

    So I inspected the other wires and wherever I found heat-shrink, gave it a light tug and sure enough, most of them were in the same condition.

    One wire that was hidden away inside some spiral-wrap did not even have heat-shrink on it!

    So I got a roll of decent wire and a bunch of clip together type connectors and Alison is getting a new nervous system at the same time as getting her chiropractor treatment for misalignment of vital parts which is hopefully happening this weekend.

    (I think that I will be running double wires to all the steppers just in case – I have a 100 meter roll so…)

    I know that many people, including her previous owners, would simply dump the machine (as they did, on ME) BUT refurbishing things is something that I enjoy doing because at the end of it all I will have a machine that is not fighting itself due to misalignment’s all over the place and now I will know that the electrical system is right.

    And when she is all fixed up I am confident that she will perform well – every other machine (or motor) that I have “blue-printed” has performed better than the best maximum specs given by whoever the manufacturer was and that means that it lives up to expectations even though it is only running at about 85% of the capability that it can run at.

    Which I am guessing on a 3d printer converts to better quality prints, less failed prints and in my case, a happier me.

    So this weekend is going to be hectic! I just hope that I don’t accidentally damage any of the acrylic parts in the “adjustment” process.

    Or the electrical/electronic bits either for that matter.

    I will see everyone next week.

    #54727

    Madman
    Participant

    Now I am OFFICIALLY PI$$ED OFF!!!

    A wire caught between 2 of the components.

    MORE wires not soldered – some with sellotape insulating them.

    Rod retainers pushing hard on rods that are through the acrylic meaning that the whole chassis is jacked skew.

    And not one single washer on the whole machine.

    No wonder it was all over the place when printing.

    But at least there are no broken acrylic parts…

    So…

    Completely stripped down!

    Now she gets put together properly and adjusted correctly.

    Then she will sing and dance.

    Wish me luck

    Attachments:
    #54730

    thesfreader
    Participant

    Wishing you quite a lot of luck, and once rebuilt, I think Allison will be way better than before. !

    1 user thanked author for this post.
    #54784

    Madman
    Participant

    Update:

    It is DEFINITELY NOT PRETTY!!! But it allows for the adjustment that is required!

    I carved out the motor mount plate to allow almost 2mm of adjustment on the motor positioning and with some fender washers, mounted the motor.

    Of course the original cap screws were not long enough to get through a washer, a fender washer, the mount plate and then thread deep enough into the motor casing.

    All I had was cap screws that were WAY too long – so a couple of nuts as extra spacers had to do.

    Then I ran out of nuts AND washers – go figure!!!

    I test fitted the Z axis guide shafts – did the “roll on a table” test – they as well as the lead screws were also nice and straight.

    So I got the left side all sorted out but on the right side I had to relieve the motor mount plate even more… Which I did.

    After making a cup of tea, as I walked back into the room I noticed from the angle I was looking at the machine that the lead screw was NO WHERE NEAR PARALLEL to the guide shaft!!!

    While I had been sitting “up close and personal” working on her I had not noticed this.

    Then when I loosened the first screw holding the nut to the printed part I noticed the nut lift ever so slightly away from the printed piece.

    Grabbed a small straight-edge and had a look see and found that the area where the outer most mounting screw for the lead nut is was dropping away.

    Now this surface is the one that is on the bed when the part was printed and “should” be perfectly flat and at 90 degrees to the axis of the guide shaft.

    Obviously what must have happened is that this area had lost adhesion to the bed and lifted slightly which under other conditions would not have been too serious but in this case caused a major alignment issue because as you tighten down the lead screw nut, it gets forced out of alignment causing the issues being experienced.

    So what to do about it?

    Eventually I decided to NOT screw the nut tight onto the carrier but to leave a small gap and lock the nut with another nut so that nothing comes loose.

    I repeated the process on the side with the fall-off, making sure that the lead screw was now parallel to the guide rod when the force was up the lead screw as it would be during operation.

    And guess what? Now everything fitted nicely at the motor end of the lead screw as well.

    (I remember correctly this is where I found the piece of match stick jammed in so “someone” had found this previously and done a “quick fix” which had not worked.)

    The long and the short of it is that Alison is probably going to be printing herself a pair of new Z guide brackets in the near future – along with a good couple of other “bling” items like cable chains and other wire management goodies.

    So basically I am stuck until I get some more cap screws of the right length. The only place you can get them from on a Sunday is RIDICULOUSLY expensive!!!

    On my shopping spree last week I got a 100 meter roll of 1,5mm wire and a boatload of plugs so today its me and wired – heaven help us all…

    Thanks for reading – and any advice would be appreciated.

    #54799

    Jeffeb3
    Participant

    (I remember correctly this is where I found the piece of match stick jammed in so “someone” had found this previously and done a “quick fix” which had not worked.)

    Haha. I was going to suggest shimming it. Also grease up those screws a little. Are they moving smoothly up and down?

    #54814

    Madman
    Participant

    Are they moving smoothly up and down?

    Hey Jeff – no motion yet.

    Shorting a bunch of fasteners and every wire in her has been stripped out – ran out of cable wrapping too.

    And was that ever a mess!!!

    Anyway, laying new cables and wires where needed, routing the ones that I can keep properly.

    All that sort of stuff going down at the moment but baby is getting a new party dress and she will be going to the prom hopefully before Wednesday.

    I think that I will have to do the final setup as if it was out of the box because who knows what they “tweaked” to work around the mechanical issues.

    I really wish I still had a dial gauge to measure the axis movements to get steps per mm right but I suppose a vernier will have to do.

    Thanks for the interest and you have a good one…

     

    #54815

    Jeffeb3
    Participant

    Hey Jeff – no motion yet.

    You can tell just by twisting it by hand. In my experience the problem with this nuts not being perpendicular is that they really stick. If you cant turn them by hand, then thats a problem.

    I really wish I still had a dial gauge to measure the axis movements to get steps per mm right but I suppose a vernier will have to do.

    The parts are made very accurately and in metric sizes so you should be able to just calculate the steps/mm. Something like 200, 800, 160… They almost always line up with something like that (unless you have an imperial leadscrew, which I’m sure you don’t). Just a tape measure would be accurate enough, and just using one of the calculators is also fine.

    1 user thanked author for this post.
    #54816

    Jeffeb3
    Participant

    The exception to that is the extruder…

    #54826

    Madman
    Participant

    Just a tape measure would be accurate enough

    ;>} Jeff, you do not know me very well YET!!! I’m kind of a major pain in the butt when it comes to setting up machines that I need to be pretty accurate…

    Believe that if you take the time to dial everything in properly and make sure that everything is playing nicely with everything else then if you hit a problem it is normally far quicker to troubleshoot – and if there is no problem then it just sings along.

    But of course everything has to be within reason as well.

    I have a good smile when guys on the forums are discussing how to get their machines to within 0.01mm or better repeat-ability and then when you have a look at their machine its frame is chipboard or some similar material which changes dimension quite a bit based on the humidity.

    And then you find out that they are machining WOOD!!!

    Basically it is horses for courses ~ know the machine limitations and get the best results within those parameters.

    I know that the MPCNC is pretty stable for what it is but I’m not naive enough to expect to build NASA or military spec components on it – that is definitely the way to go to get ulcers and migraines. I want to have fun with mine.

    Enjoy whats left of your week end there buddy.

     

    #54827

    Jeffeb3
    Participant

    Well, actually in reality aside, the correct value should be something like 200.000, because there are exactly 200 steps per revolution and you are using exactly 1/32 microstepping and there are exactly 16 teeth per gear, etc. Thats why im saying the calculator is right. Any measurement you take will just add error.

    The extruder is different, because its a hobbed gear gripping the plastic. The best you can get is close, with measurements.

    1 user thanked author for this post.
    #54868

    Madman
    Participant

    Come to think of it you are absolutely right there Jeff – thanks for bringing me back down to the planet ;<}

    Would it not be nice though if there was some way of accurately measuring the volume of the extrude out of the nozzle without having to “guesstimate” the diameter of the filament?

    If the machine could automatically compensate for variations in filament diameter of say 0.10 either way then we would all be extruding our own filament because the allowable tolerance would be so much bigger and therefor 1.75mm plus/minus 0.10mm is FAR easier to achieve at home than 1.75mm dead.

    At one point in my life I was a production planner in a factory that molded all the bits for household appliances (irons, kettles, toasters etc) and there was a couple of the large nozzle bore machines that had a gate valve in the nozzle to prevent ooze when the nozzle was retracted from the die set – something like that would take care of stringing and the need for retraction but on this small scale that would probably be overkill. But it would be nice because there is no way that the slicer can take ooze into account which means that WHEN you get ooze (stringing) the first part of your next extrude WILL be under-weight.

    But I suppose that if everything was an exact science then that would take the challenge out of 3D printing.

    Sort of like having to tune a CNC mill to take into account tool deflection and bed flex based on the feed speed, tool, material being used and the capabilities of the machine.

    But when you get all of THAT right you stand back and think to yourself “NAILED IT!!!”

    #54875

    Jeffeb3
    Participant

    Yeah, that would be nice. There are some “improvements” to Marlin and another firmware called “klipper” that tries to manage the floor by pressure in stead of position to get the right volume, but it’s not using feedback to determine the pressure. In my experience, the filament size has been pretty consistent.

    1 user thanked author for this post.
    #55353

    Madman
    Participant

    Update:

    Hi All – been one of “those” weeks!!!

    But Alison is together except for the extruder/slide assembly and the heated bed.

    Here is a “before” of the rats nest of wires

    And here is the “after”

    It was a total mess – the loom had been hacked, a black wire goes into the spiral wrap that someone used to hide the bad choices in assemble and a dark purple one comes out.

    The one Z axis motor has a green going in and it came out as red, the red came out as green.

    What a mess.

    Long story short, all my photos and wiring diagrams made before the tear down were….USELESS!!!

    So all sorts of looking up on the site and here we are.

    11pm local so I’m calling it a day – tomorrow she must move under her own power and then we start the final dial-in – think I should go through the software settings as well, set everything back to default and start from there.

    Later everyone.

    #55379

    SquidPlan
    Participant

    Progress!

    The before picture looks a lot like everything I build.  😀

    #55436

    Madman
    Participant

    Progress!

    The before picture looks a lot like everything I build. 😀

    I know EXACTLY where you are coming from but I also know the pain that it causes!

    It is not “right” yet, the wire pairs should be twisted to reduce electro-magnetic bleed because the fish tank air pipe that I had and which I used as individual wire management conduits will harden and become a lot less flexible in time but what can I do? It is what I have right now.

    I will print up cable chains and mount points etc as soon as I can – and the Z axis blocks as the current ones are somewhat “crippled”.

    I also noticed that there is not enough space on them for a “normal” sized micro switch and you have to use one of the very small (read “expensive” here in South Africa) variety so that needs to be addressed too.

    But that is something for another day.

    One good thing though is that she had proper straight and hardened multi-start lead screws and not M8 threaded bar – that stuff is NEVER straight and the tolerances and finish on them is crappy wherever you source it locally and if you import it you might as well get lead screw – suppliers just pack it better and some times it gets here and is still straight.

    Wish I still had my lathe! Making up improved parts would be so much easier…

    #55617

    Madman
    Participant

    Here is the WhatsApp I just sent to a friend:

    Took a deep breath, gulped down a BIG mouthful of tea, plugged her in and switched her on….
    NOTHING!!!
    Oh $#!T….
    Unplugged her, got out the tester, disconnected the main electronics board power wires and started going through everything…
    Then I saw that I had put the negative board feed wire into one of the positive terminals on the power supply.
    That right there is a sure fire way to blow the electronics!!!
    Under “normal” circumstances….😎
    Then I noticed that I had put the positive board feed wire into the next positive connector on the power supply.
    In other words the electronics board (which needs both positive AND negative to even think about working) only had one.
    Just maybe it was NOT blown….
    So I put all the wires where they should be, checked every wire again, 100 times, and switched on again.
    Did you know that Alison has blue eyes?
    The blue power light on the electronics board started winking at me….
    Plugged the laptop in and connected the software and tested the 3 directional motor sets.
    ALL WORKING !!!!
    So now I need to finish assembly and set everything up as it should be ~ happy days…
    Thanks for being so supportive – means SO MUCH!!!

    And thanks to everyone here on the v1engineering community as well.

     

    #55618

    thesfreader
    Participant

    Love Alison’s blue eyes 🙂 And please know you have supporters all around the world.

    1 user thanked author for this post.
    #55619

    Madman
    Participant

    Love Alison’s blue eyes 🙂 And please know you have supporters all around the world.

    Thanks for that – I will be needing those people when I try to get the LCD working – its probably a miss-match for the board but anyway…

    #55624

    Jeffeb3
    Participant

    My melzi is connected to a reprap full discount display. Should be compatible, although I had to make/edit the cable. I can see if I have my notes on it. I also had to edit the firmware…

    1 user thanked author for this post.
    #55626

    Madman
    Participant

    My melzi is connected to a reprap full discount display. Should be compatible, although I had to make/edit the cable. I can see if I have my notes on it. I also had to edit the firmware…

    Would be helpful although it is probably C and I have not worked in C since the early 90’s – but program languages are like falling of a bicycle – easy to do and hurts like heck sometimes ;>}

     

    #55669

    Jeffeb3
    Participant

    Configuring Marlin doesn’t require writing software, it’s all configured by #define’s.

    That’s my chicken scratches there. Not terribly helpful, but I think the lower left one translates from the melzi pins to the function to the reprap pins. I can find the pins file I used later, if you want it. It might be easier to follow the instructions from someone who has the same printer as you. My melzi board is not 100% standard (its from a wanhao).

    1 user thanked author for this post.
    #55709

    Madman
    Participant

    Jeff – you are a star!!!

    I will definitely be pushing on your button when I get to that stage.

    Aubrey

Viewing 30 posts - 31 through 60 (of 104 total)

You must be logged in to reply to this topic.