Limit switches not working anymore on MKS 1.4

New Home Forum Milled Printed 3D Printer -MP3DP Troubleshooting – MP3DP Limit switches not working anymore on MKS 1.4

This topic contains 6 replies, has 3 voices, and was last updated by  Jethro 3 weeks, 4 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #101353

    Jethro
    Participant

    Hi there,

    Got some trouble with the Limit switches on my MP3DP.

    The strange thing is, that I had it working on a first test 2-3 weeks ago, then put it aside as I was still waiting for parts to arrive. Unfortunately I can’t recall which firmware I used. So my guess is that it must be some setting(s) in the firmware.

    The limit switches are NC-wired, when I send the M119 command they report x_min: open, or triggered when actuated. Same goes for the Y and Z axis. I assume this is correct, or not??

    I tried some different firmware(s), but didn’t get any closer , for the moment I’m on the MP3DP_Ramps_16T_MK, the only changes I did was reversing X & Y axis that movements correspond with Pronterface and the Dual Z axis.

    I tried already to change rotation in the firmware or by wiring, it does absolutely nothing. I added the two config files if that might help, as I had it working I’m pretty sure it’s a minor thing, but I’m to stupid to figure it out. Hope someone can help to lead me on the right path.

    #101363

    Jeffeb3
    Participant

    What’s not working? Is it driving the wrong way or crashing into the switch?

    If M119 is right (and it looks like it is). If you do a manual movement before doing a homing, are they going in the right direction (away from the switches)?

    #101370

    Jethro
    Participant

    Yes, all axis are moving in the right direction, it’s just that the limit switches do absolutely nothing, doesn’t matter in which direction the axis is moving. I tried that already to change the direction either by wiring and/or in the firmware, the limit switches do nothing.

     

    #101371

    Jeffeb3
    Participant

    They do nothing, like it runs into them and doesn’t stop running?

    1 user thanked author for this post.
    #101372

    Jethro
    Participant

    Yes, same on all 3 axis.

     

     

    #101373

    Ryan
    Keymaster

    During a g28? The are not on any other time.

    1 user thanked author for this post.
    #101377

    Jethro
    Participant

    That’s it, probably it was working all the time.

    G28 is working fine, I tried movements on Pronterface, not knowing that the switches are bypassed.

    If you both were girls I would kiss you  (:~D

    1 user thanked author for this post.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.