Laser will not fire when using LightBurn

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Laser will not fire when using LightBurn

This topic contains 1 reply, has 1 voice, and was last updated by  Shane 2 weeks, 3 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #105192

    Shane
    Participant

    Hello! I’m new to lasering, and I’m issues with the laser not firing when using LightBurn

    I’m using a recently built MPCNC with a LA03-3500 3.5W blue laser from Banggood.
    Controller is RAMPs 1.4 running Marlin 2.0 (downloaded from the V1 Engineering website).
    I modified the FW to remap pin 9 (12v) to pin 44 (5v) to control the laser via TTL. I also changed the polarity on the TTL cable as they seem to have shipped backwards. I can control the laser just fine via the fan speed setting on the LCD, and it also works from a gcode file saved to the SD card.

    I can control the MPCNC fine from LightBurn, but i get echo:Unknown command: "G21 G54 in the console window whenever I move it. I also get an “unknown command” response when sending “$$”

    Any ideas what else I can try? I’m really anxious to get this working!

    Console output from when LightBurn first connects:

    start

    echo:Marlin bugfix-2.0.x
    echo: Last Updated: 2018-01-20 | Author: (V1 Engineering, Ryan, 302)
    echo:Compiled: Jun 26 2019
    echo: Free Memory: 3688 PlannerBufferBytes: 1456
    echo:Hardcoded Default Settings Loaded
    echo: G21 ; Units in mm (mm)
    echo: M149 C ; Units in Celsius
    echo:Filament settings: Disabled
    echo: M200 D3.00
    echo: M200 D0
    echo:Steps per unit:
    echo: M92 X200.00 Y200.00 Z800.00 E200.00
    echo:Maximum feedrates (units/s):
    echo: M203 X120.00 Y120.00 Z30.00 E25.00
    echo:Maximum Acceleration (units/s2):
    echo: M201 X400.00 Y400.00 Z200.00 E2000.00
    echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    echo: M204 P400.00 R3000.00 T400.00
    echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
    echo: M205 B20000.00 S0.00 T0.00 J0.00
    echo:Home offset:
    echo: M206 X0.00 Y0.00 Z0.00
    echo:Material heatup parameters:
    echo: M145 S0 H196 B92 F0
    echo: M145 S1 H240 B110 F0
    echo:PID settings:
    echo: M301 P17.98 I0.98 D83.62
    echo:SD card ok

    #105194

    Shane
    Participant

    LightBurnSettings

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.