Laser engraving – not really getting great results

New Home Forum Mostly Printed CNC – MPCNC Advice – MPCNC Laser engraving – not really getting great results

This topic contains 310 replies, has 25 voices, and was last updated by  Jamie 1 week, 2 days ago.

Viewing 11 posts - 301 through 311 (of 311 total)
  • Author
    Posts
  • #112205

    Tim
    Participant

    Just to help others that might wind up here, I also resolved a similar issue I was facing with my RAMPS/Marlin/Endurance 10w+ by only using planner.check_axes_activity() . Vector lines from LightBurn were fine but as soon as I started to use fill I had poor results.

    Endurance 10w+ supports 12v PWM so I’m using https://github.com/Allted/Marlin/archive/MPCNC_Ramps_T8_16T_LCD_32step.zip with just the planner.check_axes_activity change.

     

    1 user thanked author for this post.
    #112207

    Ryan
    Keymaster

    Thank you! I knew there was something else I was supposed to be changing in the firmware!

    #117459

    Kyle
    Participant

    Hey Tim could you explain what all you changed in the marlin.cpp file? I am trying to recreate the fix Aaron had made to the cpp file for the latest firmware (412) but making only the below changes I do not seem to be getting the same quality i was in my previous firmware.

    Did you just remove the “()” from that line? Bellow is what I took from reading this thread and copied from Aarons file

    // Limit check_axes_activity frequency to 10Hz
    //static millis_t next_check_axes_ms = 0;
    //if (ELAPSED(ms, next_check_axes_ms)) {
    planner.check_axes_activity();
    // next_check_axes_ms = ms + 100UL;
    //}

     

    #117868

    Tim
    Participant

    Kyle,

    What you have there looks right. I just commented out the if ELAPSED... logic and just have it calling planner.check_axes_activity(); like this shows.

    Maybe something else is wrong?

    -Tim

    #117871

    Kyle
    Participant

    Ok thanks Tim. Yeah it looks like the laser is still firing a little early / late sometimes I might flash back to the old firmware and see if I still have the same issues or not.  I don’t think I was but maybe I’m wrong

    #117873

    Kyle
    Participant

    Hey Tim did you enable FAST_PWM_FAN in configuration.h? (I have also tried an upload with this and seem to have the same issue still

    I confirmed that 302 firmware has the same issues with the “if enabled….” commented out. guess I was just looking closer. what speeds can you typically scan at? anything over 20mm/s will give some noticeable issues laser timing/firing issues

    • This reply was modified 1 month ago by  Kyle.
    #118256

    Andrew Turner
    Participant

    I just thought I would share my experience here just in case anyone else finds it helpful. I built my MPCNC a few months ago and have been using it with a router. I bought the kit from Ryan and got the full Rambo 1.4  with dual end stops. It works great for what I need it for – I’ve actually sold a few things already.

    I just recently I added a JTech 2.8w laser – I bought their laser and driver combo that comes with the 2.8w diode laser and driver that accepts a PWM input (https://jtechphotonics.com/?product=new-2-8w-laser-and-2-5amp-safety-compliant-driver-kit-with-us-style-power-adapter).

    I tried looking through the JTech and V1 documentation and forums but I couldn’t find instructions for my specific board and laser. The JTech instructions for the MPCNC are for a Ramps board and a lot of the forum posts and other instructions I found were for 5V PWM not the 12V – I didn’t realize this at first, so for awhile I was trying to get my laser to work with the 5V output from PIN 45 and was getting frustrated. Then I realized that Ryan’s instructions (https://www.v1engineering.com/lasers/) specifically tells you what to do for JTech 12V lasers, I just missed it somehow the first time I read through it.

    Anyway, so I got the laser working well, using Lightburn for vector outlines. However, I was struggling with raster images and stumbled across this thread – since I was having the same issues as shown in the first post. I read through this whole thread and still wasn’t sure how to fix it (maybe it’s there, it just wasn’t clear to me) – but then I read this post https://www.v1engineering.com/forum/topic/image2gcode-free-raster-image-laser-engraving-software-modified-for-mpcnc/page/11/#post-92012 ! So, I got a fresh copy of Ryan’s firmware, made the change mentioned in the post and flashed it to my board.

    Voila! It’s working great now – just got to get my speeds and power settings dialed in…

    I just wanted to say thank you to you guys for the work you put into this fix. I wish this fix had been easier to find. I realize now that the forum threads are linked on https://www.v1engineering.com/lasers/ but maybe there could be a mention to this issue right on the instructions page?

    1 user thanked author for this post.
    #118303

    Ryan
    Keymaster

    Thanks for that. The firmware is very actively being changed to accomodate lasers right now. I hope we have a real solution shortly.

    #120212

    Kyle
    Participant

    Hey Guys,

    With the planner check in the marlin.cpp change on my firmware I get a scanned raster like the attached (ruler for scale). Is this quality expected or is there anything else someone could suggest to improve quality? There seems to be a random assortment of early/late laser activations.

    Some Details:

    • Rambo Board
    • Endurance 3.5Watt laser connected to Fan port 1
    • Lightburn Laser Software
    • Currently running 412 MPCNC Firmware (similar issues on 302 Firmware)
    • MPCNC Controlled by Octoprint

    Scan-Quality

    Attachments:
    #120553

    Frank
    Participant

    Hi there,

    I finished building my MPCNC a week ago and that process went well.  In the last couple of days I’ve been trying to get the MPCNC to be a laser engraver with limited success.  I’ve read about a zillion posts in this thread, I re-flashed my MRAMBo with the magical four lines in the Marlin.cpp file, and I’ve remapped the Fan 1 pin to the Zmin endstop pin (23).  All of that is working well and I appreciate all that everyone has done to get me this far.

    My problem is this:  When I try to print a vector file using the J Tech plugin in Inkscape I get very uneven results.  Some, but not all, of the radii print slower than the straight lines.  I’m assume that this might have to do with acceleration settings in Marlin.  I swear I read about his somewhere in this thread but I can’t find it now.

    Any help would be greatly appreciated.

     

    #120555

    Jamie
    Participant

    Try disabling junction deviation. Then after you flash, check the jerk settings and perhaps do M502 and M500 to reset them to reasonable values. (If jerk settings are zero then it will still go slow around curves.)

    More here: https://www.v1engineering.com/forum/topic/stuttering-and-slow/

    • This reply was modified 1 week, 2 days ago by  Jamie.
Viewing 11 posts - 301 through 311 (of 311 total)

You must be logged in to reply to this topic.