Issues with running Crown from ESTLCAM. No issues when using Ryans G code in Rep

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Issues with running Crown from ESTLCAM. No issues when using Ryans G code in Rep

This topic contains 15 replies, has 4 voices, and was last updated by  Daniel 3 weeks, 4 days ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #118297

    joedirt
    Participant

    So I was able to pull off the crown test with a pen by copying the G code for the crown thats posted here. However running the DXF into ESTCAM and using the engraving option per the instructions doesnt work and I get some kind of nonsense on Reptier in the print preview screen. Its almost like its making hugeeeeeeee toolpaths on top of something else. Im sure im making some kind of rookie mistake and I was hoping maybe one of you guys can help me out….

    I took a ton of screen shots and also my settings maybe im missing something? My work area is 24″X36″ btw. Im using a Rambo 1.4 with end stops.

     

     

    #118299

    joedirt
    Participant

    Sorry my attachments didnt work

    #118306

    K Cummins
    Participant

    Check the units you’re importing with. Make sure the scale is appropriate.

    #118308

    joedirt
    Participant

    Delete this mods

    • This reply was modified 3 weeks, 5 days ago by  joedirt.
    • This reply was modified 3 weeks, 5 days ago by  joedirt.
    #118310

    joedirt
    Participant

    Check the units you’re importing with. Make sure the scale is appropriate.

    Its showing as MM for import settings.

    Apparently the board doesn’t like having 8 images uploaded at once and errors out. Ill use Imgur for now.

    https://imgur.com/a/leH3INc

     

     

     

    Squiggly lines everywhere!!!

     

    • This reply was modified 3 weeks, 5 days ago by  joedirt.
    • This reply was modified 3 weeks, 5 days ago by  joedirt.
    • This reply was modified 3 weeks, 5 days ago by  joedirt.
    #118317

    joedirt
    Participant

    test-crown

    This is the code ESTLCAM output after selecting the crown and using engrave

    Attachments:
    1. test-crown.gcode
    #118325

    Ryan
    Keymaster

    the output is tiny and your Z axis is going down to 12mm.

    Make your gcode and use repetier host to visualize it.

    #118326

    K Cummins
    Participant

    Do you have another gcode previewer you can use to view that code with? There’s a chance that Repetier just isn’t handling the G02 arcs gracefully in the previews. And looking at the gcode, it’s a teeny, tiny crown. All the arc endpoints live within a 2mmX2mm area or so… Maybe import as inches? Alternately, see if there’s a way to prevent EstlCAM from using arcs. I think Marlin is still having issues with them at the moment.

    #118329

    joedirt
    Participant

    Im a bit more famliar now with ESTLCAM and I made the workspace the size of a piece of paper so I can reference the resize of the DXF crown better. One thing that throws me off is there is no type of measurement increase on ESTLCAM only “resize scale factor”.

    After using the engrave option I saved it and ran it on a browser driven g code sim

    nc-preview

     

    Then this is what it looks like in Repetier the lines do in fact look different than ryans code but its getting better…

    Mine with filament enabled:

    rep-preview

     

    This is ryans with filament disabled:

    ryan-rep

    The code I got from ESTCAM with 2 mm drop0102-test

     

    I wont be able to test it till tonight and maybe im putting too much faith into the Repetier previewer lol. But using ryans crown test worked and I would def feel better running something that looked better like his.

    #118336

    Daniel
    Participant

    I just finished building my LR2 (aside from the router I don’t have yet); I have, maybe, the same issue.

    When I use EstlCam – RepetierH to try to ‘engrave’ the crown, I have to pull the plug to keep the machine from moving off the bed – before it’s drawn anything recognizable. But, if I download Ryan’s crown gcode example it works great . I tried cnc.js as well as RH with no luck.

    I re-flashed the firmware on my board and uninstalled/reinstalled EstlCam, thinking I had messed settings up somewhere – but it didn’t help. I tried several times to carefully follow the instructions on the EstlCam Basics page here on this site… no guarantee I didn’t mess up though.

    I know that doesn’t help the conversation much yet, I’ll try using a visualization tool when I get home. If I have time maybe I’ll write up a more detailed list of steps so you can point out what I did wrong 🙂

    BTW -thanks Ryan for such an amazing machine!

    #118347

    joedirt
    Participant

    91659F4B-F9E1-4A53-9834-49EE797B089E

    So it’s working now and I will say this. Don’t put too much thought into the preview for repetier because at least on my pc it shows up kinda weird but seems to draw the same as ESTLCAM shows.

    I’m pretty paranoid so I would love to see the preview work correctly  but I did maybe like 5 successful drawings from Inkscape to Estlcam to Repetier.

     

    #118353

    joedirt
    Participant

    So question for you guys…output code of my ESTLCAM vs Ryan’s Crown. Im pretty fuzzy with Gcode so bare with me. Ive been deleting my stuff and putting in Ryans stuff for now. Idk if im supposed to be doing that and if so is there a way to automate it?

     

    Any estlcam I gcode I put out I get this…

    G90
    M03 S5000
    G00 X0.0000 Y0.0000 Z0.0000 F2100
    G00 Z2.0000 F480

     

    Ryans has this which has the G92 and no machine codes:

    G90
    G92 X0 Y0 Z0
    G00 X0.0000 Y0.0000 Z0.0000 F2100
    G00 X0.0000 Y0.0000 Z5.0000 F500
    
    
    
    #118373

    Daniel
    Participant

    It looks like you’re finding the same thing I just did.

    I compared the gcode that EstlCam generated with the gcode on Ryan’s “Test Crown 12mm/s” and found that the G92 made all the difference. I can just add that (G92) to my own generated gcode and the ‘pen’ doesn’t try to move somewhere crazy.

    I haven’t had time to study EstlCam settings or post-processing (is that what’s needed?) yet, but I’m guessing there’s a better way than deleting and inserting gcode each time?

    Busy Saturday ahead, but I’ll try to experiment and report back if I find anything helpful.

    1 user thanked author for this post.
    #118394

    joedirt
    Participant

    It looks like you’re finding the same thing I just did.

    I compared the gcode that EstlCam generated with the gcode on Ryan’s “Test Crown 12mm/s” and found that the G92 made all the difference. I can just add that (G92) to my own generated gcode and the ‘pen’ doesn’t try to move somewhere crazy.

    I haven’t had time to study EstlCam settings or post-processing (is that what’s needed?) yet, but I’m guessing there’s a better way than deleting and inserting gcode each time?

    Busy Saturday ahead, but I’ll try to experiment and report back if I find anything helpful.

    If you end up figuring out how to add it to post processor let me know.  It’s a combination of me being lazy and also possibly forgetting. If I have time tomorrow I’ll try messing with it myself.

    #118397

    Ryan
    Keymaster

    Just put it in the Starting gcode tab.

    https://www.v1engineering.com/milling-basics/

    There is a lot to take in but if you go between the crown and basics page most everything you need is in there. Tough to balance enough info to be useful and lite enough for people to actually read.

    1 user thanked author for this post.
    #118410

    Daniel
    Participant

    That worked perfectly, thanks Ryan. I never thought to look under “Texts” (it took me a while to find).

    I think it would be helpful to add one more setting in Step 2 of EstlCam Basics, right after setting the feed unit; letting poor noobs like me know that they might need to open the “Texts” tab and add G92 to the Program Start section if they don’t want their gantry wandering off the bed. Unless it’s just something specific to my setup of course.

    Thanks again!

     

    Attachments:
Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.