How to… connect

This topic contains 26 replies, has 3 voices, and was last updated by  Ryan 3 years, 11 months ago.

Viewing 27 posts - 1 through 27 (of 27 total)
  • Author
  • #3439


    My best fellow builders of the mpcnc…

    I got i smal problem of how to get my stepper motors to work right..
    And i think its somewhere in the controllers or some settings in the firmware.

    Hopefully we can help others with the same problem..
    And help me to solve te problem….

    Offcourse… what do i got..
    Power supply : 12V (240V/115V / 20A max

    Steppermotor : 42BYGHW811
    Torque : 47,0 N-cm
    Rated Voltage : 3.1V
    Axel : 5mm
    Steps : 1,8
    Rated Current : 2,5A
    Wires : 4 ( black / red / blue / green )
    resistor 1,25 Ohm
    Detent Torque : 280g-cm
    Rotor inertia : 68g-cm2
    Brand : Wantai…

    Controller A4988 : 3x ( x / y /z )

    Software : Repetier Host
    Firmware : Marlin 16 32 09/06/15 on this website

    Layout :
    At the moment i have 3 steppermotors connected to the board (ramps)
    1 on the Y
    2 on the X >> paralel connected..

    Problem :
    Arduino and Ramps seems to be working just fine with the firmware.
    Changed some settings on the website part here..
    When i start Repetier and i want to manualy control the steppers
    At 0,1 at the Y it seems oke stepper is moving
    At 1 at Y still oke stepper is moving
    At 10 at Y some movement but mostly just a sound.
    At 50 at Y only sound

    On the X all steps just sound or just a little movement

    ( dont got the Z connected yet)



    Did you set the drive current on the A4988s with this procedure?

    Current Limit = VREF × 2.5



    3.1v x 2.5A = 7.75W
    7.75W/12V= .646A
    A lot of people try and use the stated amperage. Make sure you use the amps at 12v as a



    Thank you…
    I need to look for a volt meter now…
    then im goint to try that… sure it must be oke then later…
    i let you know when done of other questions…



    lol now i got a multimeter… but not sure how to set it up….



    Lowest DC setting your meter has. black wire to the black wire on you power plug, red goes to the little silver potentiometer on the driver, be careful, the pots are very sensitive and if you miss the pot you can fry the driver. steady hands.



    I am new to this part..
    but what numbers am i looking for to come out..



    i think i got it….

    i set black on the ground of a4988
    and the red on the potentional meter ( if i got name right )
    it all reads out around 7,75W now….

    am i ready to go then ?



    It really explains it well in that video SteveC linked. You should watch that all the way through first.

    I do not like posting these numbers for things I have not tested. These numbers should work for your drivers and your motors. .25v for the Z driver, and .5v for the X and Y drivers if you have heat sinks. After you set these numbers run a continuous test program like a round spiral vase sliced for 3d printing. This will drive all the steppers continuously. You are doing this to check temperatures. If the steppers got hot you need to turn down the drivers a tiny bit. if they get really hot and it stops moving you need to turn them way down. On the other hand if they are cold after running for 10 minutes you can turn them up a tiny bit and get a little more power.

    Take your time this is a pretty good thing to learn, you can really optimize your machine right here.



    No follow the next post, test for DC voltage from the pot of vref post on your stepper driver. Please watch the video.



    oke i think i finaly got it running….

    i missed jumpers under the controllers i got 3 under each one now…
    not sure yet..
    In Repetier :
    if i press 1 on X/Y axes.. does the motor do 1 round?
    of is it right if its doing a bit more or less…



    pressing 1 should get you 1mm



    i got it layed out in front of me..
    without the moving parts…
    just boards and motors…

    just want to know how many round it should do
    if i press 1 or 10 in repetier…

    ( got flags on it to see how manny rounds it do )



    No idea that is a lot of math 10mm, 16tooth pulley, pi x r^2, 2mm pitch. Way to early for that. I can’t count for you here all mine are running at the moment.



    lol sorry… its evening here….
    looks like the Y does smaller steps then the X is doing…

    I think i should give it a go and connect it all to the rest of the cnc…
    I think its in the firmware of marlin to change that…



    Put a tape flag or something on there. Is it moving twice as far? Did you modify my firmware? Your drivers are in 1/16th stepping mode, my firmware is in 32nd. Cut all the axis steps in half and re-upload to the Arduino.



    i will try thanx
    But i also noticed that the motors dont pull them trough
    I connected one paralel (X) with belt on to them… But looks like the motors have a hard time to pull trough
    i almost wanted to end the project… and start another one because of the problems im having.
    But also want to make it work…
    So i will keep trying…..




    But how to tell cnc its without endstops…



    It does not look for them by default? Have you tried it and it is trying to home?



    Hmmm… i tried..
    But when i give a command its respond is very late or even nothing now..
    Can you see in the code under this what the problem is… i cant find it
    ( just a part of de message in repetier )

    Edit: i could not try homing because of the other thing…

    19:29:06.268 : : Extruder switched off. MAXTEMP triggered !
    19:29:06.283 : Error:Printer stopped due to errors. Fix the error and use M999 to restart. (Temperature is reset. Set it after restarting)
    19:29:07.236 : ok
    19:29:07.236 : N2 M115 *4
    19:29:07.267 : FIRMWARE_NAME:Marlin V1.0.2; Sprinter/grbl mashup for gen6 FIRMWARE_URL: PROTOCOL_VERSION:1.0 MACHINE_TYPE:Mendel EXTRUDER_COUNT:1 UUID:00000000-0000-0000-0000-000000000000
    19:29:07.267 : ok



    That is a temp error. Do yoi have a 100ohm resistor or a thermistor on t0?



    resistor.. because it worked i had no errors befor….
    now its giving me that again.
    i try another one… let you know later…maybe its broken..



    I have found a solution to that in the firmware just by accident..

    If you go to marlin firmware under “Configuration.h”
    Look for this :
    #define TEMP_SENSOR_0 0
    #define TEMP_SENSOR_1 0
    #define TEMP_SENSOR_2 0
    #define TEMP_SENSOR_BED 0

    Normaly the 0 at the end tells the machine there are sensors.. so the 0 can be a 1 or 2
    Set these to 0 and errors are gone…
    At least it works on hand mode… didnt try to let it run auto yet



    I try and keep the firmware as plug and play friendly to as many attachments as possible. I leave this on so the people 3D printing do not have to reconfigure firmware to get it running, a resistor is only a few pennies.



    i see it as a little help from me ( smiles )
    at the moment working on some things to the cnc.
    so.. its a bit quiet a few days… ( lucky you… )



    I believe you told me that the cnc dont need endstops…
    if so.. can you tell me how to set the cnc to its homing point ?
    of a start point…

    when i just start a print in repetier ( just X and Y axxes )
    one of the derections just wants to keep on going and hits the end of the cnc.
    and i need to cut the power.



    Home is where ever you start it at. Move the head by hand to right where you want home to be.

    End stops come in handy if you plan on doing a tool change. Or min and max for safety.

Viewing 27 posts - 1 through 27 (of 27 total)

You must be logged in to reply to this topic.