GRBL with dual endstops – no steppers

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC GRBL with dual endstops – no steppers

This topic contains 1 reply, has 1 voice, and was last updated by  Paul 1 week, 5 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #119532

    Paul
    Participant

    I am having trouble with the GRBL dual endstop setup.

    I have an SKR v1.4 board with the ‘GRBL on Rambo’ firmware. This is attached to a raspberry pi4 running cnc.js.

    When I connect through USB, I can send commands and receive msg from the machine just fine. So GRBL and cnc.js are talking. When the initial startup is complete the steppers do not even power on. I can slide the gantries around. If I try to jog I get an error 2 soft limits.

    However, when I flash Marlin onto the SKR board and select Marlin in CNC.js everything works fine and I’ve drawn a Crown no problems. So I’m assuming it’s a setting in GRBL somewhere. I disabled Homing Init lock and the safety door lock as well.

    Which setting should I look into and where are the stepper drivers defined?

    Thanks

    #119588

    Paul
    Participant

    case closed

    I gave up on dual endstop+GRBL and went with Marlin. I know Things are working great after I realized that when I had to reverse my Y-axis, I also had to swap the Y endstops.

    To see the two axis self-square each time I home  is quite something. Great design

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.