Gcode troubleshoot ?

This topic contains 12 replies, has 6 voices, and was last updated by  Joshua 1 day, 9 hours ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #117138

    Thanos
    Participant

    Hello to the team ! I have successfully made my first try at cutting wood but with a few drawbacks .. The issue am having is the following , With the pen I made the crown, some rectangles and some circles that went very well so I moved to cutting but unfortunately I am facing some weird moving at very certain points of the cut and it is the same at every pass the tool makes . I have 2 gcode files at my sd card for a program of a profile . The one is 2 slots and the second is the profile of the part a want to cut . Attached is the gcode file and a picture of the model . The gcode is produced by Fusion 360 using the this post processor I found in github. Also the slots are done correct and with no issues .

    https://github.com/martindb/mpcnc_posts_processor/blob/master/MPCNC_Mill_Laser.cps

    Also here is a video of the last 2 passes .

    My conclusion is that something is wrong with the gcode and not the machine but I would like to have your input .

     

    Thanks

    • This topic was modified 1 week, 4 days ago by  Thanos.
    • This topic was modified 1 week, 4 days ago by  Thanos.
    #117697

    Bill
    Participant

    There is certainly issues with the gcode. I’ll wait for others to chime in on whether they are in the Fusion 360 setting or the post processor, or both. Typically each line of gcode has a speed setting (Fxxx) and the X or Y movements are on a different line than the Z, since Z moves at a different speed than X and Y do. The gcode is also using arcs, and IIRC there were issues with arcs in some versions of the firmware. Which board and firmware are you using?

    1 user thanked author for this post.
    #117828

    Thanos
    Participant

    Hello ! Thank you for your time and your reply , I am using Ramps 1,6 with DRV8825 drivers and dual endstop firmaware . MPCNC_Ramps_T8_16T_LCD_32step_DualEndstop

    #117942

    Bill
    Participant

    The gcode issues aren’t with the firmware or hardware, they are problems with the CAM. Either you aren’t using the right post processor for Fusion 360 or you have some parameters set wrong. I could help figure out what is wrong if you were using Estlcam, but I haven’t used the CAM functions in Fusion 360. We will just have to wait for someone else to chime in, since the post processor is working right for others.

    1 user thanked author for this post.
    #117994

    Kevin Russell
    Participant

    Have you tried Guffy’s fusion 360 post processor mentioned at the bottom of this page?  https://www.v1engineering.com/milling-basics/

    I copied your code to https://ncviewer.com/ and It looks like it’s cutting a small hole at end of each pass.  I don’t see the other little hitch shown in your video.  I’m not sure why but the cutting motion is a mirror of what your video shows.

    1 user thanked author for this post.
    #118003

    Thanos
    Participant

    Hello , thank you guys for your input ! I also tried Guffy’s PP but it does the same if not more hitches . I cant figure out why these are done in the first half of the part and not in the rest . I also tried an other PP for a different machine from the Fusion library with the same results(attached is the file for a machine from fusion library) …About the mirror moves its because I have the machine set up this way and mirrors the moves .

    • This reply was modified 3 days, 17 hours ago by  Thanos.
    #118210

    Thanos
    Participant

    Ok so now I tried with .gcode generated by ESTL-CAM and the result is exactly the same , the machine cuts the half part great and the in the other half its doing the same weird hitches . The slots also came out as they should . I’m getting really confused at the moment … Its driving me crazy … I also reflashed the firmware just in case …

    #118221

    Jeffeb3
    Participant

    The gcode looks good to me, but I’m no computer.

    Does the .dxf have anything goofy in it? Like a repeated line there or something? I didn’t see anything like that in the gcode.

    What if you turn off the arcs in estlcam? Does that change anything?

    What if you cut in the air or foam instead of wood?

    If you can’t tell, I’m shotgunning it, because I can’t explain it.

    1 user thanked author for this post.
    #118227

    frosty
    Participant

    Line 86-89 of Profile-1.gcode is very suspicious:

    `G0 Z6
    G0 X49.022 Y-1.979 F2500
    G1 Z2 F100
    G1 Z-0.75`

    Likewise 145-148:

    `G0 Z6
    G0 X49.022 Y-1.979 F2500
    G1 Z1 F100
    G1 Z-1.75`

    ETA: The 1001 gcode has the same sort of thing going on but the b1-v3 doesn’t. Are you sure you are having problems with that one too? If so, what sort of hitch are you seeing and where is it in the part?

    • This reply was modified 2 days, 8 hours ago by  frosty.
    1 user thanked author for this post.
    #118230

    Bill
    Participant

    In the latest (b1-v3.gcode) you have some Z plunges at F1200, they should be no more than F480, so something isn’t setup right. Why don’t you attach the dxf or other source that you’re working from so we can see if there’s anything in there that’s causing issues. No problem if it’s proprietary, we’ll keep on muddling through with educated guesses. 🙂

    1 user thanked author for this post.
    #118236

    Bill
    Participant

    OK, I think I’ve got it… You are using the dual endstop firmware which is limited in that it doesn’t allow movements off the build area. In the gcode I see movements in the Part 4 section such as line 108 (G01 X-0.4353 Y88.7219 F600) that’s trying to move to X-0.4353. Any negative values are off your work area and not allowed. I believe it’ll just twitch there, then go to the next line and twitch until it get a valid line in which case it’ll move. Make sure your design is *all* inside the build area before generating the gcode and it should work correctly.

    2 users thanked author for this post.
    #118264

    Thanos
    Participant

    Thank you guys for the help ! The problem has been found 😛  Bill here with his last comment gave me a spark and changed the origin of the model and everything went great ! I did not know that movements outside of the digital build area are not allowed !

    #118293

    Joshua
    Participant

    You can also temporarily disable that feature by going to Motion on the screen and turn Soft Endstops off.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.