G02/G03 commands yes or no, or do I miss something else?

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC G02/G03 commands yes or no, or do I miss something else?

This topic contains 7 replies, has 4 voices, and was last updated by  Jeffeb3 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #117394

    Jethro
    Participant

    I fired my second MPCNC up today, as I brought the controller with me from the first build, I did not expect any troubles, and there was none.
    I updated that deviation setting from 0.05 to 0.1, and went for the crown.
    The first test went pretty slow around corners, same as I knew from my first build.
    On the second test I disabled the G02/G03 in Estlcam and it goes much faster around corners.
    Are the G02/G03 commands to be avoided as a rule of thumb, or are I missing some major update in my firmware. I use the dual endstop version with Marlin 2.??.
    As mentioned b4 I changed the deviation setting, b4 that my last change was the laser delay.


    #117518

    Ryan
    Keymaster

    I would love for you to run that same test with the current 412 version of the firmware. I am trying to just get above the arc threshold with the tuning.

    #117628

    Jethro
    Participant

    Grrr, forum ate my post, so now just the filed, did the update to “412” but results pretty much same.

    <iframe src=”//www.youtube.com/embed/T8D5adwZOpo?t=73s” width=”560″ height=”314″ allowfullscreen=”allowfullscreen”></iframe>

    <iframe src=”//www.youtube.com/embed/9zSpqMvIxtw?t=4s” width=”560″ height=”314″ allowfullscreen=”allowfullscreen”></iframe>

    <iframe src=”//www.youtube.com/embed/inywMF9KECo?t=1s” width=”560″ height=”314″ allowfullscreen=”allowfullscreen”></iframe>

    • This reply was modified 1 week ago by  Jethro.
    #117632

    Jeffeb3
    Participant

    Grrr, forum ate my post

    It made it to my email:

    Alright, here we go. I updated to the 412 version, had of course to do some adjustments, mainly in config.h, config.adv i compared but there were no changes to my version.

    The only other thing I touched was the pins.h remapping D9 to pin 44. For the “fan delay, I did not check, as I do not have a laser in the moment.

    I would say the behavior is pretty much the same, I did a third test with junction deviation from 0.01 > 0.05 that went a bit better, but still, there are better results when the G02/G03 commands are disabled. I can’t see any difference with the deviation setting changed.

    I found some settings in config.adv and thought they could play a role, so I played a bit with those, but quickly changed them back, as things got out of dimensions.

    // G2/G3 Arc Support
    //
    #define ARC_SUPPORT // Disable this feature to save ~3226 bytes
    #if ENABLED(ARC_SUPPORT)
    #define MM_PER_ARC_SEGMENT .3 // Length of each arc segment
    #define MIN_ARC_SEGMENTS 24 // Minimum number of segments in a complete circle
    #define N_ARC_CORRECTION 25 // Number of interpolated segments between corrections
    //#define ARC_P_CIRCLES // Enable the ‘P’ parameter to specify complete circles
    //#define CNC_WORKSPACE_PLANES // Allow G2/G3 to operate in XY, ZX, or YZ planes
    #endif

    Was maybe not so a good idea to changed them all at once.

     

    And let me put the firmware too, if someone wants to check, the two G-code files vreated with Estlcam are included too in a folder. Had to compress it in 7Zip, the normal zip-file was over 12MB.

    The zip-file just contains the Marlin and the G-code folder.

    Hope someone can use it.

    BTW, I know I have to work on my cable management, drag chains a.s.o are on the way 😀

    1 user thanked author for this post.
    #117653

    Jamie
    Participant

    Can you try M503 (reports EEPROM settings) and post the results here?  If you have not deliberately tuned your accelerations and there is nothing you are attached to, you can also try M502 and M500.  The EEPROM settings are not overwritten when you update firmware, I learned a while ago first-hand.  It is probably not your acceleration settings, but this would rule it out.

    #117655

    Jamie
    Participant

    Also for fun I plotted the gcode in Excel, and it highlights the points where the arcs start/end.  It is interesting that some of these points coincide with the jerky points in your movement, but I’m not sure what to conclude from it.  Maybe someone else will have more insight.

    excel_crown

    Attachments:
    1 user thanked author for this post.
    #117685

    Jethro
    Participant

    Here we go. I’m not so sure that the EEPROM settings are not overwritten.

    It seems that the new acceleration values (400) are stored, they were “#define DEFAULT_MAX_ACCELERATION { 600, 600, 100, 2000 }” in my previous version (402)

    >>>M503
    SENDING:M503
    echo: G21 ; Units in mm (mm)
    echo: M149 C ; Units in Celsius
    echo:Filament settings: Disabled
    echo: M200 D3.00
    echo: M200 D0
    echo:Steps per unit:
    echo: M92 X200.00 Y200.00 Z3200.00 E200.00
    echo:Maximum feedrates (units/s):
    echo: M203 X120.00 Y120.00 Z12.00 E25.00
    echo:Maximum Acceleration (units/s2):
    echo: M201 X400.00 Y400.00 Z100.00 E2000.00
    echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
    echo: M204 P400.00 R3000.00 T400.00
    echo:Advanced: B<min_segment_time_us> S<min_feedrate> T<min_travel_feedrate> J<junc_dev>
    echo: M205 B20000.00 S0.00 T0.00 J0.05
    echo:Home offset:
    echo: M206 X0.00 Y0.00 Z0.00
    echo:Endstop adjustment:
    echo: M666 X0.00 Y0.00
    echo:Material heatup parameters:
    echo: M145 S0 H196 B92 F0
    echo: M145 S1 H240 B110 F0
    echo:PID settings:
    echo: M301 P17.98 I0.98 D83.62

     

    #117687

    Jeffeb3
    Participant

    If you want to reset to what’s in Configuration.h, you can use M502.

    http://marlinfw.org/docs/gcode/M502.html

    Sometimes, it resets on it’s own, if the version written in the EEPROM doesn’t match what’s in the firmware.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.