Firmware V412 – I could use some testers

New Home Forum Updates Firmware V412 – I could use some testers

This topic contains 18 replies, has 8 voices, and was last updated by  Kyle 4 days, 13 hours ago.

Viewing 19 posts - 1 through 19 (of 19 total)
  • Author
    Posts
  • #115459

    Ryan
    Keymaster

    I have all the new firmware up for the CNC’s and Printers. I could use some testesers. I have verified all steppers work and lcds on the Ramps, Rambo, and Mini. For now teh Archim is worse than before, Ultimachine might help with the archim firmware but no confirmations.

    So I am looking for any issues you might find with the boards particularly the arc issues.

    I would really appreciate a confirmation for each board/firmware version. So if you are brave and someone has not confirmed whatever board and firmware combo I would love to hear from you.

    MP3DP – both boards are cleared. I have been using them for a few days (prints seem pretty good).

    Mini –

    Rambo series –

    Rambo Dual –

    Ramps –

    Ramps Dual –

    • This topic was modified 2 weeks, 3 days ago by  Ryan. Reason: new version 412
    2 users thanked author for this post.
    #115493

    Melvin
    Participant

    I could test. I have just been getting comfortable with flashing firmwares. I have MPCNC with RAMBo, dual endstops. Currently running 402. I just re-downloaded your latest, not even realizing it was v411! Will try this out tomorrow.

    • This reply was modified 3 weeks, 3 days ago by  Melvin.
    1 user thanked author for this post.
    #115504

    Jamie
    Participant

    Okay, I’m running 411 RAMPS now.  I can confirm the joystick works (just enabled #define JOYSTICK and that’s it, woo!).

    I’m partly disassembled so I can’t put it through a more thorough test right now, but given how the RAMPS flavor is very close to the upstream bugfix-2.0.x, I’m not anticipating any issues.

    On 402 I had previously disabled JUNCTION_DEVIATION and S_CURVE_ACCELERATION and ADAPTIVE_STEP_SMOOTHING, largely from shooting in the dark for possible CPU issues which turned out not to exist.  I’ve re-enabled them now and we will see how it goes.

    1 user thanked author for this post.
    #115505

    Ryan
    Keymaster

    I have those on and adjusted the values as well as decreased arc resolution from what I had (this was my guess for the actual problem).

    I started the firmware but the person from lulzbot changed your joystick stuff in the middle of it so I had to start again. Sadly it has been changed again so it is not the most current version of your feature. But maybe I can do a small bump in a week to get it in there.

    #115507

    Jamie
    Participant

    As far as I know, “my” latest had been accepted into bugfix-2.0.x, and others have extended it from there, so this is the best case where the local patches are not needed, just pull the upstream and it’s got the good stuff.  Same with G53/G54 (https://www.v1engineering.com/forum/topic/g54-work-offset-coordinates-bugfixed/) I’m glad a fix was implemented and more glad when I don’t have to do any patching on my end to take advantage of it.

    #115508

    Ryan
    Keymaster

    Dang the joystick stuff was just changed again a few hours ago, a big one. I forgot all about the g54…shoot. You have been busy. I am doing my best to keep up. That is why I am outsourcing the testing. Firmware updates are exciting to dig around and find all the new stuff…but once and a while it would be cool if it slowed down a bit.

    #115535

    Jeffeb3
    Participant

    Hopefully they do and then release 2.0. That will be a good place to stay for a while.

    #116447

    Ryan
    Keymaster

    Okay I just did an update to V412 – I tested it with a ramps board and LCD to fix the new LCD timing issues on the ramps and mini. Looks good. I will test the rest tomorrow morning.

    #116450

    For now the Archim is worse than before, Ultimachine might help with the Archim firmware but no confirmations.

    I finally did a successful flash of firmware for my CR10s. Never could use a pre-rolled one successfully and then couldn’t revert back to original. I have done some work with the tinyG that I have as my first foray into control boards. Been playing with rPis for a long time but just been doing Arduino and ESP32 for a year. So comfortable enough with flashing things. Just lots to learn.

    So I guess it is time for me to dig into the hardware and firmware and learn about what it takes to drive these things really. I got the v2 for the better drivers but didn’t realize the ramifications of choosing this board. So I’ll study up on this. I hope some day I can contribute. May take awhile. For the time being it just works fine and does everything I need it to. The Z probe widget on CNCjs does the opposite as documented in places, but none of the fixes have worked so far. But the homeZ works fine in the upper axis widget so I’m good with my touch plate for now.

    #116452

    Ryan
    Keymaster

    I think the V2 is working. I just saw a PR for the V1 but I have not tested it yet, only a few hours old.

    1 user thanked author for this post.
    #116496

    Tam
    Participant

    I have an Archim V1 with dual end stops and can test. I’m out of town until next week, so I’ll see if I can test when I get back.

    • This reply was modified 2 weeks, 2 days ago by  Tam.
    • This reply was modified 2 weeks, 2 days ago by  Tam.
    #116577

    Ryan
    Keymaster

    Tam, I need to do one more update the Archim 1 update just got pushed this morning by Ultimachine and it did not fix the LCD so we need to hold tight a little longer to get a current Archim 1 firmware.

    #117205

    Tam
    Participant

    Ryan, no problem. As a checkpoint, the firmware I am currently running is baselined on my github repository.  If I do run into issues, I can analyze the change requests to see what broke (apparently a lot has changed since February).

    https://github.com/aznoohwee/Marlin/tree/MPCNC_Archim1_T8_16T_LCD_DualEndstop/Marlin

    This firmware has dual endstop support and LCD.

    #117332

    Kyle
    Participant

    Hi I have a Rambo board and Willing to give the firmware a try.  Just wondering if there is a summary of changes I can see somewhere? I believe I’m on 302. I’m kind of new to GitHub so I could just be missing it.

    #117338

    Ryan
    Keymaster

    Well, not really. This is mostly a catch up to the current development branch, there have been 700+edits since the last version, and 800+ since your version. So nothing major has changed yet most of the code has been updated.

    #117348

    Kyle
    Participant

    Ok no problem!  I have a couple projects I’m finishing up this weekend so next week I’ll give it a try.

    #117357

    Anttix
    Participant

     

    EDIT: Moved my excitment to another thread.

    Will the next update revert custom changes to pins.h files now that we have https://www.v1engineering.com/forum/topic/omg-extruders-0/ ?

    • This reply was modified 1 week, 3 days ago by  Anttix.
    • This reply was modified 1 week, 3 days ago by  Anttix.
    #117509

    Kyle
    Participant

    I’ve managed to get the 412 firmware updated and everything seems to be mostly okay so far.

    Although I am noticing that If I do not probe/ set my Z minimum the Max_software_endstops does not seem to work.

    It would also appear that the laser issue I had with 302 (laser on/off timing) was still not resolved. If I use the cpp file here (https://www.v1engineering.com/forum/topic/laser-engraving-not-really-getting-great-results/page/10/#post-94989 [v1engineering.com] ) as a baseline and edit the current marlin.cpp file, I do not seem to be getting the quality I was previously. I had used Aarons marlin.cpp file on the previous 302 build but I am not sure if he change more then shown in the attached images

    #117914

    Kyle
    Participant

    looks like I was just going crazy  my previous firmware (302) and this new one (412) both have the same issue, guess I was just not looking close enough.

    So appart from the software endstops behaving differently I have not seen any new issues on my RAMBO 1.4 board with 412 firmware (Dual End Stops, 16T)

Viewing 19 posts - 1 through 19 (of 19 total)

You must be logged in to reply to this topic.