F360 > Octoprint M0 vs M00

New Home Forum Mostly Printed CNC – MPCNC Advice – MPCNC F360 > Octoprint M0 vs M00

This topic contains 1 reply, has 1 voice, and was last updated by  Dave S 3 weeks, 5 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #101192

    Dave S
    Participant

    This morning I was testing out some fresh gcode from F360 using Guffy’s post processor.   Took a while figure out all the pieces in F360 to generate a tool path and post process it, but I think I got that square.   When running it thru Octoprint I noticed that the pauses that are in the gcode for z probing etc. do not behave the same way they did for gcode generated in Estlcam.   I think it is related to the fact that Estlcam puts out a M00 (self defined), while F360 puts out a M0.   The F360 code (M0) pauses and resumes thru octoprint not LCD, while the Estlcam code (M00) pauses thru the LCD (which is what I want since Octoprint kind of buries the message in the terminal output and I had to dig for why the run stopped).

    Is there a way to change the M0 to M00 in F360.   I could not find it in the post processor files from github.  Seems like a built in thing.

    Thanks in advance,  Dave

    Sample tool change from Estlcam:

    ;No. 3: Engraving 4
    M05
    G00 Z50 ; rise for tool change
    G00 X0 ; move over to y rail
    G00 Y0 ; move to park position
    M00 Turn OFF Router
    M00 Change tool: Sharpie 1.0
    M00 Turn ON Router
    G00 Z52 ; lift a little
    M03
    G00 Y30 ; unpark

    And the default start code from F360

    ; *** START begin ***
    G90
    G21
    M84 S0
    G92 X0 Y0 Z0
    ; COMMAND_TOOL_MEASURE
    M0 Attach ZProbe
    G28 Z
    G92 Z0.92
    G0 Z12 F300
    M400
    M0 Detach ZProbe
    ; *** START end ***

     

     

    #101279

    Dave S
    Participant

    Update to verify that there is in fact a difference in how M0 with Octoprint.

    M0 – Pauses thru the Octoprint host

    M00 – Pauses thru the LCD

    because M00 is passed to the printer directly.   By default M0 is processed locally by Octoprint.  Apparently, there is  a setting in Octoprint to change the behavior as of 1.3.9.

    https://github.com/foosel/OctoPrint/issues/1513

     

    1 user thanked author for this post.
Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.