Estilcam gcode differences

New Home Forum LowRider Troubleshooting – LowRider Estilcam gcode differences

This topic contains 8 replies, has 3 voices, and was last updated by  Ryan 2 weeks ago.

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #108632

    Ray Drapela
    Participant

    I’ve constructed a lowrider2 and ran the crown no problem. I fired up Estilcam 11.040 and inputed the 611dxf. Z feed problems.

    Opened gcode in text editor and no feedrate for first z move.

    opened crown and feedrates on every line.

    How do I get estillcam to post process correctly?

    I currently have to hand set feedrates but can’t do a 1200 page gcode hand edit.

    How did you get the crown code to generate the feedrates on every line?

    Sorry for my excitement but am eager to collect sawdust.

    #108678

    Jamie
    Participant

    In this box, the highlighted check box causes repeating feedrate “F” on every line. Without this checked, Estlcam will guess whether the F is needed or not.

    From here https://www.v1engineering.com/estlcam-basics/

     

    1 user thanked author for this post.
    #108820

    Ray Drapela
    Participant

    Although I printed out that page I missed that checkbox. Still notice a small problem.

    G90
    M03 S20000
    G00 Z5.0000 F480
    ;No. 1: 
    G00 X-3.0000 Y23.6000 F2100
    G01 Z-1.0000 F1200 S20000
    G01 Y396.4000 F1200
    G01 X2.2000 Y397.6000 F1200
    G01 Y22.4000 F1200
    G01 X7.0000 F1200
    G01 Y397.6000 F1200
    G01 X12.2000 F1200
    G01 Y22.4000 F1200
    G01 X17.0000 F1200
    G01 Y397.6000 F1200
    G01 Z0.5000 F1200
    I have tool feedrate for x,y =1200 Z =480 (mm/min)
    the max feedrate for x,y =2100 Z =480 (mm/min)
    so why am I getting Z feeds F1200?
    Thank-you Jamie
    Thank-you Ryan
    #108824

    Jamie
    Participant

    Your third line shows your rapids are okay at 480.

    For the Z feed rate it’s in the tool definition for “F(z)”.  This will normally be much less than “F(xy)”

     

    #108966

    Ray Drapela
    Participant

    I agree the 3rd line is working fine. (I’m cutting softwood and foam so more concerned about weight and resonances in carriage.)

    The small problem I’m talking about is after line 3 the Z feeds are same as x-y which is too high for the Z.

    I included enough code to show 2 G01 Zfeeds at 1200, or am I missing something.

    I figured I would learn how to use the machine by trial and error, but with a conservative adventuring.

    I’ve done 1 carving into mdf that worked great but I had manually set all feeds to 480 (search and replace).

    Sorry for not being clear in my previous missive.

    And again Thank you!

    #108975

    Ryan
    Keymaster

    Uninstall and reinstall if you are sure all the other settings are correct. It looks good but passing the wrong value.

    #108987

    Jamie
    Participant

    I included enough code to show 2 G01 Zfeeds at 1200, or am I missing something.

    Yes I agree, I think this is your problem. This is defined in the box that lists all your tools. 1200 mm/min means you have 20 mm/sec in your F(z) column which is much too high. Change F(z) to 8 mm/sec and you wont need search and replace to get 480 in your gcode. (Or even slower might be better.)

    #109013

    Ray Drapela
    Participant

    Sir Keymaster:

    I did fresh install of latest version Estlcam 11.115.

    Brought in a rectangle dxf, holed and pocketed and corner relieved. Gcode was proper all z feeds were as specified.

    The problem is the handling of stl files. I brought one in and upon examining the gcode generated from free machining it doesn’t output proper Z feeds.

    I realize this is a problem with Estlcam but perhaps you could tell Christian he may have a Z feedrate problem in stl free machining.

    #109116

    Ryan
    Keymaster

    @christian-knuell If your not to busy we have two open bugs for you. The one above Z speeds not correct in STL free machining and V carve points are backwards starting from the point not the open pocket at least when using a flat endmill for the roughing.

     

    • This reply was modified 2 weeks ago by  Ryan.
Viewing 9 posts - 1 through 9 (of 9 total)

You must be logged in to reply to this topic.