Teaching Tech Skr 1.3

New Home Forum LowRider Advice – LowRider Teaching Tech Skr 1.3

This topic contains 22 replies, has 4 voices, and was last updated by  Rick Hamner 3 days, 3 hours ago.

Viewing 23 posts - 1 through 23 (of 23 total)
  • Author
    Posts
  • #120420

    Dak
    Participant

    The issue I had has been resolved. I also uploaded precompiled firmware for everyone to enjoy 🙂 See post here

     

     

    —Original Post—

    Hello all!

    SKR 1.3

    I’m following Teaching Tech’s video on the LowriderV2. In it he has his Y endstops home to the back, where I want mine to home to the front.

    I’ve changed #define Y_HOME_DIR 1 to #define Y_HOME_DIR -1 in configuration.h, and it moves the Y axis in the correct direction, but the actual endstops aren’t triggering.

    All others work flawlessly, and I’ve confirmed that they are wired correctly. Any ideas of what else should need changed? The only thing I can think of is that in the advanced config #define Y2_USE_ENDSTOP _YMIN_ is set instead of #define Y2_USE_ENDSTOP _YMAX_. Could this be it?

    Thanks 🙂

    • This topic was modified 1 week, 3 days ago by  Dak.
    • This topic was modified 1 week, 3 days ago by  Dak.
    • This topic was modified 1 week, 1 day ago by  Dak. Reason: Issue fixed, changed title so people can find this easier
    #120429

    Jeffeb3
    Participant

    The only thing I can think of is that in the advanced config #define Y2_USE_ENDSTOP _YMIN_ is set instead of #define Y2_USE_ENDSTOP _YMAX_. Could this be it?

    Yep.

    You can test with M119 to shoe you the state of the endstops.

    #120660

    Rick Hamner
    Participant

    Can you tell me how you got the firmware to flash that tt edit for the skr 1.3?

    I have put just the fm for the 1.3 on the root of the microcard and booted on with no luck. I even tried a second card. I was able to do the firmware on the lcd screen with no issues. Not sure if it certain jumpers needs to be in place. I’m using 5160 with this.

    Or am I to use pronterface to upload the file.

    Thanks

    #120667

    Jeffeb3
    Participant

    I think you have to compile it first with platform.io

    1 user thanked author for this post.
    #120677

    Rick Hamner
    Participant

    Well it got the best of me.  Spent the whole day on this and got no where..

    I tried to compile with Atom and then VSCode.

    I’ve watch so many videos of what to add to be able to compile.

    It’s rough on a two meg connection for internet.

    I get 1 failed and 0 succeeded.

    LPC1768 Failed

    Everything else ignored as should be.

    Platformio.ini  left as TT had it..

    [platformio]
    src_dir = Marlin
    build_dir = .pioenvs
    lib_dir = .piolib
    libdeps_dir = .piolibdeps
    boards_dir = buildroot/share/PlatformIO/boards
    env_default = LPC1768

     

    and further down….

    [env:LPC1768]
    platform = https://github.com/p3p/pio-nxplpc-arduino-lpc176x/archive/master.zip
    framework = arduino
    board = nxp_lpc1768
    build_flags = -DTARGET_LPC1768 -DU8G_HAL_LINKS -IMarlin/src/HAL/HAL_LPC1768/include -IMarlin/src/HAL/HAL_LPC1768/u8g ${common.build_flags}
    # debug options for backtrace
    # -funwind-tables
    # -mpoke-function-name
    lib_ldf_mode = off
    lib_compat_mode = strict
    extra_scripts = Marlin/src/HAL/HAL_LPC1768/upload_extra_script.py
    src_filter = ${common.default_src_filter} +<src/HAL/HAL_LPC1768>
    monitor_speed = 250000
    lib_deps = Servo
    LiquidCrystal
    U8glib-HAL=https://github.com/MarlinFirmware/U8glib-HAL/archive/dev.zip
    [email protected]<1.0.0
    Adafruit NeoPixel=https://github.com/p3p/Adafruit_NeoPixel/archive/master.zip

     

    I’m sure there something simple I’m over looking..

    Anyone have know what my issue is?

    Thanks..

    #120685

    Jeffeb3
    Participant

    Is there other details around the message that it failed?

    If it helps, remember that this isn’t like trying to understand nature or even psychology. This system was designed for humans to use, by humans. It’s far from perfect, but it is doable.

    #120686

    Dak
    Participant

    I had the same issue. For some reason the upload_extra_script.py is different than what’s on the official, so replacing it fixed the problem for me.

    To save you (and anyone else who finds this thread) the problems of compiling it themselves, just see attached 🙂

    There’s two versions. One is the default with the Y axis to the back (how TT has it) and the second is with it to the front.

    Just unzip the file, choose the one you want, throw it onto the Micro SD card in the SKR and you should be good to go 🙂

    1 user thanked author for this post.
    #120704

    Rick Hamner
    Participant

    Thanks for the files.  I just went and compared both files then replace the file as well.  It compiles!!!

    Thanks.. thanks..

    #120716

    Rick Hamner
    Participant

    Ok I put my microsd back in and I power the board on and after about 15 seconds. I get message on the lcd:  Error Printer halted. kill () called!

    I have nothing hooked to the board as of yet.

    Only jumpers I got set is the four under each driver like tt shows and the two red near the x endstop connectors. (left +5v jumper in place)

    I’m using 5160 drivers and without any mods to them.  I’ve seen to much where you do and you don’t do anything to them.

    I unplug hook up x only and go into move x and nothing.

    Thanks..

     

    #120718

    Ryan
    Keymaster

    You need to enable the fake thermistor and add a value of 170 for it, or extruders=0.

    #120725

    Rick Hamner
    Participant

    Ryan this is what I got and same issue. I did not try to undefine the extruders. If I put Extruders 0 then it won’t compile.

    // This defines the number of extruders
    // :[1, 2, 3, 4, 5, 6]
    #define EXTRUDERS 1


    // Dummy thermistor constant temperature readings, for use with 998 and 999
    #define DUMMY_THERMISTOR_998_VALUE 170
    #define DUMMY_THERMISTOR_999_VALUE 170

    #120726

    Ryan
    Keymaster

    If you can’t set 0 it is an older version of Marlin. To set the dummy it is two line, one to specify 999 and the one you show to set the value. Look a few lines up for thermistor defines (probably says 11 right now) change it to 999

    #120730

    Rick Hamner
    Participant

    This is what already set:

    Use these for Testing or Development purposes. NEVER for production machine.
    * 998 : Dummy Table that ALWAYS reads 25°C or the temperature defined below.
    * 999 : Dummy Table that ALWAYS reads 100°C or the temperature defined below.
    *
    * :{ ‘0’: “Not used”, ‘1’:”100k / 4.7k – EPCOS”, ‘2’:”200k / 4.7k – ATC Semitec 204GT-2″, ‘3’:”Mendel-parts / 4.7k”, ‘4’:”10k !! do not use for a hotend. Bad resolution at high temp. !!”, ‘5’:”100K / 4.7k – ATC Semitec 104GT-2 (Used in ParCan & J-Head)”, ‘501’:”100K Zonestar (Tronxy X3A)”, ‘6’:”100k / 4.7k EPCOS – Not as accurate as Table 1″, ‘7’:”100k / 4.7k Honeywell 135-104LAG-J01″, ‘8’:”100k / 4.7k 0603 SMD Vishay NTCS0603E3104FXT”, ‘9’:”100k / 4.7k GE Sensing AL03006-58.2K-97-G1″, ’10’:”100k / 4.7k RS 198-961″, ’11’:”100k / 4.7k beta 3950 1%”, ’12’:”100k / 4.7k 0603 SMD Vishay NTCS0603E3104FXT (calibrated for Makibox hot bed)”, ’13’:”100k Hisens 3950 1% up to 300°C for hotend ‘Simple ONE ‘ & hotend ‘All In ONE'”, ’20’:”PT100 (Ultimainboard V2.x)”, ’51’:”100k / 1k – EPCOS”, ’52’:”200k / 1k – ATC Semitec 204GT-2″, ’55’:”100k / 1k – ATC Semitec 104GT-2 (Used in ParCan & J-Head)”, ’60’:”100k Maker’s Tool Works Kapton Bed Thermistor beta=3950″, ’61’:”100k Formbot / Vivedino 3950 350C thermistor 4.7k pullup”, ’66’:”Dyze Design 4.7M High Temperature thermistor”, ’67’:”Slice Engineering 450C High Temperature thermistor”, ’70’:”the 100K thermistor found in the bq Hephestos 2″, ’71’:”100k / 4.7k Honeywell 135-104LAF-J01″, ‘147’:”Pt100 / 4.7k”, ‘1047’:”Pt1000 / 4.7k”, ‘110’:”Pt100 / 1k (non-standard)”, ‘1010’:”Pt1000 / 1k (non standard)”, ‘-4’:”Thermocouple + AD8495″, ‘-3’:”Thermocouple + MAX31855 (only for sensor 0)”, ‘-2’:”Thermocouple + MAX6675 (only for sensor 0)”, ‘-1′:”Thermocouple + AD595″,’998’:”Dummy 1″, ‘999’:”Dummy 2″ }
    */
    #define TEMP_SENSOR_0 999
    #define TEMP_SENSOR_1 0
    #define TEMP_SENSOR_2 0
    #define TEMP_SENSOR_3 0
    #define TEMP_SENSOR_4 0
    #define TEMP_SENSOR_5 0
    #define TEMP_SENSOR_BED 0
    #define TEMP_SENSOR_CHAMBER 0

    // Dummy thermistor constant temperature readings, for use with 998 and 999
    #define DUMMY_THERMISTOR_998_VALUE 170
    #define DUMMY_THERMISTOR_999_VALUE 170

    // Use temp sensor 1 as a redundant sensor with sensor 0. If the readings
    // from the two sensors differ too much the print will be aborted.
    //#define TEMP_SENSOR_1_AS_REDUNDANT
    #define MAX_REDUNDANT_TEMP_SENSOR_DIFF 10

    #120901

    Rick Hamner
    Participant

    Would soldering clk to gnd solve this?

    #120915

    Jeffeb3
    Participant

    You can wire a resistor in the T0 port. But the software solution should work.

    Here is a link to exactly how Ryan does it:

    https://github.com/Allted/Marlin/blob/MPCNC_MRambo_T8_16T_LCD/Marlin/Configuration.h#L406

    #120977

    Rick Hamner
    Participant

    Other then I put my 998 value to 170 to test.. all other vaules look same as I posted above.. I could be over looking something.. it does show I have:  #define TEMP_SENSOR_0 999 and #define DUMMY_THERMISTOR_999_VALUE 170

    Could I have another problem?  Does the lcd need a different power source? LCD powers on when connected to the skr 1.3

    #120983

    Jeffeb3
    Participant

    I guess we just assumed it was a temperature problem but other things can cause a halt.

    Commecting with repetier host might let you see more detail over the serial port.

    You can also try without the lcd.

    #120986

    Dak
    Participant

    Do you have all the motors plugged in? That caused the issue for me. Once everything was plugged in it worked correctly.

    You don’t need a thermistor with the SKR 1.3 build from TT

    #121006

    Rick Hamner
    Participant

    I don’t have everything plugged in.  I only tried with X.   The temp outside drop from 72 yesterday to 18 so it might be a bit before I try.  Thanks everyone.  I will report back either way after I try all hook up.

    #121378

    Rick Hamner
    Participant

    Ok I made it back outside.

    Still same error.  I hook everything up but the endstops.

    Do the endstops have to be hooked up to not get the error?

    So we are sure I don’t need a resistor or clk to gnd or any other mod?

    I’m having to leave to watch my kids basketball game so no time to wire up endstops right now.

     

    thanks everyone..

    #121379

    Jeffeb3
    Participant

    I think you should hook up repetier host to see what the error message is that gets printed on the serial port. That would help a lot.

    #121405

    Rick Hamner
    Participant

    I will give this a try tomorrow. Thanks

    #121530

    Rick Hamner
    Participant

    Ok with repeater host:

    LCD display with in a few seconds: Testing X connection.. Error: All low

    and repeater host displays:

    17:00:08.948 : No start signal detected – forcing start
    17:00:09.026 : FIRMWARE_NAME:Marlin bugfix-2.0.x (Github) SOURCE_CODE_URL:https://github.com/MarlinFirmware/Marlin PROTOCOL_VERSION:1.0 MACHINE_TYPE:V1 E CNC EXTRUDER_COUNT:1 UUID:cede2a2f-41a2-4748-9b12-c55c62f367ff
    17:00:09.026 : Cap:SERIAL_XON_XOFF:0
    17:00:09.026 : Cap:BINARY_FILE_TRANSFER:0
    17:00:09.026 : Cap:EEPROM:1
    17:00:09.026 : Cap:VOLUMETRIC:1
    17:00:09.026 : Cap:AUTOREPORT_TEMP:1
    17:00:09.026 : Cap:PROGRESS:0
    17:00:09.026 : Cap:PRINT_JOB:1
    17:00:09.026 : Cap:AUTOLEVEL:0
    17:00:09.026 : Cap:Z_PROBE:0
    17:00:09.026 : Cap:LEVELING_DATA:0
    17:00:09.026 : Cap:BUILD_PERCENT:0
    17:00:09.026 : Cap:SOFTWARE_POWER:0
    17:00:09.026 : Cap:TOGGLE_LIGHTS:0
    17:00:09.026 : Cap:CASE_LIGHT_BRIGHTNESS:0
    17:00:09.026 : Cap:EMERGENCY_PARSER:0
    17:00:09.026 : Cap:PROMPT_SUPPORT:0
    17:00:09.026 : Cap:AUTOREPORT_SD_STATUS:0
    17:00:09.026 : Cap:THERMAL_PROTECTION:1
    17:00:09.026 : Cap:MOTION_MODES:1
    17:00:09.026 : Cap:CHAMBER_TEMPERATURE:0
    17:00:09.026 : X:0.00 Y:0.00 Z:40.00 E:0.00 Count X:0 Y:0 Z:32000
    17:00:09.026 : echo:DEBUG:INFO,ERRORS
    17:00:09.026 : Begin file list
    17:00:09.026 : End file list
    17:00:09.026 : echo:Unknown command: “M80”
    17:00:09.026 : echo:DEBUG:INFO,ERRORS

    I don’t have endstops hooked up as of yet if that makes any difference.  If I don’t get this going soon I will just hook up the minirambo back up.

Viewing 23 posts - 1 through 23 (of 23 total)

You must be logged in to reply to this topic.