Dual Endstops Triggered

This topic contains 6 replies, has 5 voices, and was last updated by  Jamie 1 week, 3 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #119802

    Chas
    Participant

    Hi all,

    These are the default outputs for m119 of my MPCNC using Rambo 1.4 dual endstop firmware. Does anyone have any idea how to troubleshoot the

    15:21:01.540 : Reporting endstop status
    15:21:01.540 : x_min: TRIGGERED
    15:21:01.540 : x2_min: open
    15:21:01.540 : y_min: TRIGGERED
    15:21:01.541 : y2_min: TRIGGERED
    15:21:01.541 : z_min: open

    15:21:01.541 : z_max: TRIGGERED

    Just pressed x2_min w/ m119 and it turned to “Triggered” and isn’t turning back… wondering why I can turn them all to open by default??

    #119827

    Jeffeb3
    Participant

    Look at the wiring. It should be on the (s) and (-) on the board and common and NC on the switch.

    1 user thanked author for this post.
    #120134

    Chas
    Participant

    I believe it’s right… correct me if I’m wrong please…

    Also, is there a reliable earlier version of marlin I can use for dual endstops, jtech photonics laser, and before the current version? Rambo1.4DualEndstopLinux.

    #120137

    Ryan
    Keymaster

    You need to bend the wires away from the bearing, did the bearing wear through the plugs and short them?

    #120389

    Chas
    Participant

    That doesn’t appear to be the case. .

    #120393

    Richard
    Participant

    In Chas post above, he shows the M119 report as:

    15:21:01.540 : x_min: TRIGGERED
    15:21:01.540 : x2_min: open
    15:21:01.540 : y_min: TRIGGERED
    15:21:01.541 : y2_min: TRIGGERED
    15:21:01.541 : z_min: open

    15:21:01.541 : z_max: TRIGGERED

    When I run M119, I don’t get a status on the z_maz?  I’m using the Duel End stop code.  Any idea why all 6 sensors wouldn’t be reported?

     

    #120413

    Jamie
    Participant

    When I run M119, I don’t get a status on the z_maz? I’m using the Duel End stop code. Any idea why all 6 sensors wouldn’t be reported?

    Within Configuration.h in the firmware you can find a section that looks like this:

    #define USE_XMIN_PLUG
    #define USE_YMIN_PLUG
    #define USE_ZMIN_PLUG
    //#define USE_XMAX_PLUG
    //#define USE_YMAX_PLUG
    #define USE_ZMAX_PLUG

    This will define which endstops exist and are reported by M119

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.