Dual Endstops "jitters" in endstops

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Dual Endstops "jitters" in endstops

Tagged: 

This topic contains 2 replies, has 2 voices, and was last updated by  Joe 2 weeks, 5 days ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #111832

    Joe
    Participant

    Hi everyone,

    I’ve been very happily been using my MPCnC with a knife to cut paper and foil templates. I wanted to go dual endstops and added the endstops, flashed the new firmware from the branch, checked my endstops with M119 and then triggered a homing with G28 X.

    I was surprised when the carriages hit the endstops, but the motors didn’t stop turning. The carriages repeatedly hit the endstops. I quickly turned the power off and repeated the procedure, however manually triggered the endstops, while the carriages were still far away. The carriages stopped correctly.

    I’m flumoxed. Any ideas? Will be checking the switches, to see If that has an influence.

    #111851

    Ryan
    Keymaster

    Make sure they are on the correct side, X1 with X1. Each endstop should get hit twice, it is called a bump. This increases accuracy.

    1 user thanked author for this post.
    Joe
    #111881

    Joe
    Participant

    Ryan,

    I don’t know how many time i checked the endstop wiring, never did it occur to me, to crosscheck with the motors! That was it! Thank you!

    1 user thanked author for this post.
Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.