Dual Endstop Issue. Y Axis Rams the endstop

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Dual Endstop Issue. Y Axis Rams the endstop

This topic contains 12 replies, has 5 voices, and was last updated by  Ryan 1 week ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #104849

    Joel
    Participant

    Hi Everybody.

    I´m finishing the assembly of the MPCNC with Dual Firmware.
    I´ve already installed the Dual Endstop on each of X & Y Axis and they are connect to the board as Ryan suggested.
    From both ways (Repetier & direct from the LCD Screen) the Y axis rams the endstop when I send to home, it does not stop when either sides endstop are reached.

    With the command M119 I´ve checked the endstops status and they are fine NC and if I trigered by hand and check again they change fine.

    X axis works fine and makes Home great with both endstop, but Y does not.

     

    Any suggestion???

    Thanks in advance

    #104858

    Erwin Vigilia
    Participant

    If you manually step in a negative Y direction, does the gantry move towards your microswitch? If it doesn’t, both Y motors need to be reversed.

    #104871

    Ryan
    Keymaster

    What board, what firmware, what exactly does M119 say for it’s list of stops available?

    #104896

    Joel
    Participant

    No, it moves away from the endstop with positive values, if a I move it back , it goes fine until 0 and it stops there, it does no goes below 0.

    #104927

    Joel
    Participant

    It´s a RAMBo dual firmware got it from here.

    When the endstops are not pushed/activated by any axis, M119 says:
    19:10:16.318 : N17 M119*28
    19:10:16.318 : Reporting endstop status
    19:10:16.318 : x_min: open
    19:10:16.318 : x2_min: open
    19:10:16.318 : y_min: open
    19:10:16.318 : y2_min: open
    19:10:16.318 : z_min: open
    19:10:16.318 : z_max: open

    When pushed  one of each

    19:12:31.343 : N18 M119*19
    19:12:31.343 : Reporting endstop status
    19:12:31.343 : x_min: open
    19:12:31.343 : x2_min: TRIGGERED
    19:12:31.343 : y_min: open
    19:12:31.343 : y2_min: TRIGGERED
    19:12:31.343 : z_min: open
    19:12:31.343 : z_max: open

    #104993

    Ryan
    Keymaster

    Are you sure you have the correct steppers and endstops paired?

    Using repetier,

    G28 Y

    Manually hit both endstops with your fingers, twice, 3 seconds apart (sym a bump). What happens, what direction do they head?

    #105021

    Joel
    Participant

    Hi Ryan.

     

    Please see the video and pics.

    Endstop are fine and stepers too. Only the closest steper is the one that rams the endstop.

    https://photos.app.goo.gl/zYaA7qxgRDuq2Tzj8

    Switch closes and opens fine, tested with M119

    #105026

    Joel
    Participant

    If I hit manually twice (3 sec apart) it stops fine!!

    #105027

    Jamie
    Participant

    I think your endstops are reversed. Ymin should be on the “Y” port while ymax should be on the “E1” port. You are showing “Y” colored stepper wires with black and white endstop on Ymax.

    2 users thanked author for this post.
    #105028

    Joel
    Participant

    DONE!!!!

     

    Endstop X1 was on stepper X2

     

    Kind regards!

    #105029

    Joel
    Participant

    Thanks, that was exactly what was going on!

    #105996

    adam57
    Participant

    Bonjour à tous

     

    Voila ma MPCNC est monter et marche

    Mon problème est les fin de course qui ne marche pas j’ai essayer comme sur cette photos

    avez vous des propositions

    Merci

    Voila my MPCNC is up and walking

    My problem is the end of race that does not work I try as in this photos

    do you have any proposals

    Thank you

    Attachments:
    #106084

    Ryan
    Keymaster

    Endstops only work when homing, G28 X Y.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.