Dual Endstop Homing/Offset

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Dual Endstop Homing/Offset

This topic contains 6 replies, has 5 voices, and was last updated by  Barry 2 weeks, 5 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #119175

    Chas
    Participant

    Hey all,

    I’m noticing all of my endstops are by default “triggered” whether I press each limit switch or not. I’m wondering if there’s something I can modify in the firmware, or if something is wrong with my Rambo, or repetier. Any feedback would be appreciated.

    I’m using Ubuntu 18.04

    Repetier Host applinux

    Rambo 1.4 board

    Marlin-MPCNC_Rambo_T8_16T_LCD_DualEndstop firmware

    #119198

    Jeffeb3
    Participant

    I’m using Ubuntu 18.04

    High five!

    all of my endstops are by default “triggered” whether I press each limit switch or not

    That shouldn’t be the behavior of the endstops in the default firmware. On the board it should be between the (s) and (-) pins. Unless you’ve got special endstops, you shouldn’t use the (+). On the endstop, it should be on the C (common, middle) and the NC (normally closed).

    #119233

    Chas
    Participant
    #119272

    Chris Gifford
    Participant

    I am also having an issue.  Endstops are wired correctly (double checked with a multimeter).  They are reporting triggered when they are really open.

     

    *EDIT* I figured it out…the multimeter lies

    #119286

    Chas
    Participant

    Pictures of said limit switch connections and wiring…

    Chris Gifford, what changed for you in your situation???

    #119354

    Michael McCallum
    Participant

    Just as an FYI, when I first checked the endstops without the proper software, they showed triggered.  After installing the proper Rambo software, they show open even though they are wired normally closed.  Ryan must have taken care of this in the code.

    I do have one issue.  My area is about 14” x 14”. If the spindle is far from the home point, the software seems to time out before it finds the endstops.  Is there a time or distance number I need to update?

    #119360

    Barry
    Participant

    Just as an FYI, when I first checked the endstops without the proper software, they showed triggered. After installing the proper Rambo software, they show open even though they are wired normally closed. Ryan must have taken care of this in the code.

    I do have one issue. My area is about 14” x 14”. If the spindle is far from the home point, the software seems to time out before it finds the endstops. Is there a time or distance number I need to update?

    Bed dimensions are in the firmware, I think the default is 200mm square.  I think if you search for soft stops you can find it, or Ryan or Jeff will chime in later and say where it is.

    1 user thanked author for this post.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.