dual endstop different x0/x1 and y0/y1 movement

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC dual endstop different x0/x1 and y0/y1 movement

This topic contains 1 reply, has 2 voices, and was last updated by  Ryan 2 weeks, 4 days ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #111995

    Glen
    Participant

    Hello,

    I have noticed today that I have considerably different movement for the 10mm movement command via the display unit:

    10mm desired:  actual x0=8.3mm, x1=16.3mm, y0=11.1mm, y1=5.9mm

    It is very consistent, and is not a mechanical issue.

    There is no way to calibrate the X1 separately from X0, and, similarly, no way to calibrate Y0 from Y1.

    So, I must have something wrong in the firmware.

    I have Separate E settings undefined.

    Board SKR 1.3, with TMC2208 drivers (5), Marlin bugfix 2.0, dual_endstop code.

    As you can see, nearly TWICE the movement desired for X1, and nearly HALF the movement desired for Y1.

    I have XYZ and E0,E1,E2 drivers defined. (Not X2/Y2).

    The ‘print’ movement is jerky, which can be obvious from having opposite end motors moving at different rates.

    What should I look for in the Marlin code?

    TIA

    GlenB

     

     

    #111999

    Ryan
    Keymaster

    Make sure you are using 16T pulleys. Make sure they are actually tight (#1 issue at the moment around here), make sure you are asking it to move at a reasonable speed, take off the belts and verify they are all moving and in the right direction.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.