Did I fry my board?

This topic contains 30 replies, has 5 voices, and was last updated by  Wildc4t 5 months ago.

Viewing 30 posts - 1 through 30 (of 31 total)
  • Author
    Posts
  • #62894

    Wildc4t
    Participant

    Did I fry my board?

    I spent the weekend building my mpcnc. I had all the axis running and decided I was done for the evening. Right now, I’m just bolted to a board since I wanted to take it to work to finalize everything. I ziptied all my connections so I could transport it. When I had to carry it to my car this morning, I had to carry it on its side. The middle assembly went to the bottom corner (very quickly) and my LCD lit up. Not thinking much of it, I carried on. Now it’s set up where it will be for a while (at work) and I plugged in the board to power. My board just flashes (including the LCD). Should I try to reflash the board or did I toast the electronics?

    (Also I unpowered and disconnected everything from the board. Still flashes….)

    Fuses are good.

    Edit: can’t reflash, won’t stay powered on.

    Alex

    Attachments:
    1. Video.mov
    #62900

    Wildc4t
    Participant

    Here’s another video just to prove what I’m saying….

     

    Alex

    Attachments:
    1. Video2.mov
    #62922

    Barry
    Participant

    I think you killed it!

    #62942

    Ryan
    Keymaster

    Yikes. all 4 steppers generating power at the same time must have been too much for the built in protection.

    It keeps flashing like that with power and usb plugged in at the same time? If so I would say it is dead, sorry to hear it.

    1 user thanked author for this post.
    #62984

    woodknack
    Participant

    Well instead of buying another mini rambo board for $85. get 3 TB6600 drivers off amazon for $35.99 and an Arduino Uno board for $8.49 and install / Flash GRBL on the uno card. Its pretty much what the x carve and shapoko use. You can then use Easle from xcarve’s site for an easy cad cam option. I started with the marlin and Ryan’s mpcnc kit. and the power supply quit on me at the very beginning(probably just a fluke?). I ordered one of the power supplies off amazon for $18.85. So if you ordered all that stuff it would still be $20 dollars cheaper then buying just a mini rambo board for $85. And in my opinion, if you are just going to use this as a cnc router GRBL is a much better option then Marlin. I believe you can still use estlcam too. I opted to buy Vectric Vcarve desktop as you can do your cad/cam right in it and it was very easy for me to learn and there are TONS of how to videos on the net for this software. Its the goto software for cnc wood routers. If you decide to go this route I found this video which helped me with my setup. Made this sign for inlaws to put on there camp road with this new setup. Love it.

    Attachments:
    2 users thanked author for this post.
    #63002

    woodknack
    Participant

    Also just for grins. Check all your fuses on your rambo board.

    #63009

    woodknack
    Participant

    https://youtu.be/q8EyXu_gBtU

    Here is my setup making a different camp sign.

    #63089

    Wildc4t
    Participant

    Woodknack:

    Thank you so much for the detailed response! Right now, my goal is to get the setup as described and designed by Ryan and then modify it as I learn more. I honestly think I’ll be trying a GRBL-based system in the future so I really appreciate the links and the information. I’m sure I’ll be referring to them in the future.

    Ryan:

    I appreciate the quick response, and I think my new board will arrive today. Thanks for shipping it out so quickly.

    -Alex

    1 user thanked author for this post.
    #63096

    Ryan
    Keymaster

    Woodknack, beautiful sign! I was talking about GRBL a few days ago. Now that marlin is using the same motion equations, what else do you like about it? I thought that was the major difference? I don’t have a board it can run on…anymore, but might soon. I am thinking about offering it as an option if it is worth it. I really have next to zero experience with it, so maybe some highlights if you have a few minutes.

    1 user thanked author for this post.
    #63107

    Tim
    Participant

    I Love my MPCNC

    What i like about GRBL is UGS Universal G-code Sender over 3 years now with  laser and Estlcam with the Roland MDX-40A and Shop Bot tabletop.  XYZ touch off with MPCNC. Use Christians Foil for touch off surface and very cheap and fast. you;can use Estlcam for firmware with the hardware. if you want It is also what i have my laser setup with so virtually no setup changes between machines I  like separate machines it never fails I switch over and then I need the other cutter ,laser,print head back.  When I set up my MPCNC all the software was different and Iv been using Estlcam since ver8 and love it but repieter host was nothing but frustration for me.

    I have never owned a 3D printer so I’m sure if  did I would feel just the opposite I understand keeping things uniform for trouble shooting keeps the headaches down 🙂  I used your setup till I got my bugs worked out and am very happy with it now GRBL.  I do wish i could try our end stops but I only have a Mini Rambo and i will put that on a MP3DP

    1 user thanked author for this post.
    #63169

    woodknack
    Participant

    Pic of the sign I was making in the video.

    #63177

    Tim
    Participant

    Love the fonts and how they cut. How did you finish the sign?

     

    #63221

    woodknack
    Participant

    I sealed the whole board after it was done cutting, let that dry then used a paint brush and filled in all the fonts. let that dry over night then sanded the whole thing and put 3 coats of clear on it. Simple as that. 😉

    1 user thanked author for this post.
    Tim
    #63222

    woodknack
    Participant

    Woodknack, beautiful sign! I was talking about GRBL a few days ago. Now that marlin is using the same motion equations, what else do you like about it? I thought that was the major difference? I don’t have a board it can run on…anymore, but might soon. I am thinking about offering it as an option if it is worth it. I really have next to zero experience with it, so maybe some highlights if you have a few minutes.

    The reason I switched is #1 the marlin post processor for vectric vcarve that someone made didn’t always act right. Vcarve already has post processors for GRBL in inch and metric installed. #2 though I liked using the LCD display and not having to have a computer in the shop to run my files, I quickly noticed my z-axis drops when not under power from the steppers. so I would have to get my file ready to go and manually screw my z axis and hold the coupling by hand until I started my file. And I’m not a fan of repetier host even as a 3d print software. With GRBL I use universal gcode sender to run the machine. I’m now able to use the software to bring my z down at whatever increment I need to and zero it before I start my job.

    For me it just much easier (grbl). Also right in USG you can adjust your settings and hit save and it sends it right to the Uno board and saves it. No more trying to go into marlin firmware to make a change then reflash the card.  Also with this setup, you’re not just limited to USG to run the machine. You can use estlcam, easle from xcarve or shapoko’s carbide 3d software free. and many more. Most cnc routers on the market(hobby ones) run grbl or mach3  it seems.

    Also those tb6600 drivers are cheap (like $39 for 3 of them) and have dip switches to adjust your steps and your voltage (very simple). A good power supply and a uno board and you ready for action at much less money then the price of a mini rambo board.

    I’m having fun and learning a ton. And I’m just scratching the surface. Thanks for your design. It has my wheels turning on maybe making another machine of my own design later on.

     

    #63274

    Wildc4t
    Participant

    Good morning everyone,

    Good news and bad news:

    I got the new board on Friday, but my MPCNC is at work. Came in first thing this morning and got everything plugged in…. the new board flashes just like the old board. Immediately, I took the old connector off the power supply end and re-stripped the wires and used the new connector (thinking I didn’t have enough electrical contact in the connector). Same result.

    So, at this point it has to be the power supply, right? If so, the good news is that I probably have 2 good mini-Rambo boards… the bad news is that I have to wait a couple more days to find out if the brick is what’s causing the issue.

    Alex

    #63281

    woodknack
    Participant

    Good morning everyone,

    Good news and bad news:

    I got the new board on Friday, but my MPCNC is at work. Came in first thing this morning and got everything plugged in…. the new board flashes just like the old board. Immediately, I took the old connector off the power supply end and re-stripped the wires and used the new connector (thinking I didn’t have enough electrical contact in the connector). Same result.

    So, at this point it has to be the power supply, right? If so, the good news is that I probably have 2 good mini-Rambo boards… the bad news is that I have to wait a couple more days to find out if the brick is what’s causing the issue.

    Alex

    My power supply that came in part of Ryan’s kit quit very early in the build. I quickly bought a better one that was suggested by someone on this forum “Barry”(powersupply)But I got no power what so ever to the board. All you have to do to test the power is, plug it in and put a mutli meter on the 12v end and see if it reads anything. I doubt that is your problem because when you plug it in you said your board lights up and if your power supply was dead then nothing would light up.

    Try unplugging all your axis’s then power it back on and see if you get the same issue. Are you using the lcd screen? you may have your wires backwards on the lcd or board.

    look at these photos and make sure your power “color” wire is right on the board and look at the direction of the lcd cable . look close there is a red wire showing direction.

    #63285

    woodknack
    Participant

    Try this. unplug all your axis’s (make sure there is no power going to the board). Then make sure your 12v power cable is plugged in the right direction on your board. Then make sure your lcd is plugged in right. I would unplug the lcd from the board and the lcd and check the cable then plug them back in, make sure they are in all the way. Look at the photo and which way the red is plugged in on both the LCD and the board. Then with NO axis’s plugged in, power on your board and see if your lcd come to life. Then we can go from there.

    I would first take your multimeter and make sure you are getting 12 volts out of your power supply. Mine just died all together but yours may have done something different and is not putting out enough volts? I hate to say this but I don’t think those power supplies are very good. If that seems to be the issue get the one that I listed above. Barry suggested it to me awhile back and it has worked flawlessly. Matter of a fact I bought another one for another project. 😉

    1 user thanked author for this post.
    #63286

    Wildc4t
    Participant

    Woodknack,

    I unplugged everything on the board (including the LCD) and applied power. I don’t have my DVOM here at work, it’s on my desk at home. But yes, white is on the left and red is on the right (corresponding to red (+) white (-)). Also, I’d like to note that everything worked fine at first. As in, the first time I fired everything up I was able to move each axis.

    If it’s not the board, then it has to be the PSU… I ordered the same one on amazon since buying from this store would mean I’d pay as much in shipping as I would for the PSU.

    Maybe I should change the topic of this post to “Did I brick the brick?”

    Alex

    #63287

    Wildc4t
    Participant

    Woodknack,

    Refer to the first two videos in this post that I posted. You can see the wiring is correct and the new board is acting identically to the one in the video. The most concerning point is that the power supply is cycling on and off as indicated by the green power light on the board. I thought I had fried the board, but this board is acting the same.

    Alex

    #63289

    woodknack
    Participant

    Well, check your power supply with a multimeter. Like I said mine just up and quit very early in my build. If you do a search on those power supplies they DON’T have very good reviews. That is why I opted to go with what Barry suggested and I wouldn’t look back now.

    #63338

    Wildc4t
    Participant

    Never really had to mess with these power supplies, but I brought my DVOM to work…

    Not connected to the board I get 12.3-12.5V DC.

    Connected to the board I get a range from 5V – 11V (nothing else is connected).

    I’m surprised that I get a pretty consistent 12v out of the PSU… something inside it must be cycling when a load is applied? This really hasn’t confirmed my diagnosis of a bad PSU since the voltage could just be fluctuating as the board powers up and then powers off. It’s still early for me, but I guess I won’t know for sure until I throw another PSU (arrives this evening) onto one of these boards.

    Alex

    #63341

    woodknack
    Participant

    Keep us posted. 😉

    Did you order the same power supply as you had or a different one?

    1 user thanked author for this post.
    #63366

    Wildc4t
    Participant

    I ordered the same PSU.

    Honestly, I’m so motivated to get this project up and running that I ran out of patience. Moment of truth should be tonight when I get home testing PSU #2 on Board #1.

    Thanks for the support.

    I promise I’m not ignoring your input, I just wanted to get the thing running on all the recommended hardware first. I will probably end up with GRBL and the PSU that you’ve been having luck with, it will just be shortly after I get all the kinks out. Maybe I’ll try out the Einsy board and get some of that nice quiet Trinamic goodness. Who knows!

    My theory is this: if I go with the recommended setup, I’ll have a much larger pool of people to help me diagnose and troubleshoot if things go wrong. Once I know the machine is mechanically and electrically sound I’ll have a starting point to start tweaking the hardware. Going after hardware that few people have experience with right off the bat will likely cause a ton of frustration.

    Alex

    #63369

    Ryan
    Keymaster

    My theory is this: if I go with the recommended setup, I’ll have a much larger pool of people to help me diagnose and troubleshoot if things go wrong. Once I know the machine is mechanically and electrically sound I’ll have a starting point to start tweaking the hardware. Going after hardware that few people have experience with right off the bat will likely cause a ton of frustration.

    😀

    #63372

    Wildc4t
    Participant

    I was in such a rush to get home and try the new PSU that I forgot the connector and my wire strippers…. managed to get it prepped with a sharp knife and touched the leads EXTREMELY carefully to the board.

    NO MORE FLASHY FLASHY! So, I’ll take PSU #2 into work and throw PSU #1 in the garbage.

    Anyone want a mini-Rambo? lol

    Alex

    #63391

    woodknack
    Participant

    I wouldn’ throw out your other power supply. I’d keep it. You can use the power cord for the power supply I showed you when this one quits or goes screwy. 🙂

    #63402

    Wildc4t
    Participant

    Thanks everyone for the help!

    It’s Alive!

    1 user thanked author for this post.
    #63404

    Ryan
    Keymaster

    Alive and the drawings look great, glad you stuck with it.

    1 user thanked author for this post.
    #63405

    Wildc4t
    Participant

    @Ryan

    Honestly, it was a blessing in disguise that the machine was down for a little while. I got to make custom length harnesses, wire it up the way I wanted and do a lot of the little stuff that I would have skipped over had it been running immediately. lol

    #63406

    Ryan
    Keymaster

    Sweet! This sort of thing can go either way, some get really irritated, some find other things to spend time on. It has been a rough few days I am super stoked to break the streak and finally have someone that is satisfied. I /we are doing our best, but for some that isn’t enough.

Viewing 30 posts - 1 through 30 (of 31 total)

You must be logged in to reply to this topic.