computer requirements and software

New Home Forum Mostly Printed CNC – MPCNC Advice – MPCNC computer requirements and software

This topic contains 57 replies, has 6 voices, and was last updated by  Ryan 9 months, 1 week ago.

Viewing 30 posts - 1 through 30 (of 58 total)
  • Author
    Posts
  • #53401

    John R Draxler
    Participant

    I have an old windows xp machine. I have found that I cannot run the later versions of estlcam. I installed a real old version but there are not settings or anything in there. I have one of the original kits from you and your board etc. I also have an older windows laptop but found it hard to understand what to program into that one also. Seems most of the people doing all this already understand a lot of these programs and how to install and do the setup. I have setup an older homemade cnc router with mach 3 but have no idea if that will work here. Can you give me some fairly simple step by step idea of what I need for a computer and what software it takes to run this.

    #53404

    Ryan
    Keymaster

    If you are using the old laptop to run the machine that is fine but you can use your good computer to do your CAM work on.

    If that isn’t an option you can start asking which setting you don’t understand specifically and we can help. There really shouldn’t be many differences in the actual setup provided you are using a copy of estlcam that has the marlin settings. If that isn’t the case you will need to find a way to update or nothing will be easy.

    This page is where most are actually learning from, https://www.v1engineering.com/assembly/software/ the crown tutorial page linked at the end should have all the info you need. That would be an excellent page to compare to.

    #53521

    John R Draxler
    Participant

    using windows 7 on laptop, repetier hose version 2.0.5

    It says I don’t have the proper driver for the device

    what do I have to do to get the computer to recognize the router

    #53526

    Ryan
    Keymaster

    Did you install the arduino IDE?

    https://www.v1engineering.com/assembly/software/

     

    #53541

    John R Draxler
    Participant

    yes, arduino is installed on the computer. do I have to open it or have a file loaded in repetier for the software to recognize the router.

    I open repetier and try to connect and that is when it tells me the comm port don’t exist

    I opened the control panels and the device is unknown device, no drivers

    #53544

    Ryan
    Keymaster

    In repetier, if auto does not work for the com port, what others are listed in the drop down in the setting panel in repetier? What is your buad rate set at?

    #53549

    John R Draxler
    Participant

    as far as port choices there is only auto

    #53562

    SquidPlan
    Participant

    Just to rule out bad cords (I’ve had my share) did you try using a different USB cable?

    #53580

    John R Draxler
    Participant

    when I go on my computer and open the devices and printers window, there is an icon for USB2.0 serial and it has the little tiny yellow triangle and ! in it. When I unplug the usb to the router this icon disappears and then reappears when I plug it back in. When I click that icon the window opens and for General everything is unavailable or unknown, under hardware … Port_#0003.Hub_#0003.

    device status says the drivers for this device are not installed

    #53581

    Ryan
    Keymaster

    What control board and where did you buy it from?

    #53582

    John R Draxler
    Participant

    The control board is from MPCNC, one of the earlier kits you sold

    #53583

    Ryan
    Keymaster

    Ramps, Mini rambo, or rambo? You bought it from me? I ask because some older Ramps not from me do need a special driver.

    #53601

    John R Draxler
    Participant

    Should be the ramps from you. I bought the complete kit.

    #53602

    Ryan
    Keymaster

    Can you try unplugging the Ramps board, reboot the computer, Reinstall the Arduino IDE, make sure you install the drivers it comes with. I would say reboot again, then open repetier, plug in the ramps to the usb, with nothing else connected to the ramps stack. See if repetier has some com port options in “printer settings”. Try ever single USB port on the laptop. If it is really old Like updated to windows 7 old I have a feeling this is a usb baud rate issue.

    Can you also list the values for all the other settings on that settings panel, or a screen shot of it.

    #53648

    John R Draxler
    Participant

    I have done what you said and still nothing

    the laptop does have windows 7 home……. do I need to upgrade the computer?

     

    the baud rate showing in the settings window is 25000

     

    #53653

    Barry
    Participant

    What com port are you using?

    #53667

    John R Draxler
    Participant

    the only choice that showed up was auto detect

    the laptop has 3 usb ports and all give the same result

    #53723

    Bill
    Participant

    Fire up Device Manager and look under COM ports. The Arduino is likely to be COM4 or higher.

    #53799

    Ryan
    Keymaster

    John’s screen shot. Anyone have any ideas? It is USB 2.0 so it should be fine otherwise right?

     

    Attachments:
    #53802

    Al Quentin
    Participant

    John’s screen shot. Anyone have any ideas? It is USB 2.0 so it should be fine otherwise right?

    Not sure if this will help you track down your issue John,  but for both my XP and Win7 uses the Arduino, when seen, shows up under Ports (Com & LPT) – not USB, in Device Manager.  In the XP case, it’s picky about the boot sequence. If I fire up the program first (Print-Run), the only port showing (COM3) never sees the Arduino when plugged in. If I plug in the Arduino first and then fire up the program, the Arduino can be connected to via an additional port (COM5) that shows up. With both my XP and Win7 uses, Ports(COM & LPT) doesn’t show up at all in Device Manager unless the Arduino is powered up and seen.

    1 user thanked author for this post.
    #53803

    John R Draxler
    Participant

    do I have to open the arduino ide program at all?

    #53807

    John R Draxler
    Participant

    I should mention that i am a Mac person, know them inside out……. windows…. quite lost as to all the com port stuff and whatever else goes on so I struggle my way through all this because of it.

     

    #53820

    Ryan
    Keymaster

    You can use a MAC.

    No you don’t need to have arduino open but you should have at least opened it once to make sure the drivers loaded.

    #53823

    John R Draxler
    Participant

    I can use a Mac????

    what programs can I use to run the router?

     

    #53824

    Ryan
    Keymaster

    Any program that runs a 3D printer, repetier, cura, matter control. All the program does is dump Gcode.

    #53825

    John R Draxler
    Participant

    OK, I use Cura on my iMac to run my Lulzbot Taz6 3d printer

    anybody got settings and all for me to input into Cura? And what edition of Cura should I use?

    is there anything else I need to get connected?

    #53826

    Ryan
    Keymaster

    You don’t need settings, you are not slicing anything. You just need to connect and send it your gcode that you made with your CAM program.

    You can follow my getting started page word for word, even using repetier. The first line has MAC instructions if you still have issues.

    #53831

    John R Draxler
    Participant

    I am excited, can you post a link to the portion for mac where you have instructions?

    #53837

    Ryan
    Keymaster

    There should be no difference. https://www.v1engineering.com/assembly/software/

    On the first line there is a highlighted sentence for older MAC’s.

    #53865

    John R Draxler
    Participant

    the link that Cody shows is for some chinese format something and downloads as a   .exe file……….. not a mac thing.

    can someone explain this to me

     

     

    =============================Cody wrote

    I had to do two things on my Mac to let Repetier control my Ramps:

    Install the driver found here:

    http://wch.cn/downloads.php?name=pro&proid=5

    Reboot

    Next, using the Arduino IDE to edit the configuration.h file, search for #define BAUDRATE (cmd+F)

    Set the communication speed in baud to:

    #define BAUDRATE 115200

    You can keep the other speed in comments, just remember this: //#define BAUDRATE 250000

    =================================

Viewing 30 posts - 1 through 30 (of 58 total)

You must be logged in to reply to this topic.