Archim1.0a USB Port, LCD cables connection?

New Home Forum Mostly Printed CNC – MPCNC Advice – MPCNC Archim1.0a USB Port, LCD cables connection?

This topic contains 16 replies, has 4 voices, and was last updated by  George 3 months, 3 weeks ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #82371

    George
    Participant

    Hello,  I am looking for advise.

    1.  I did search this forum for Archim USB, but did not find the answer.
      Just received my Archim from Ryan yesterday, as per Ultimachine github page I installed “Additional Board Manager URL”, selected Archim board, but Arduino still cannot connect to board since the Port is not showing up. The power LED is flashing so is LCD panel.

    What am I missing?

    2.  Also I cannot find anywhere what is the correct orientation of ribbon cables for Archim, as there is no marking on PCB for pin1.
    I found two pictures:  one showing red stripe (pin1) towards the Atmel chip, the other (on Ryan’s website) showing cable 1 red stripe pointing towards Atmel chip, but cable 2 red strip on the side of USB connector.
    Which one is correct?

    Any help is appreciated!  Thank you.

     

    #82372

    Ryan
    Keymaster

    Hi, try my firmware and my flashing instructions, here, here.

    The lcd ports are labeled 1 and 2 but the “1” pin on each can be harder to see. I am working on a clear diagram but for now know you can not break anything by plugging the lcd in wrong.

    #82581

    George
    Participant

    Hello Ryan,

    still no luck.  As per your instructions I did download new Marlin2 FW, Updated Arduino to 1.9 (beta), installed the library, ultimachine URL.  Archim still shows in Arduino, but the USB port does not show up – please see screenshot. (Same as I was running Arduino 1.8 yesterday)
    LCD and Power LED keep flashing. Both Exp1 and Exp2 are connected so the pin1 (stripe) is next to Atmel chip.

    I am running MacOS 10.13.
    Perhaps there is some new Arduino USB driver which needs to be loaded in order to work with Archim?

    Thank you.

    #82587

    Ryan
    Keymaster

    Crap you are on a MAC I have no idea what it could be. Some had buad rate issues on all boards, but I have no idea if that is still a thing.

    But from the picture I have on the ultimachine page the red stripe goes away from the chip.

    #82590

    George
    Participant
    1. Normally, I’d change baud rate in Arduino Tools>Serial Monitor.  I could do that in the past when I had Arduino Mega connected.
      Cannot do that on Archim though, since the USB port is not even showing.
      Will try tomorrow on Windows machine.
    2. Did connect LCD ribbon cables as you suggested, both pin1 (red stripe) away from Atmel chip, near the USB connector.  The LCD stopped flashing, the power LED is still flashing.
    #83035

    George
    Participant

    Hello Ryan,

    tried to connect it to Windows 7 machine with same results – unable to select any port whatsoever.

    Interestingly, Marlin file in Archim shows ‘Archim on Com3’ in bottom right corner.

    Correspondingly, on MacOS, it shows ‘Archim on /dev/cu.usbmodem1421’.

    Power LED keeps flashing on both MacOS or Windows.

     

    I am at loss, please advise.

    The boards are tested at Ultimachine, right?

    #83036

    Ryan
    Keymaster

    They test and flash the boards and then I test and flash my firmware, ever one.

    If the power light is flashing the board has no, or incorrect firmware. Did you press the erase button at any point?

    You need power and usb to flash, just to be clear, it will flash and then verify the flash, the Archim take much longer to flash but show a progress screen while doing it.

    #83094

    George
    Participant
    1. Good to know it was tested then.
    2. I was expecting that board has no FW.  The trouble is how do I connect to it to flash FW, if serial USB is not showing?
      I am afraid I do not even know there is erase button.  After a couple of tries, I did try to press the Reset button at the edge of the board next to USB connector though. Hope that did not messed up anything.
    3. Yes, I did power it up with 12V/6A power supply, then plugged in the USB cable.

    What should I do now?

    #83096

    Ryan
    Keymaster

    Do you have any other arduinos you can use top verify your hardware is ready?

    I have zero suggestions for a mac and windows 7 is extremely old but I assume it works. I have no idea what to do at this point.

    I really can’t help on the MAC, but if you go back to the windows machine I can try to help there. Exactly what happens when you plug it in the usb and power and open the Ardiuno 1.9 on the windows machine.

    From the wiki win 10 and mac have the drivers built in, win 7 needs drivers.

    USB Driver

    • Windows 10, Linux and Mac use CDC interface and have hardware driver built in.
    • Windows legacy can use hardware driver: File:RAMBo USBdriver.zip
    #83160

    Jim O’Connor
    Participant

    I was able to install the dual endstop firmware on my Rambo 1.4 from 10.13 on a new MBP.
    I had to reboot with the USB cable attached to the Rambo.

    1 user thanked author for this post.
    #83161

    Ryan
    Keymaster

    I had to reboot with the USB cable attached to the Rambo.

    Interesting, if this is the case I will add it to the Firmware page. let me know if this works George.

    #83191

    George
    Participant

    Tried few more things tonight:

    1. Connected to Win10 – exactly same results: Port is not available at all.
    2. Tried to reboot whole system (MacOS, Win7, Win10) while Archim plugged in before power on – still same results: Port is not available
    3. For sanity check, I plugged in my old Arduino Mega2560 – Port shows up properly (see attached screenshot).

    Since I am unable to connect to USB port on Archim, while all the proper files and drivers are loaded, using MacOS, Win7, Win10, all showing same behavior, I strongly suspect there is something wrong with the board I received last Saturday. Perhaps it is defective USB port.

    Please advise.

    #83193

    Ryan
    Keymaster

    On a windows 10 machine arduino 1.9 installed, nothing shows up, under the com port? When you plug in the usb it does not make a sound? What lights come on and exactly what to they do? Using the supplied USB and powering both 12v, logic and stepper ports? All the fuses are still good?

    Windows 10 I can easily trouble shoot.

    I highly suspect there is some small step you are missing. If you don’t mind as a last ditch effort before money is spent, can you just verify the above, and try the reset below. Kinda have a feeling the MAC messed with it and you need to reset it.

    USB only should show nothing, Power to the first two ports you should get a green light, green light still on adding the usb you should get the windows 10 sound. At that point I can select the correct com port in arduino. If you do not see that while powered you can hold the erase button down and press the reset button, let them go, at that time you should definitely have a com port. In device manager it will show as a “ports” “Bossa”.

     

    #83280

    Bill
    Participant

    Try also a different USB cable. I suspect when Ryan tests the boards he uses his own cable, not the supplied one.

    1 user thanked author for this post.
    #83448

    George
    Participant

    Hello Ryan,

    1. On Win10, Arduino 1.9, connected before power up, nothing shows under com port, which is grey.
      (My Arduino Mega2560 shows COM3 port.)
    2. No sound whether plugging or unplugging USB cable.
      (My Arduino Mega2560 generates sound response from Win10 machine.)
    3. The PWR LED comes up flashing when I power external power source. No light without external power.
    4. Powering both logic and stepper circuits with 12V/6A.
    5. All three fuses are still good.
    #83456

    Ryan
    Keymaster

    If you do not see that while powered you can hold the erase button down and press the reset button, let them go, at that time you should definitely have a com port. In device manager it will show as a “ports” “Bossa”.

    #90342

    George
    Participant

    Just an belated UPDATE (was traveling, unable to work on this):

    As Bill hinted, it was indeed defective USB cable I got with Archim.  (Somehow, it did not occur to me that brand new cable included with board will not work.)

    Used my old USB cable and voila, I can connect now.

    Had some issues with something like ‘unable to find directories’ since I did it on my MacOS.  Friend managed to flash the board on Windows, now my motors move, still need to perform calibration, especially Z axis which seems to be moving 5x as much.

    Also my LCD still does not show anything beyond lit blank screen.  Will work on that too (saw some other posts regarding correct LCD control board selection).

    BTW, do we have definite work how the LCD wiring should be on Archim?  It looks there are two short bold lines on chip side of the connectors, perhaps marking pin1?

    Please let me know.

    ____________________

    I am not EE nor CS, but its is strange that Arduino has such a complex labyrinth of directories, folders and libraries.  No consistency whatsoever.
    The problem is amplified and becomes un-manageable on MacOS.
    There is a huge amount of these types of issues available by search on web.  It looks like it was designed by some government entity ;-).
    Just curious, is someone working on streamlining this notorious complexity?

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.