archim board trouble

This topic contains 23 replies, has 4 voices, and was last updated by  AZ_Ron 4 months ago.

Viewing 24 posts - 1 through 24 (of 24 total)
  • Author
    Posts
  • #83488

    brian langermeier
    Participant

    Just got a new archim board this week for a brand new build. hooked everything up and installed repitier host.  was able to get it to connect but only x1 and y1 motors would turn when i manually moved using the repitier control panel, no x2 or y2.  also the lcd screen lit up blue but just a solid block. no letters.

    so i have gone through the firmware instructions step by step a couple of times trying to upload the Marlin Mpcnc_archim1_t8_16t_LCD_Dualendstop firmware from github using arduino 1.9 and im getting an error when compiling

    Arduino: 1.9.0-beta (Windows 10), Board: “Archim”

    panic: interface conversion: error is *exec.Error, not *exec.ExitError

    goroutine 1 [running]:
    github.com/arduino/arduino-builder.(*ArduinoPreprocessorRunner).Run(0xb1d904, 0x118a6000, 0xb1d904, 0x13ac9ec0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/preprocess_sketch.go:129 +0x907
    github.com/arduino/arduino-builder.(*PreprocessSketchArduino).Run(0xb1d904, 0x118a6000, 0xb1d904, 0x0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/preprocess_sketch.go:69 +0x2a3
    github.com/arduino/arduino-builder.runCommands(0x118a6000, 0x11784b68, 0x1, 0x1, 0x1, 0x11784b68, 0x0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:207 +0xc1
    github.com/arduino/arduino-builder.(*PreprocessSketch).Run(0xb1d904, 0x118a6000, 0xb1d904, 0x0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:154 +0xb6
    github.com/arduino/arduino-builder.runCommands(0x118a6000, 0x11a5bde8, 0x22, 0x22, 0x1, 0x0, 0x0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:207 +0xc1
    github.com/arduino/arduino-builder.(*Builder).Run(0x117fbf0c, 0x118a6000, 0x82, 0x11814090)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:125 +0xb3a
    github.com/arduino/arduino-builder.RunBuilder(0x118a6000, 0x82, 0x11814090)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:223 +0x29
    main.main()
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/arduino-builder/main.go:406 +0x753
    C:\Users\blang\Downloads\arduino-1.9.0-beta-windows\arduino-PR-beta1.9-BUILD-96\arduino-builder returned 2
    Error compiling for board Archim.

    at this point I am not able to connect any more using repitier host , it now tells me “com port does not exist”

    green light on archim board is solid green

    anyone have a clue what im doing wrong?

     

    Thanks, Brian

    #83489

    Ryan
    Keymaster

    That is completely unfamiliar. You followed my instructions step for step exactly?

    Windows 10? Full arduino version 1.9, not the windows app?

    The one thing that is really striking me is how long your file locations are, try doing it with the marlin folder directly on the main c: folder.

    #83490

    Ryan
    Keymaster

    Oh wait, you clicked arduino-builder.exe, use arduino.exe

    #83492

    brian langermeier
    Participant

    yes windows 10.  full downloaded version of arduino 1.9, moved marlin directly to the c:// directory. same result

     

    clicked on the arduino.exe program to start. not sure where the arduino builder is coming from in the error message

    #83494

    Ryan
    Keymaster

    Same error message?

    #83495

    brian langermeier
    Participant

    yes

    Arduino: 1.9.0-beta (Windows 10), Board: “Archim”

    panic: interface conversion: error is *exec.Error, not *exec.ExitError

    goroutine 1 [running]:
    github.com/arduino/arduino-builder.(*ArduinoPreprocessorRunner).Run(0xb1d904, 0x11940000, 0xb1d904, 0x134d0540)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/preprocess_sketch.go:129 +0x907
    github.com/arduino/arduino-builder.(*PreprocessSketchArduino).Run(0xb1d904, 0x11940000, 0xb1d904, 0x0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/preprocess_sketch.go:69 +0x2a3
    github.com/arduino/arduino-builder.runCommands(0x11940000, 0x13a9a1c0, 0x1, 0x1, 0x1, 0x13a9a1c0, 0x0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:207 +0xc1
    github.com/arduino/arduino-builder.(*PreprocessSketch).Run(0xb1d904, 0x11940000, 0xb1d904, 0x0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:154 +0xb6
    github.com/arduino/arduino-builder.runCommands(0x11940000, 0x11a29de8, 0x22, 0x22, 0x1, 0x0, 0x0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:207 +0xc1
    github.com/arduino/arduino-builder.(*Builder).Run(0x118a9f0c, 0x11940000, 0x46, 0x1185a0a0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:125 +0xb3a
    github.com/arduino/arduino-builder.RunBuilder(0x11940000, 0x46, 0x1185a0a0)
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/builder.go:223 +0x29
    main.main()
    /home/jenkins/workspace/arduino-builder-all-cross/src/github.com/arduino/arduino-builder/arduino-builder/main.go:406 +0x753
    C:\mpcnc\arduino-PR-beta1.9-BUILD-96\arduino-builder returned 2
    Error compiling for board Archim.

    This report would have more information with
    “Show verbose output during compilation”
    option enabled in File -> Preferences.

    #83496

    Ryan
    Keymaster

    Are you just double clicking teh .ino file? Make sure to open it from inside arduino 1.9. (if you have a non-beta arduino build it will open instead).

    When mine compiles it says 1.9 and the build number, where yours says arduino-builder?

    Reboot your computer just to be certain.

    #83497

    Ryan
    Keymaster

    Did you unzip the arduino folder or perhaps you are running it in the zip as sometimes windows lets you?

    Your file locations just don’t seem right at all. Mine are c:\\users\\ryan\\arduino-pr-beta1.9\\…..

    Yours say github.com and home which seems like a network storage device, or from github directly?

    #83506

    brian langermeier
    Participant

    yes I did unzip the arduino folder and the clicked on the arduino.exe file in the unzipped folder.

    I did notice though that the 1.9 beta version doesnt seem to install and give you a desktop icon like version 1.8.8 does, am i missing something there

    #83507

    Ryan
    Keymaster

    No it runs self contained and does not install. What happens when you just try to verify it not upload it?

    #83508

    brian langermeier
    Participant

    same result

     

    #83509

    Ryan
    Keymaster

    Can I see a screen shot with as much of the error showing as possible?

    #83512

    brian langermeier
    Participant

    Attachments:
    #83519

    Ryan
    Keymaster

    I meant put the Unzipped marlin folder in your root directory, try that.

    Marlin 2.0 is big with many folders, that is the reason it only works with arduino 1.9 beta, the file structure was too big. You are adding at least 5 more folders deep,.

    #83549

    Bill
    Participant

    Just tried it, following the directions here. Downloaded the Arduino 1.9 beta, extracted it to a folder (in my case C:\Users\bills\Downloads\arduino-1.9.0-beta-windows\arduino-PR-beta1.9-BUILD-96). Cloned Ryans github and used a git switch to change from the master to the Archim version. Fired up the Arduino beta and added the U8glib. In File;Preferences I pointed to the Utilimachine site and added the Archim board. I then switched Board in Tools to Archim and opened the .ino file saved previously. I went to Sketch;Verify and it compiled. You likely have missed a step…

    #83551

    brian langermeier
    Participant

    ok. only thing i did not do in that sequence is the  “used a git switch to change from the master to the Archim version”

    what is that?

    #83553

    Bill
    Participant

    Ah, I’m using TortoiseGIT on my Windows machine to give a GUI to git. A Switch changes your base code from the master to a branch. In this case to Ryan’s MPCNC_Archim1_T8_16T_LCD branch. If you specified that branch in your original checkout it probably got it. If you just cloned his github then you might be trying with his 1.1.x version instead.

    #83554

    brian langermeier
    Participant

    just to be clear. i went to https://github.com/Allted/Marlin/tree/MPCNC_Archim1_T8_16T_LCD_DualEndstop and dowloaded the .zip file, unzipped it, ant then opened the marlin.ino file with arduino 1.9 beta

    #83555

    Bill
    Participant

    I just switched to 1.1.x and tried a compile:

    Arduino: 1.9.0-beta (Windows 10), Board: "Archim"
    
    In file included from sketch\MarlinConfig.h:26:0,
    
                     from C:\src\RyanArchim\Marlin\Marlin\Marlin.ino:31:
    
    fastio.h:32:20: error: avr/io.h: No such file or directory
    
     #include <avr/io.h>
    
                        ^
    
    compilation terminated.
    
    exit status 1
    avr/io.h: No such file or directory
    
    This report would have more information with
    "Show verbose output during compilation"
    option enabled in File -> Preferences.
    

    Which is not the error group you saw.

    #83556

    Bill
    Participant

    So next I tried switching to the dual endstops version, since I’d done the normal. No issue. So I downloaded the zip file instead. Extracted it to C:\Users\bills\Downloads\Marlin-MPCNC_Archim1_T8_16T_LCD_DualEndstop and loaded the .ino file and redid the verify sketch again. Still worked. 🙁

    #83557

    brian langermeier
    Participant

    ok, so i just loaded arduino 1.8.8 and it compiled successfully with that. does that offer any clue?

    #83558

    brian langermeier
    Participant

    ok, now i was able to upload to the board with 1.8.8 and it seems to be working fine. both motors turning and lcd works also.

    is there a downside to using arduino 1.8.8 instead of 1.9?

    #83606

    Ryan
    Keymaster

    No but that is very odd, that should not work. It did so leave it as is, what version of arduino is used has zero effect on the actual firmware once it is on the board!

    #89428

    AZ_Ron
    Participant

    Well Hell’s Bells… This is almost identical to the issue I’ve been fighting all day…

     

    Here’s the Debugging text I got each time I was trying to compile.

    I just now read Brian’s victory!!! I’m going to try Arduino 1.8.8 now and see what happens. I spent some time earlier making every effort to completely get rid of 1.8.8… Ahhhh… 1 step forward, 2 steps back!

    Archim-Error

    Attachments:
Viewing 24 posts - 1 through 24 (of 24 total)

You must be logged in to reply to this topic.