Adding a laser

This topic contains 5 replies, has 3 voices, and was last updated by  Aaryn 2 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #93076

    Thierry Deux
    Participant

    Hello, I’ve got an 8w diode Acan laser I’d like to put on my CNC. https//imgur.com/a/6j0Hu40

    Am I right in assuming I can take the 3 wire off the current board (the controller not ths laser board) and put it on my Rambo board? Using the MX2 pins +, -, and 45 for the one that’s currently labeled “S”.

    What do I need to change in the Marlin firmware and is there anything I need to do in Fusion360 to use the laser or am I better using a different program?

    So many questions haha. Any help is appreciated. Thank you!

     

    #93115

    Ryan
    Keymaster

    Have a look here, and see if it helps much.

    Lasers

    Pin change in the firmware, and Fusion is probably not the right choice for a laser, yet.

    1 user thanked author for this post.
    #93136

    Thierry Deux
    Participant

    Yup, had a look through there. I think I understand the wiring and firmware portion. Just need to read up on the software/control bit now. Thank you.

    #93221

    Thierry Deux
    Participant

    Ok, I updated the firmware on the RAMBo board un-commenting #define SPINDLE_LASER_ENABLE. The ACAN laser I’m using is 12v so I’ve got that wired to FAN 0. I have the control pin from the laser wired to pin 45 on RAMBo. pins_Rambo.h has 45 listed as the PMW pin.

    I used ImagetoGcode to write some code and it seems like everything is fine except it’s not controlling the power of the laser. the gantry moves as I would expect. An M106 command starts the laser at full blast including the cooling fan on it. Repertier host throws an error when it sees an S** command.

    Also, turning M106 without running a gcode file turns the laser on full blast. It seems to me it should start the laser cooling fan but not the laser itself without some sort of signal.

    I’m assuming I’m doing something wrong with the control pin.

    Any ideas would be appreciated.

    #93349

    Ryan
    Keymaster

    It is best not to use the marlin laser controls right now. The regular fan control with the delay commented out is the best we have right now.

    #93380

    Aaryn
    Participant

    An M106 command starts the laser at full blast including the cooling fan on it. Repertier host throws an error when it sees an S** command.

    Also, turning M106 without running a gcode file turns the laser on full blast. It seems to me it should start the laser cooling fan but not the laser itself without some sort of signal.

    I’m assuming I’m doing something wrong with the control pin.

    Any ideas would be appreciated.

    The laser should NOT be getting power through your Rambo.  It should have a dedicated plus and minus wire for power and should be on.  The cooling fan should be on full speed the entire time.  I could be reading your message wrong but it sounds like the laser is powered up only when you use M106.  That is not right.

    Then you should have the control wires going from the Rambo to the TTL pins on the laser.  That is what should control the on/off and brightness of the laser.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.