9mm GT2 belt source? Will 6mm work?

New Home Forum LowRider Hardware Development – LowRider 9mm GT2 belt source? Will 6mm work?

This topic contains 4 replies, has 3 voices, and was last updated by  George Vaccaro 4 months, 4 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #89677

    George Vaccaro
    Participant

    Anyone have a good source for the 9mm GT2 belt?  Looks like it’s $30 on Amazon and more importantly it takes a while for shipping.

    Yesterday I spent about 10 hours expanding my table but while I was prepared for the expansion in the x-axis (left the rest of the belt spooled up at one end) I didn’t make similar preparations for the y-axis which I mistakenly thought was long enough and is instead about 10 inches short on each side. 🙁

    Also, will 6mm work ($10 and Prime) or is it not worth the risk?

    Btw, I’ve got 2 lightly used 44″ tubes if anyone wants them.  I paid a fortune for them but I’ll obviously let them go under market price.  I’ve got a shipping tube from my 60″ tubes I can cut down and use to ship them.  Lmk if anyone is interested.

    Thank you!

    #89708

    Ryan
    Keymaster

    For the Y axis you can just move up the stop blocks until you get the belts in the mail. 6mm will work in a pinch but If you have to buy some only buy 9-10mm.

    I should have more in stock in 26th or so.

    2 users thanked author for this post.
    #89784

    George Vaccaro
    Participant

    Thanks Ryan.  For now I have the original length mounted so it’s usable, I just have a design that will take advantage of the full sheet size so I can’t cut it yet…  I’ll be patient and wait. 🙂

    #89800

    Barry
    Participant

    Hey George, while you can, take pictures of all the stuff under the plastic.  After a few jobs, it’s all going to be the same shade of wood dust, so the pictures will help finding stuff.  😉

    1 user thanked author for this post.
    #90099

    George Vaccaro
    Participant

    🙂

    I’ve already cut a bunch of stuff and I’m not seeing an accumulation yet.  Maybe my dust collection is working better than average?

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.