Reply To: Z-axis Still giving me a problem after everything

New Home Forum Mostly Printed CNC – MPCNC Troubleshooting – MPCNC Z-axis Still giving me a problem after everything Reply To: Z-axis Still giving me a problem after everything



Hey guys thank you all for the responses!

After everything I’ve tried I hate to be too quick to jump to saying it is fixed, but I have run extensive tests and no failures over about 13 cuts which beats all past records.

@P3DCNC & @vicious1 I was running the tests faster than my normal cut speeds hoping to narrow down my issues quicker. I am well aware that 510 mm/m is the absolute max, but my G-code I kept posting was running a Z speed of half that and still having the problem. You guys got me on the right track though. It wasn’t an issue with my G-code (or at least it appears that it wasn’t) I just needed to lube my rod

After cleaning and lubricating the threaded rod I ran the same code I posted earlier but with the router off and just watched it run the code (3 times) no issues. So then I ran the router and did the same code (2 times mainly testing if interference from the router’s wiring could be messing up my signal) still no issues. I then ran it with my shop-vac running (2 more times to test if amperage loss could be causing an issue because they are on the same breaker) still no issues. Then I went back a few versions on my g-code where I had slightly faster Z speeds (from the 200mm/m to the 400mm/m ran this a few times) still no issues. Finally I ran a couple of actual cuts and still no plunges.

So again I don’t want to bee too hasty, but I can feel a big difference in the threaded rod’s tension when I manually adjust it, and so far so good. Fingers crossed!

Thank you all for the help! Hopefully I’m back on track now